aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-02-09 02:54:17 +0800
committersem <sem@FreeBSD.org>2005-02-09 02:54:17 +0800
commit4588b840f6f83b9a0ac678ab02ff55cab9cced25 (patch)
tree928019e9a88cf5d970fdd505684a948120f43094
parent07d4120dbec4d72ba0cabb8e6c2f21746b1a4a5b (diff)
downloadfreebsd-ports-gnome-4588b840f6f83b9a0ac678ab02ff55cab9cced25.tar.gz
freebsd-ports-gnome-4588b840f6f83b9a0ac678ab02ff55cab9cced25.tar.zst
freebsd-ports-gnome-4588b840f6f83b9a0ac678ab02ff55cab9cced25.zip
- Update to 1.0rc3
- Try to unbreak on ia64 - While I'm here: add USE_APACHE PR: ports/77081 Submitted by: maintainer
-rw-r--r--www/winhelpcgi/Makefile10
-rw-r--r--www/winhelpcgi/distinfo4
-rw-r--r--www/winhelpcgi/files/patch-bigend.h17
3 files changed, 23 insertions, 8 deletions
diff --git a/www/winhelpcgi/Makefile b/www/winhelpcgi/Makefile
index 62e898fe6c87..06fae248358e 100644
--- a/www/winhelpcgi/Makefile
+++ b/www/winhelpcgi/Makefile
@@ -6,25 +6,23 @@
#
PORTNAME= winhelpcgi
-PORTVERSION= 0.99
+PORTVERSION= 1.0r3
CATEGORIES= www textproc
MASTER_SITES= http://www.herdsoft.com/ftp/
-DISTNAME= ${PORTNAME}_0.99-3
+DISTNAME= ${PORTNAME}_1.0rc3-1
MAINTAINER= endx7@users.sf.net
COMMENT= A winhelp converter cgi program
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0rc3
GNU_CONFIGURE= yes
USE_AUTOMAKE_VER= 14
USE_GETTEXT= yes
+USE_APACHE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-pre-patch:
- (cd ${WRKSRC}; ${TOUCH} config.h)
-
post-build:
@${CAT} ${PKGDIR}/pkg-message | ${SED} -e 's:%%PREFIX%%:${PREFIX}:' > ${PKGMESSAGE}
diff --git a/www/winhelpcgi/distinfo b/www/winhelpcgi/distinfo
index bb78d76609b7..e7c01450604f 100644
--- a/www/winhelpcgi/distinfo
+++ b/www/winhelpcgi/distinfo
@@ -1,2 +1,2 @@
-MD5 (winhelpcgi_0.99-3.tar.gz) = 94cdc550d320a78a71293e4d71b8006f
-SIZE (winhelpcgi_0.99-3.tar.gz) = 305524
+MD5 (winhelpcgi_1.0rc3-1.tar.gz) = ffea4a34898b3746184d50f5d2ea38c7
+SIZE (winhelpcgi_1.0rc3-1.tar.gz) = 338589
diff --git a/www/winhelpcgi/files/patch-bigend.h b/www/winhelpcgi/files/patch-bigend.h
new file mode 100644
index 000000000000..507dcd68da6c
--- /dev/null
+++ b/www/winhelpcgi/files/patch-bigend.h
@@ -0,0 +1,17 @@
+--- libhlpaccess/bigend.h.orig Sun May 16 13:35:18 2004
++++ libhlpaccess/bigend.h Wed Jan 5 17:00:48 2005
+@@ -4,9 +4,11 @@
+ *
+ */
+
+-#if defined(__powerpc__) || defined(__ppc__) || defined(__sparc__) || defined(_AIX)
++#include <sys/endian.h>
++
++#if BYTE_ORDER == BIG_ENDIAN
+ # define BIGENDIAN /* This is a big-endian machine MSB is the first Byte */
+-#elif defined(__i386__) || defined(__alpha__) || defined(__amd64__)
++#elif BYTE_ORDER == LITTLE_ENDIAN
+ # define LITTLEENDIAN /* This is a little-endian machine MSB is the last Byte */
+ #else
+ # error Endianness undefined
+