aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:45:26 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-12-31 16:45:26 +0800
commit4643d57a224cc4121f3702e49d48575dbbeece01 (patch)
treef88339b7cfa6834f19ba8629172d15213c79f034
parentb76bfebe000e9252c2120f9a14ab372c45299b47 (diff)
downloadfreebsd-ports-gnome-4643d57a224cc4121f3702e49d48575dbbeece01.tar.gz
freebsd-ports-gnome-4643d57a224cc4121f3702e49d48575dbbeece01.tar.zst
freebsd-ports-gnome-4643d57a224cc4121f3702e49d48575dbbeece01.zip
Using output of /dev/urandom. Simply convert bytes into 8-bit
characters. WWW: http://search.cpan.org/dist/String-Urandom/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-String-Urandom/Makefile25
-rw-r--r--textproc/p5-String-Urandom/distinfo2
-rw-r--r--textproc/p5-String-Urandom/pkg-descr4
-rw-r--r--textproc/p5-String-Urandom/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 68a4b3a946b8..db1384cf7cb2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -714,6 +714,7 @@
SUBDIR += p5-String-ToIdentifier-EN
SUBDIR += p5-String-Tokenizer
SUBDIR += p5-String-Truncate
+ SUBDIR += p5-String-Urandom
SUBDIR += p5-Syntax-Highlight-Engine-Kate
SUBDIR += p5-Syntax-Highlight-Perl-Improved
SUBDIR += p5-TeX-Encode
diff --git a/textproc/p5-String-Urandom/Makefile b/textproc/p5-String-Urandom/Makefile
new file mode 100644
index 000000000000..ebd914bc10fc
--- /dev/null
+++ b/textproc/p5-String-Urandom/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: String::Urandom
+# Date created: 31 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Urandom
+PORTVERSION= 0.16
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to convert /dev/urandom to 8-bit chars
+
+RUN_DEPENDS= \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Urandom.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Urandom/distinfo b/textproc/p5-String-Urandom/distinfo
new file mode 100644
index 000000000000..00576af6c3b8
--- /dev/null
+++ b/textproc/p5-String-Urandom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-Urandom-0.16.tar.gz) = c1dc53e8483a77f3b5fa0c41ad843699420d46411ffb0b30bc4c70dd863b5139
+SIZE (String-Urandom-0.16.tar.gz) = 5115
diff --git a/textproc/p5-String-Urandom/pkg-descr b/textproc/p5-String-Urandom/pkg-descr
new file mode 100644
index 000000000000..015640296abf
--- /dev/null
+++ b/textproc/p5-String-Urandom/pkg-descr
@@ -0,0 +1,4 @@
+Using output of /dev/urandom. Simply convert bytes into 8-bit
+characters.
+
+WWW: http://search.cpan.org/dist/String-Urandom/
diff --git a/textproc/p5-String-Urandom/pkg-plist b/textproc/p5-String-Urandom/pkg-plist
new file mode 100644
index 000000000000..101e9029fbda
--- /dev/null
+++ b/textproc/p5-String-Urandom/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Urandom/.packlist
+%%SITE_PERL%%/String/Urandom.pm
+%%SITE_PERL%%/String/example.pl
+@dirrmtry %%SITE_PERL%%/String
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Urandom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String