aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2008-05-20 20:39:08 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2008-05-20 20:39:08 +0800
commit47987da86d9d681eab7d01e1b3707acad9e5755b (patch)
treece3d69c3b4edff432555bf7d18c74dd68c9c2499
parent28507f771e43c14748273e7d9eb4ccaf8b4d2cad (diff)
downloadfreebsd-ports-gnome-47987da86d9d681eab7d01e1b3707acad9e5755b.tar.gz
freebsd-ports-gnome-47987da86d9d681eab7d01e1b3707acad9e5755b.tar.zst
freebsd-ports-gnome-47987da86d9d681eab7d01e1b3707acad9e5755b.zip
- Fix permissions on directories
- Remove USE_GCC while I am here - Bump PORTREVISION PR: ports/116485 (inspired by) Submitted by: Li-Lun "Leland" Wang <llwang infor.org> (maintainer)
-rw-r--r--games/vultures-eye/Makefile3
-rw-r--r--games/vultures-eye/pkg-plist31
2 files changed, 26 insertions, 8 deletions
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 7df2d5f12844..2b2a2024f12b 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vultures
PORTVERSION= 2.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://www.darkarts.co.za/projects/vultures/attachment/wiki/downloads/${PORTVERSION}/
PKGNAMESUFFIX= -eye
@@ -23,7 +23,6 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_GMAKE= yes
USE_SDL= sdl mixer ttf
USE_BZIP2= yes
-USE_GCC= 3.2+
WRKSRC= ${WRKDIR}/${DISTNAME}/nethack
HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/sys/unix
diff --git a/games/vultures-eye/pkg-plist b/games/vultures-eye/pkg-plist
index 3cd81404fd12..d88515af42cc 100644
--- a/games/vultures-eye/pkg-plist
+++ b/games/vultures-eye/pkg-plist
@@ -134,12 +134,31 @@ bin/vultureseye
%%DATADIR%%/vultureseye
%%DATADIR%%/vultureseye.ico
%%DATADIR%%/vultureseye.png
-@dirrm %%DATADIR%%/sound
+@exec mkdir -p %D/%%DATADIR%%/save
+@exec chown games:games %D/%%DATADIR%%
+@exec chown games:games %D/%%DATADIR%%/config
+@exec chown games:games %D/%%DATADIR%%/fonts
+@exec chown games:games %D/%%DATADIR%%/manual
+@exec chown games:games %D/%%DATADIR%%/manual/img
+@exec chown games:games %D/%%DATADIR%%/music
+@exec chown games:games %D/%%DATADIR%%/graphics
+@exec chown games:games %D/%%DATADIR%%/save
+@exec chown games:games %D/%%DATADIR%%/sound
+@exec chmod 775 %D/%%DATADIR%%
+@exec chmod 775 %D/%%DATADIR%%/config
+@exec chmod 775 %D/%%DATADIR%%/fonts
+@exec chmod 775 %D/%%DATADIR%%/manual
+@exec chmod 775 %D/%%DATADIR%%/manual/img
+@exec chmod 775 %D/%%DATADIR%%/music
+@exec chmod 775 %D/%%DATADIR%%/graphics
+@exec chmod 775 %D/%%DATADIR%%/save
+@exec chmod 775 %D/%%DATADIR%%/sound
+@dirrmtry %%DATADIR%%/sound
@dirrmtry %%DATADIR%%/save
-@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/manual/img
-@dirrm %%DATADIR%%/manual
-@dirrm %%DATADIR%%/graphics
-@dirrm %%DATADIR%%/fonts
+@dirrmtry %%DATADIR%%/music
+@dirrmtry %%DATADIR%%/manual/img
+@dirrmtry %%DATADIR%%/manual
+@dirrmtry %%DATADIR%%/graphics
+@dirrmtry %%DATADIR%%/fonts
@dirrmtry %%DATADIR%%/config
@dirrmtry %%DATADIR%%