aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-12-11 16:10:49 +0800
committernovel <novel@FreeBSD.org>2016-12-11 16:10:49 +0800
commit48e3e8542a03ece0a2774c5b43258245e47cf997 (patch)
tree7a8904ad49415b270f355c19f9c61c76c1a2367f
parentf5dccc660df1e4a0d5fc4ec3d95d478d602fc993 (diff)
downloadfreebsd-ports-gnome-48e3e8542a03ece0a2774c5b43258245e47cf997.tar.gz
freebsd-ports-gnome-48e3e8542a03ece0a2774c5b43258245e47cf997.tar.zst
freebsd-ports-gnome-48e3e8542a03ece0a2774c5b43258245e47cf997.zip
Add py-designateclient 2.3.0, openStack DNS-as-a-Service - Client.
PR: 215146 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
-rw-r--r--net/Makefile1
-rw-r--r--net/py-designateclient/Makefile33
-rw-r--r--net/py-designateclient/distinfo3
-rw-r--r--net/py-designateclient/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2a6b2ea8268a..e82109606f1d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -965,6 +965,7 @@
SUBDIR += py-cjdns
SUBDIR += py-cloudfiles
SUBDIR += py-coherence
+ SUBDIR += py-designateclient
SUBDIR += py-dpkt
SUBDIR += py-dugong
SUBDIR += py-ec2-cli-tools
diff --git a/net/py-designateclient/Makefile b/net/py-designateclient/Makefile
new file mode 100644
index 000000000000..f56ad777e1dc
--- /dev/null
+++ b/net/py-designateclient/Makefile
@@ -0,0 +1,33 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= designateclient
+PORTVERSION= 2.3.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= OpenStack DNS-as-a-Service - Client
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}stevedore>=1.16.0:devel/py-stevedore \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}osc-lib>=1.0.2:devel/py-osc-lib \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.10.0:devel/py-keystoneauth1 \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}debtcollector>=1.2.0:devel/py-debtcollector \
+ ${PYTHON_PKGNAMEPREFIX}cliff>=0:devel/py-cliff
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-designateclient/distinfo b/net/py-designateclient/distinfo
new file mode 100644
index 000000000000..1d5e568edef9
--- /dev/null
+++ b/net/py-designateclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481114369
+SHA256 (python-designateclient-2.3.0.tar.gz) = f41e533cd9eda72638ce288e3dfad1e18cfc4210bd9ca248d70939ff2fccf856
+SIZE (python-designateclient-2.3.0.tar.gz) = 78445
diff --git a/net/py-designateclient/pkg-descr b/net/py-designateclient/pkg-descr
new file mode 100644
index 000000000000..6836237ea9ed
--- /dev/null
+++ b/net/py-designateclient/pkg-descr
@@ -0,0 +1,4 @@
+This is a client library for Designate built on the Designate API. It provides
+a Python API (the designateclient module) and a command-line tool (designate).
+
+WWW: http://pypi.python.org/pypi/python-designateclient