aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-11-30 06:08:18 +0800
committermaho <maho@FreeBSD.org>2006-11-30 06:08:18 +0800
commit48e41fd308ad9ddda7e1dfba3b0a88591f4a088d (patch)
tree7765e79f128d19a195269bc1bfb16e02519bd99b
parent1c11d14b37f23d60458376be3e38084717cbaa12 (diff)
downloadfreebsd-ports-gnome-48e41fd308ad9ddda7e1dfba3b0a88591f4a088d.tar.gz
freebsd-ports-gnome-48e41fd308ad9ddda7e1dfba3b0a88591f4a088d.tar.zst
freebsd-ports-gnome-48e41fd308ad9ddda7e1dfba3b0a88591f4a088d.zip
* Fix package. TMPPLIST must be overwrite at the first.[1]
* Fix pkg-message. Submitted by: Jack L.[1]
-rw-r--r--editors/openoffice-3-devel/Makefile2
-rw-r--r--editors/openoffice-3/Makefile2
-rw-r--r--editors/openoffice.org-2-RC/Makefile4
-rw-r--r--editors/openoffice.org-2-devel/Makefile2
-rw-r--r--editors/openoffice.org-2/Makefile2
-rw-r--r--editors/openoffice.org-3-RC/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/Makefile2
-rw-r--r--editors/openoffice.org-3/Makefile2
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile2
9 files changed, 20 insertions, 2 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index bd460e745fe9..5e6f08aa9b03 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -283,6 +284,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 09bfa6ee705d..15a4ad07923c 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -248,6 +248,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -281,6 +282,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index a199d3c50226..b614fa9bc1ff 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -273,7 +274,7 @@ post-install:
done ; \
done
.endif
- @cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
+ @cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} > ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type l >> ${TMPPLIST}
@@ -284,6 +285,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index bd460e745fe9..5e6f08aa9b03 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -283,6 +284,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 09bfa6ee705d..15a4ad07923c 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -248,6 +248,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -281,6 +282,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index a199d3c50226..b614fa9bc1ff 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -273,7 +274,7 @@ post-install:
done ; \
done
.endif
- @cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
+ @cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} > ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type l >> ${TMPPLIST}
@@ -284,6 +285,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index bd460e745fe9..5e6f08aa9b03 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -283,6 +284,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 09bfa6ee705d..15a4ad07923c 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -248,6 +248,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -281,6 +282,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index bd460e745fe9..5e6f08aa9b03 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -250,6 +250,7 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+ @${PRINTF} "" > ${TMPPLIST}
.if defined(WITH_MENU)
@${REINPLACE_CMD} -e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@@ -283,6 +284,7 @@ post-install:
-e 's#%%INSTALLATION_BASEDIR%%#${INSTALLATION_BASEDIR}#g' \
-e 's#%%EXECBASE%%#${EXECBASE}#g' \
-e 's#%%OOOTAG%%#${OOOTAG}#g' \
+ -e 's#%%OOOVERSION%%#${OOOVERSION}#g' \
${PKGMESSAGE}
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}