aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-09-16 23:18:42 +0800
committerdinoex <dinoex@FreeBSD.org>2012-09-16 23:18:42 +0800
commit4970d21bfd03b3760508de4c2293fdbb1c16d6ab (patch)
treea841d1d8daa29ebcd805ac2d6b490bf3eed036ab
parent55498f76b725a5f6a18fe0cd70def79ce1eda8e3 (diff)
downloadfreebsd-ports-gnome-4970d21bfd03b3760508de4c2293fdbb1c16d6ab.tar.gz
freebsd-ports-gnome-4970d21bfd03b3760508de4c2293fdbb1c16d6ab.tar.zst
freebsd-ports-gnome-4970d21bfd03b3760508de4c2293fdbb1c16d6ab.zip
- use OPTIONS_DEFINE
-rw-r--r--mail/popa3d-before-sendmail/Makefile4
-rw-r--r--mail/popa3d/Makefile22
2 files changed, 9 insertions, 17 deletions
diff --git a/mail/popa3d-before-sendmail/Makefile b/mail/popa3d-before-sendmail/Makefile
index ac88659fdfea..be44f17ac5cc 100644
--- a/mail/popa3d-before-sendmail/Makefile
+++ b/mail/popa3d-before-sendmail/Makefile
@@ -12,9 +12,7 @@ MAINTAINER= dinoex@FreeBSD.org
WITH_SMTP_AFTER_POP3= yes
MASTERDIR?= ${.CURDIR}/../popa3d
-OPTIONS?= SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" on \
- STANDALONE_POP3 "Enable standalone server mode" off \
- SETPROCTITLE "Enable setproctitle mode" off
+OPTIONS_DEFAULT= SMTP_AFTER_POP3
.if exists(${.CURDIR}/Makefile.local)
.include "${.CURDIR}/Makefile.local"
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index 7826e0877ee3..3f234464b306 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -22,21 +22,15 @@ PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
UNIQUENAME= ${.CURDIR:T}
-OPTIONS?= SMTP_AFTER_POP3 "Enable SMTP-after-POP mode" off \
- STANDALONE_POP3 "Enable standalone server mode" off \
- SETPROCTITLE "Enable setproctitle mode" off
+OPTIONS_DEFINE= SMTP_AFTER_POP3 STANDALONE_POP3 SETPROCTITLE
+NO_OPTIONS_SORT=yes
+SMTP_AFTER_POP3_DESC=Enable SMTP-after-POP support
+STANDALONE_POP3_DESC=Enable standalone server mode
+SETPROCTITLE_DESC=Enable setproctitle() support
.include <bsd.port.options.mk>
-# honor old flags
-.if defined(STANDALONE_POP3)
-WITH_STANDALONE_POP3= yes
-.endif
-.if defined(SMTP_AFTER_POP3)
-WITH_SMTP_AFTER_POP3= yes
-.endif
-
-.if defined(WITH_STANDALONE_POP3)
+.if ${PORT_OPTIONS:MSTANDALONE_POP3}
STANDALONE_SUFFIX= -standalone
PLIST_SUB+= STANDALONE_POP3=""
CONFLICTS?= popa3d-0.* popa3d-before-sendmail-0.*
@@ -48,7 +42,7 @@ SUB_FILES= pkg-message
PLIST_SUB+= STANDALONE_POP3="@comment "
.endif
-.if defined(WITH_SMTP_AFTER_POP3)
+.if ${PORT_OPTIONS:MSMTP_AFTER_POP3}
SMTP_AFTER_POP3_SUFFIX= -before-sendmail
EXTRA_PATCHES+= ${FILESDIR}/pop-before-sendmail.patch
PLIST_SUB+= SMTP_AFTER_POP3=""
@@ -58,7 +52,7 @@ PLIST_SUB+= SMTP_AFTER_POP3="@comment "
CONFLICTS?= popa3d-standalone-0.* popa3d-before-sendmail-0.*
.endif
-.if defined(WITH_SETPROCTITLE)
+.if ${PORT_OPTIONS:MSETPROCTITLE}
EXTRA_PATCHES+= ${FILESDIR}/setproctitle.patch
.endif