aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-04-21 07:09:04 +0800
committerohauer <ohauer@FreeBSD.org>2011-04-21 07:09:04 +0800
commit4989b6ed994a62bff13b52934f1626752f4a7bcd (patch)
treecef232194292eb904bb0e92f02a2280e06e18307
parent561e3604e6a540b0fb714739e20646c1f0a68675 (diff)
downloadfreebsd-ports-gnome-4989b6ed994a62bff13b52934f1626752f4a7bcd.tar.gz
freebsd-ports-gnome-4989b6ed994a62bff13b52934f1626752f4a7bcd.tar.zst
freebsd-ports-gnome-4989b6ed994a62bff13b52934f1626752f4a7bcd.zip
- fix crash due to a null pointer dereference
Thanks to Christian Peron csjp@
-rw-r--r--security/nmap/Makefile1
-rw-r--r--security/nmap/files/patch-TargetGroup.cc12
2 files changed, 13 insertions, 0 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 5340fc73877e..8b7b31a2e43d 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nmap
PORTVERSION= 5.51
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
diff --git a/security/nmap/files/patch-TargetGroup.cc b/security/nmap/files/patch-TargetGroup.cc
new file mode 100644
index 000000000000..46af812ce807
--- /dev/null
+++ b/security/nmap/files/patch-TargetGroup.cc
@@ -0,0 +1,12 @@
+--- ./TargetGroup.cc.orig 2011-01-21 01:04:16.000000000 +0100
++++ ./TargetGroup.cc 2011-04-21 00:55:50.000000000 +0200
+@@ -220,7 +220,8 @@
+ resolvedaddrs.push_back(ss);
+ }
+ }
+- freeaddrinfo(addrs);
++ if(addrs)
++ freeaddrinfo(addrs);
+
+ if (resolvedaddrs.empty()) {
+ error("Failed to resolve given hostname/IP: %s. Note that you can't use '/mask' AND '1-4,7,100-' style IP ranges", target_net);