aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-02 19:00:25 +0800
committermiwi <miwi@FreeBSD.org>2009-11-02 19:00:25 +0800
commit49a745fdf622155241a639c8b83bb834436bcd12 (patch)
tree05f520311015d264dd5a9249b999a57dca174e4f
parent9f583d146890a53f6b62b6b6b1cba63e8f9ec34a (diff)
downloadfreebsd-ports-gnome-49a745fdf622155241a639c8b83bb834436bcd12.tar.gz
freebsd-ports-gnome-49a745fdf622155241a639c8b83bb834436bcd12.tar.zst
freebsd-ports-gnome-49a745fdf622155241a639c8b83bb834436bcd12.zip
Dulwich is a pure-Python implementation of the Git file formats and protocols.
It aims to give an interface to git repos that doesn't call out to git directly but instead uses pure Python. It is based on the Python-Git module released by James Westby. WWW: http://samba.org/~jelmer/dulwich/ PR: ports/140027 Submitted by: Marco Broeder <marco.broeder at gmx.eu>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dulwich/Makefile39
-rw-r--r--devel/dulwich/distinfo3
-rw-r--r--devel/dulwich/pkg-descr7
-rw-r--r--devel/dulwich/pkg-plist69
5 files changed, 119 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9e1d96b01b0f..2ee0d2c7b031 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -288,6 +288,7 @@
SUBDIR += dprog
SUBDIR += drpython
SUBDIR += dsss
+ SUBDIR += dulwich
SUBDIR += duplo
SUBDIR += dwarfdump
SUBDIR += dyncall
diff --git a/devel/dulwich/Makefile b/devel/dulwich/Makefile
new file mode 100644
index 000000000000..ef9ba6d44d2c
--- /dev/null
+++ b/devel/dulwich/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: dulwich
+# Date created: 2009-10-24
+# Whom: Marco Broeder <marco.broeder@gmx.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dulwich
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= http://samba.org/~jelmer/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= marco.broeder@gmx.eu
+COMMENT= Pure-Python implementation of the Git file formats and protocols
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.ifndef (NOPORTDOCS)
+PORTDOCS= AUTHORS COPYING HACKING NEWS README
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|PYTHON = python|PYTHON = /usr/bin/env python|g; \
+ s|/usr|${PREFIX}|g' ${WRKSRC}/Makefile
+
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g' \
+ ${WRKSRC}/setup.py
+
+post-install:
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for n in ${PORTDOCS}; do \
+ ${INSTALL_MAN} ${WRKSRC}/$${n} ${DOCSDIR}/; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/dulwich/distinfo b/devel/dulwich/distinfo
new file mode 100644
index 000000000000..0f06474c5901
--- /dev/null
+++ b/devel/dulwich/distinfo
@@ -0,0 +1,3 @@
+MD5 (dulwich-0.4.0.tar.gz) = 579f2c60b0cdf05774da9842d5580c1f
+SHA256 (dulwich-0.4.0.tar.gz) = 03c082349f934c332df98072d711874953e1134f17504dc51c16084cf0a81565
+SIZE (dulwich-0.4.0.tar.gz) = 73140
diff --git a/devel/dulwich/pkg-descr b/devel/dulwich/pkg-descr
new file mode 100644
index 000000000000..f23c77a71b8c
--- /dev/null
+++ b/devel/dulwich/pkg-descr
@@ -0,0 +1,7 @@
+Dulwich is a pure-Python implementation of the Git file formats and protocols.
+
+It aims to give an interface to git repos that doesn't call out to git directly
+but instead uses pure Python. It is based on the Python-Git module released by
+James Westby.
+
+WWW: http://samba.org/~jelmer/dulwich/
diff --git a/devel/dulwich/pkg-plist b/devel/dulwich/pkg-plist
new file mode 100644
index 000000000000..d8df96e50fcb
--- /dev/null
+++ b/devel/dulwich/pkg-plist
@@ -0,0 +1,69 @@
+bin/dul-daemon
+bin/dulwich
+%%PYTHON_SITELIBDIR%%/dulwich/__init__.py
+%%PYTHON_SITELIBDIR%%/dulwich/__init__.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/__init__.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/_objects.so
+%%PYTHON_SITELIBDIR%%/dulwich/_pack.so
+%%PYTHON_SITELIBDIR%%/dulwich/client.py
+%%PYTHON_SITELIBDIR%%/dulwich/client.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/client.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/errors.py
+%%PYTHON_SITELIBDIR%%/dulwich/errors.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/errors.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/index.py
+%%PYTHON_SITELIBDIR%%/dulwich/index.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/index.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/lru_cache.py
+%%PYTHON_SITELIBDIR%%/dulwich/lru_cache.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/lru_cache.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/misc.py
+%%PYTHON_SITELIBDIR%%/dulwich/misc.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/misc.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/object_store.py
+%%PYTHON_SITELIBDIR%%/dulwich/object_store.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/object_store.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/objects.py
+%%PYTHON_SITELIBDIR%%/dulwich/objects.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/objects.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/pack.py
+%%PYTHON_SITELIBDIR%%/dulwich/pack.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/pack.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/protocol.py
+%%PYTHON_SITELIBDIR%%/dulwich/protocol.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/protocol.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/repo.py
+%%PYTHON_SITELIBDIR%%/dulwich/repo.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/repo.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/server.py
+%%PYTHON_SITELIBDIR%%/dulwich/server.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/server.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_client.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_client.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_client.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_index.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_index.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_index.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_lru_cache.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_lru_cache.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_lru_cache.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_object_store.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_object_store.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_object_store.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_objects.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_objects.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_objects.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_pack.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_pack.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_pack.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_protocol.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_protocol.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_protocol.pyo
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_repository.py
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_repository.pyc
+%%PYTHON_SITELIBDIR%%/dulwich/tests/test_repository.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/dulwich/tests
+@dirrm %%PYTHON_SITELIBDIR%%/dulwich