aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-06-28 03:52:12 +0800
committermi <mi@FreeBSD.org>2007-06-28 03:52:12 +0800
commit4c356e074aec36383e8dcced075cb6516dd6d99a (patch)
treeb0ba0dce00202a7350c7f69f5ee4f9240f8559a2
parent2c283b0ac40fbea8294fc4d7be9cf559f6d862de (diff)
downloadfreebsd-ports-gnome-4c356e074aec36383e8dcced075cb6516dd6d99a.tar.gz
freebsd-ports-gnome-4c356e074aec36383e8dcced075cb6516dd6d99a.tar.zst
freebsd-ports-gnome-4c356e074aec36383e8dcced075cb6516dd6d99a.zip
Convert to using the USE_TCL knobs instead of trying to guess the
desired TCL-version. PR: 109716 (partial)
-rw-r--r--devel/tcllib/Makefile12
-rw-r--r--devel/tcllib/scripts/post-patch9
2 files changed, 8 insertions, 13 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index d816be918d9e..1605429c5103 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -16,13 +16,13 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= A collection of utility modules for Tcl
BUILD_DEPENDS= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}
+USE_TCL_BUILD= yes
+USE_TCL_RUN= ${USE_TCL_BUILD}
-TCL_VER?= 8.4
USE_BZIP2= yes
GNU_CONFIGURE= yes
ALL_TARGET= all
MAKE_ENV+= LANG=C
-SCRIPTS_ENV+= TCL_VER=${TCL_VER} PATCH="${PATCH}"
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -58,6 +58,10 @@ MANN= aes.n asn.n ansi_cmacros.n ansi_cctrl.n ansi_cattr.n \
MANCOMPRESSED= no
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ENV+= ac_cv_path_tclsh="${TCLSH}"
+
post-patch:
#
# Ensure, the detailed output of vendors' self-tests is
@@ -65,8 +69,8 @@ post-patch:
#
${REINPLACE_CMD} -e 's,test run,test run -l testlog,' \
${WRKSRC}/Makefile.in
-
-.include <bsd.port.pre.mk>
+ ${REINPLACE_CMD} -e 's,exec tclsh,exec ${TCLSH},' \
+ ${WRKSRC}/apps/dtplite
RUNTEST= ${SETENV} LANG=C DISPLAY= ${MAKE} -C ${WRKSRC} test
MYID != ${ID} -u
diff --git a/devel/tcllib/scripts/post-patch b/devel/tcllib/scripts/post-patch
deleted file mode 100644
index 3ff853ec0461..000000000000
--- a/devel/tcllib/scripts/post-patch
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-${PATCH} -f ${WRKSRC}/apps/dtplite << EOP
-@@ -1,3 +1,1 @@
--#! /bin/sh
--# -*- tcl -*-
--exec tclsh "$0" ${1+"$@"}
-+#!${PREFIX}/bin/tclsh${TCL_VER}
-EOP