aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2009-10-01 23:42:20 +0800
committerdanfe <danfe@FreeBSD.org>2009-10-01 23:42:20 +0800
commit4d064e87fa950eeaffdc0064b72086c2241daf0c (patch)
tree204b8ab9888c0900e19ac227597e047184614fa2
parent94483ef253792226145754fd1a26cca4a9184b1f (diff)
downloadfreebsd-ports-gnome-4d064e87fa950eeaffdc0064b72086c2241daf0c.tar.gz
freebsd-ports-gnome-4d064e87fa950eeaffdc0064b72086c2241daf0c.tar.zst
freebsd-ports-gnome-4d064e87fa950eeaffdc0064b72086c2241daf0c.zip
- Allow to build with ncurses renderer; while it still fails to behave
correctly in text console, it gets better in xterm/screen [*] - Optimize away ``.for .. .endfor'' loop while here Requested by: Alex Kozlov [*]
-rw-r--r--editors/biew/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 91d013222209..f60f4f8880ea 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -14,12 +14,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
MAINTAINER= danfe@FreeBSD.org
COMMENT= Binary file viewer and editor
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --cc="${CC}" --with-extraincdir="${LOCALBASE}/include" \
--ld="${CC}" --with-extralibdir="${LOCALBASE}/lib" \
- --prefix="${PREFIX}" --datadir="${DATADIR}" --enable-slang
+ --prefix="${PREFIX}" --datadir="${DATADIR}"
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
@@ -38,8 +36,17 @@ MAN1= biew.1
PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
file_ini.ru licence.en licence.ru release.txt unix.txt
+OPTIONS= SLANG "Use S-Lang based display renderer" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SLANG)
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+CONFIGURE_ARGS+= --enable-slang
+.else
+CONFIGURE_ARGS+= --enable-curses
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= Does not compile
.endif
@@ -63,9 +70,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/biew.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>