aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-05-08 19:20:46 +0800
committervs <vs@FreeBSD.org>2004-05-08 19:20:46 +0800
commit4dc285eecbbc409987d31979eb56558e8cf28393 (patch)
tree18f26294e532c6f7e290a603a0e94c4fa08e4e3c
parent948bf91cc529782568c9e8355b0caab9fb37c087 (diff)
downloadfreebsd-ports-gnome-4dc285eecbbc409987d31979eb56558e8cf28393.tar.gz
freebsd-ports-gnome-4dc285eecbbc409987d31979eb56558e8cf28393.tar.zst
freebsd-ports-gnome-4dc285eecbbc409987d31979eb56558e8cf28393.zip
- use gethostname() instead of uname(): the latter returns only returns
the first 32 chars of the hostname - patch helper-script to generate less bogus intermediate output - NB: This port will still register a wrong dependency on dns/host when dns/bind is installed
-rw-r--r--net/xtraceroute/Makefile5
-rw-r--r--net/xtraceroute/files/patch-main.c22
-rw-r--r--net/xtraceroute/files/patch-share::xtraceroute-resolve-location.sh.in11
3 files changed, 37 insertions, 1 deletions
diff --git a/net/xtraceroute/Makefile b/net/xtraceroute/Makefile
index e2af044e07d0..9bd5d9075edf 100644
--- a/net/xtraceroute/Makefile
+++ b/net/xtraceroute/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xtraceroute
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.dtek.chalmers.se/~d3august/xt/dl/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
@@ -34,6 +34,9 @@ DATAFILES= ndg_files.tar.gz
MAN1= xtraceroute.1
+post-patch:
+ @${TOUCH} ${WRKSRC}/po/*
+
post-install:
${INSTALL_DATA} ${WRKDIR}/hosts.cache ${PREFIX}/share/xtraceroute
${INSTALL_DATA} ${WRKDIR}/networks.cache ${PREFIX}/share/xtraceroute
diff --git a/net/xtraceroute/files/patch-main.c b/net/xtraceroute/files/patch-main.c
new file mode 100644
index 000000000000..3586cf2cee0a
--- /dev/null
+++ b/net/xtraceroute/files/patch-main.c
@@ -0,0 +1,22 @@
+--- main.c.orig Fri May 7 13:50:04 2004
++++ main.c Fri May 7 13:50:10 2004
+@@ -1215,15 +1215,14 @@
+ {
+ float tmpquat[4];
+ float vect[3] = {0.0, 1.0, 0.0};
+- struct utsname un;
+- struct hostent* he;
++ char namebuf[256];
++ struct hostent* he = NULL;
+ struct in_addr in;
+
+ memset(&local, 0, sizeof(site));
+
+- uname(&un);
+- strcpy(local.name, un.nodename);
+- he = gethostbyname(un.nodename);
++ if (gethostname(namebuf,256) == 0)
++ he = gethostbyname(namebuf);
+ if(!he)
+ {
+ printf("Error gethostbynaming local hostname");
diff --git a/net/xtraceroute/files/patch-share::xtraceroute-resolve-location.sh.in b/net/xtraceroute/files/patch-share::xtraceroute-resolve-location.sh.in
new file mode 100644
index 000000000000..13f4ba00bdf0
--- /dev/null
+++ b/net/xtraceroute/files/patch-share::xtraceroute-resolve-location.sh.in
@@ -0,0 +1,11 @@
+--- share/xtraceroute-resolve-location.sh.in.orig Fri May 7 15:01:36 2004
++++ share/xtraceroute-resolve-location.sh.in Fri May 7 15:01:57 2004
+@@ -34,7 +34,7 @@
+ BIND)
+ FIRST=yes
+ #while target contains a dot.
+- while [ `echo $TARGET | cut -s -f1- -d.` ] || [ $FIRST = yes ]
++ while [ -n "$TARGET" ] && [ `echo $TARGET | cut -s -f1- -d.` ] || [ $FIRST = yes ]
+ do
+ FIRST=no
+ #echo $TARGET
tions'>+3 * - Use canonical form (ports@FreeBSD.org) in MAINTAINER linesergei2003-12-211-1/+1 * - Update to version 2.8.3krion2003-12-192-2/+2 * Add xplore, an Explorer-like Motif based file manager.pav2003-12-189-0/+478 * Add velocity, a file manager for GNOME 2 desktop environment.pav2003-12-119-0/+172 * lower the gcc requirement to 3.2oliver2003-12-111-1/+1 * USE_MESA -> USE_GLfjoe2003-12-101-1/+1 * Update to 1.30 (see extensive ChangeLog for details). Adds more verboselinimon2003-12-088-136/+210 * Add emelfm2 0.0.3,oliver2003-12-086-0/+90 * update xfce to 4.0.1oliver2003-12-053-3/+10 * Upgrade to 0.11.45obraun2003-12-052-2/+2 * Upgrade to 0.1.2.olgeni2003-12-042-2/+2 * - Update to version 2.8.2krion2003-12-042-2/+2 * Upgrade to 0.11.43obraun2003-11-202-4/+2 * - Use system gettext instead of bundled one.pav2003-11-192-2/+2 * USE_REINPLACE need be defined only when REINPLACE_CMD is used.trevor2003-11-171-1/+0 * Upgrade to 0.11.41obraun2003-11-172-2/+2 * Upgrade to 0.11.40obraun2003-11-172-2/+3 * I thought it was just my slow and overstuffed disks, but Adamtrevor2003-11-161-0/+1 * Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.trevor2003-11-131-1/+1 * Remove my e-mail address from DESCR files of portstrevor2003-11-132-2/+0 * Remove my e-mail address from comment blocks of portstrevor2003-11-131-1/+1 * Rename PORTDOCS to MYPORTDOCS to avoid a conflict with the recently addedmarcus2003-11-072-4/+4 * Mark BROKEN (see bento logs). These ports are scheduled for removalkris2003-11-031-0/+2 * Upgrade to 0.11.39.obraun2003-11-013-2/+26 * Upgrade to version 0.1.21.olgeni2003-10-273-3/+21 * * Fix crash trying to find pixmapsmarcus2003-10-276-30/+40 * The author's distribution site and homepage appears to have been removed;petef2003-10-271-1/+3 * add tk83 to LIB_DEPENDS. it should have been added when BLT waskjc2003-10-261-1/+2 * Upgrade to 0.11.38.obraun2003-10-262-2/+2 * utilize SITE_PERLijliao2003-10-241-1/+1 * Install man page.trevor2003-10-241-0/+3 * Upgrade to 0.11.37.obraun2003-10-202-3/+3 * make tkdesk not to depend on the ports version of the BLT library.kjc2003-10-201-3/+1 * - Get the translations installed (Make configure able to detectoliver2003-10-192-3/+22 * Fix packaging due to gnomehack being overwritten by automake.marcus2003-10-172-8/+2 * Update to 2.4.1.adamw2003-10-134-14/+3 * Upgrade to 0.11.36.obraun2003-10-132-2/+3 * Upgrade to version 2.1.0.olgeni2003-10-093-91/+98 * FSViewer new portedwin2003-10-086-0/+220 * * Update to 1.0.1 [1]marcus2003-10-0516-152/+234 * Upgrade to 0.11.35.obraun2003-10-052-2/+2 * Omit unnecessary USE_MESA.trevor2003-10-041-1/+0 * Omit unnecessary -DFLTK_1_0_COMPAT, -lMesaGL, PTHREAD_CFLAGS andtrevor2003-10-041-5/+4 * * Show the scripts menu/popup item regardless if any scripts exist or notmarcus2003-10-043-24/+100 * Add back DIST_SUBDIR. It was removed by mistake.demon2003-09-294-2/+4 * Update to 4.0.0 release.demon2003-09-275-17/+9 * Work around a problem found by Bill Fenner's survey: the patchtrevor2003-09-251-1/+1 * Make portlint(1) happy by changing strip to ${STRIP_CMD}osa2003-09-241-2/+2 * Fix a crash when an invalid URI is entered.marcus2003-09-222-0/+12 * Use USE_GNOME to fix the build on bento.marcus2003-09-211-4/+1 * Update to GNOME 2.4.0. For all the goodies on what's changed, known issues,marcus2003-09-186-234/+163 * Drop maintainershiplioux2003-09-081-1/+1 * Update to 1.46.trevor2003-09-062-2/+4 * Update to version 4.0 RC3.demon2003-09-034-13/+12 * - Fix build on -current (embedded newlines)krion2003-08-303-4/+95 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-271-0/+1 * Chase the libintl.so shared lib version.marcus2003-08-251-1/+1 * - Update to 2.8.1krion2003-08-223-4/+12 * take maintainershipoliver2003-08-172-2/+2 * Convert to new GNOME infrastructure.marcus2003-08-171-3/+1 * Assign maintainership back to ports@. Thanks for all your work, Martin.marcus2003-08-171-1/+1 * Start using the new xfce sub-categoryoliver2003-08-162-2/+2 * Remove this ports as part of phase II of the GNOME 1.4 desktop removal.marcus2003-08-128-136/+0 * Add xfe 0.54.2, fast MS-Explorer like filemanager for X.oliver2003-08-085-0/+199 * Fix build on gcc-3.3.xmaho2003-08-021-0/+11 * fix LIB_DEPENDS. dbh library got changed during the last databases/dbh changes.oliver2003-08-011-1/+1 * bumped PORTREVISIONoliver2003-07-311-0/+1 * Add missing dependenciesoliver2003-07-311-1/+3 * Add xfce4-fm-icons 3.99.2,oliver2003-07-295-0/+1367 * Add xfce4-fm 3.99.2, xFce 4 file manager.oliver2003-07-295-0/+199 * Upgrade to version 2.0.1.olgeni2003-07-252-2/+2 * Begin the de-orbit burn of the GNOME 1.4 desktop. This is phase I. Allmarcus2003-07-1620-1814/+0 * Add missing entry to the plist and Makefile.sanpei2003-07-122-0/+2 * Update port to 0.30sanpei2003-07-085-16/+15 * Update to version 0.1.20.olgeni2003-06-213-3/+4 * Remove REINPLACE commands that were rolled into gnomehack.adamw2003-06-122-8/+0 * Update to 1.20arved2003-06-0312-624/+8 * Update to version 2.0.0.olgeni2003-06-032-2/+2 * Update to version 0.1.1.olgeni2003-06-022-2/+2 * Update to version 1.3.10.olgeni2003-06-012-2/+2 * Add default CHARSET fallback (iso-8859-1).olgeni2003-05-201-0/+5 * Update to version 1.3.9. Add support for updating the shared mimeolgeni2003-05-183-2/+11 * Add krusader, a midnight commander like Filemanager for KDEarved2003-05-1817-0/+975 * Do not call autoconf in post-patch target.olgeni2003-05-141-5/+1 * Change in-place replacement.kiri2003-05-082-2/+3 * Set MASTER_SITES fetchable and correct reinplace commands.kiri2003-05-084-12/+17 * Update to 2.2.4.marcus2003-05-083-2/+4 * As announced on 27 March 2003 in <20030328052350.GA18971@rot13.obsecurity.org>,kris2003-05-061-1/+0 * As announced on 27 March 2003 in <20030328052350.GA18971@rot13.obsecurity.org>,kris2003-05-0610-248/+0 * Add missing file (RunROX).olgeni2003-04-242-1/+3 * Chase checksum. The new tarball was verified by GPG signature.olgeni2003-04-211-1/+1 * Install the rox binary mode 755, not 775kris2003-04-211-1/+1 * Remove USE_GNOMENG.marcus2003-04-2111-11/+0 * Update to version 0.1.19.olgeni2003-04-173-3/+3 * Change the gnomecontrolcenter2 dependency to a GNOME component.marcus2003-04-141-2/+2 * * Update to new GNOME infrastructuremarcus2003-04-072-6/+3 * PORT UPDATE: x11-fm/twanderedwin2003-04-054-17/+11 * Update to 2.2.3.1.marcus2003-04-044-16/+19 * Update to version 1.3.8.olgeni2003-03-302-2/+2 * Trim whitespace at end of file.olgeni2003-03-301-2/+0 * Add message about non-UTF-8 filenames and fallback CHARSET encoding.olgeni2003-03-301-0/+11 * Add MIME type editor for the ROX desktop.olgeni2003-03-255-0/+62 * Retire obsolete rox-base port (no longer needed by any rox application).olgeni2003-03-255-89/+0 * Use /sbin/shutdown (-p or -r) as the default halt/reboot command.olgeni2003-03-241-0/+16 * Fix WWW using specific project page.olgeni2003-03-241-1/+1 * Update to version 1.3.7.olgeni2003-03-235-42/+48 * Fix build: replace BUILD_DEPENDS with EXTRACT_DEPENDS where appropriatelioux2003-03-231-2/+2 * Make this usable with the new fltk library.trevor2003-03-231-3/+1 * Clear moonlight beckons.ade2003-03-0714-7/+7 * Add twander, a macro-configurable file manager written in Python.marcus2003-03-036-0/+75 * Retire comment file.trevor2003-03-014-2/+2 * De-pkg-commentlioux2003-02-242-1/+1 * De-pkg-comment my ports + some more.olgeni2003-02-234-2/+2 * de-pkg-comment.sanpei2003-02-222-1/+1 * De-pkg-comment.knu2003-02-2122-11/+11 * De-pkg-comment.knu2003-02-2112-6/+6 * De-pkg-comment and make portlint a little bit happier.obraun2003-02-182-1/+1 * Clean up the Makefile some to remove the dead Mozilla bits.marcus2003-02-182-44/+6 * chmod the Nautilus .desktop files since they will be copied to each user'smarcus2003-02-161-0/+3 * Update to 2.2.1.marcus2003-02-123-2/+3 * obsolete due to upgrade of master port (ports/misc/mc) to version 4.6.0fjoe2003-02-102-19/+0 * Chase gtk20's shared lib version.marcus2003-02-082-2/+4 * Update to GNOME 2.2.marcus2003-02-089-444/+63 * Update to version 5.0.2demon2003-02-053-2/+9 * Update MASTER_SITES and WWW and release to the wild.sobomax2003-01-202-3/+4 * Add a RUN_DEPENDS on gnomecontrolcenter2. This is for users that like tomarcus2003-01-201-0/+2 * This was broken by the recent update to the fltk port. David Thiel'strevor2003-01-171-0/+2 * Remove share/gnome/apotheke.marcus2003-01-131-0/+1 * Upgrade to version 1.3.6.olgeni2003-01-122-2/+2 * Update to 5.0.0.demon2003-01-096-73/+47 * Update to version 0.1.18 and add non-i386 arch support in plist.olgeni2003-01-023-7/+54 * (whitespace) Separate assignments from Makefile targets.olgeni2003-01-021-4/+4 * Update to 1.3.5.olgeni2003-01-025-17/+64 * Add support for ARCH != i386.olgeni2003-01-022-4/+14 * fix port that did not follow the automake/autoconf rules; approved by kris; F...alane2002-12-202-2/+2 * Fix port Makefile to play nice by the new, stricter, autoconf/automakealane2002-12-062-2/+2 * Fix package building.marcus2002-12-021-2/+3 * find, rm, xargs -> ${FIND}, ${RM}, ${XARGS}.olgeni2002-11-231-4/+4 * Update to 2.0.8.marcus2002-11-203-2/+7 * Add a missing dependency on libglade.marcus2002-11-191-1/+1 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-1112-11/+6 * Add a dependency on ssh-askpass. Bump PORTREVISION.marcus2002-11-101-0/+2 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-0710-5/+10 * Use PORTCOMMENT variable instead of pkg-comment file.obraun2002-11-062-1/+1 * Add apotheke, a CVS view for Nautilus 2.marcus2002-11-056-0/+64 * Fix build on -CURRENT.naddy2002-11-011-4/+10 * * Upgrade to 2.7.0.obraun2002-10-272-3/+5 * Switch to MASTER_SITE_LOCAL to make this port fetchablearved2002-10-251-1/+2 * Update to version 1.3.4.olgeni2002-10-113-6/+4 * Add a missing dependency on gnomecanvas.marcus2002-10-061-1/+1 * Add a missing dependency on gdkpixbuf.marcus2002-09-251-1/+1 * Add missing dependency on gnomevfs. Unbreak.marcus2002-09-211-3/+1 * BROKEN: configure failskris2002-09-211-0/+2 * GNOME has just changed the layout of their FTP site. This resulted inmarcus2002-09-212-2/+2 * Add a missing dependency on gdkpixbuf.marcus2002-09-192-2/+2 * fix for strcasestr problemijliao2002-09-173-12/+19 * * Update to 2.0.7marcus2002-09-154-15/+44 * Backport sobomax's CD eject patch to nautilus from nautilus2.marcus2002-09-122-3/+12 * Since FreeBSD doesn't have unified eject command which works forsobomax2002-09-112-3/+15 * Forward-port the nautilus patches for fixing removable media volumes onmarcus2002-09-112-13/+64 * Okay, _this_ should complete the filesystem stuff. With this patch, CD namesmarcus2002-09-112-13/+66 * Complete the removable media patch as was done in nautilus.marcus2002-09-112-6/+23 * Port sobomax's nautilus2 volume patches to nautilus, and take things a stepmarcus2002-09-112-26/+37 * Clean up some evilness in FreeBSD-specific volume monitor code. Particularlysobomax2002-09-102-29/+28 * Upgrade to 0.11.34.obraun2002-09-082-2/+2 * Upgrade to 0.11.33obraun2002-09-024-13/+3 * Deploy USE_GNOMENG infrastructurelioux2002-09-027-7/+14 * Upgrade to 0.11.32.obraun2002-08-294-4/+14 * Update to 2.0.6.marcus2002-08-292-2/+2 * Upgrade to 2.6.1.obraun2002-08-273-2/+5 * Update to 2.0.5.marcus2002-08-242-3/+3 * Use USE_GNOMENG.marcus2002-08-243-1/+26 * Change MAINTAINER to my FreeBSD address.obraun2002-08-211-1/+1 * Update to 2.6.0kevlo2002-08-212-2/+2 * Update to 2.0.4.marcus2002-08-154-12/+14 * define WITHOUT_ICONV, WITHOUT_ISPELLfjoe2002-08-111-0/+2 * This port is no longer used in GNOME so take maintainership andfjoe2002-08-1116-456/+5 * Update to 0.11.31pat2002-08-102-2/+2 * Update to 2.0.3.marcus2002-08-084-14/+12 * Fix links to the Handbook, the FAQ and the porters-handbook.blackend2002-08-04