aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-11-28 13:39:16 +0800
committerlinimon <linimon@FreeBSD.org>2007-11-28 13:39:16 +0800
commit4e649bac26aa6b7c1075685917af02e5c837b748 (patch)
tree3f325c73e6870d38f27639480b9154878067688d
parentef622cf3f64f49c74ff5c8c89a2ca9c2ff2dc488 (diff)
downloadfreebsd-ports-gnome-4e649bac26aa6b7c1075685917af02e5c837b748.tar.gz
freebsd-ports-gnome-4e649bac26aa6b7c1075685917af02e5c837b748.tar.zst
freebsd-ports-gnome-4e649bac26aa6b7c1075685917af02e5c837b748.zip
Attempt to unbreak on gcc4.2.
PR: ports/117131 Subbmited by: maintainer Approved by: portmgr (self)
-rw-r--r--devel/libchipcard/Makefile10
-rw-r--r--devel/libchipcard/files/patch-src-libchipcard-cards-hbcicard.cpp14
2 files changed, 15 insertions, 9 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index ff0ab5f0ed75..fd667067dc8a 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -40,12 +40,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d
@${SED} -e 's,%%PREFIX%%,${PREFIX},' ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libchipcard/files/patch-src-libchipcard-cards-hbcicard.cpp b/devel/libchipcard/files/patch-src-libchipcard-cards-hbcicard.cpp
new file mode 100644
index 000000000000..369651ce379f
--- /dev/null
+++ b/devel/libchipcard/files/patch-src-libchipcard-cards-hbcicard.cpp
@@ -0,0 +1,14 @@
+--- src/libchipcard/cards/hbcicard.cpp.orig 2007-10-12 09:54:53.000000000 +0200
++++ src/libchipcard/cards/hbcicard.cpp 2007-10-12 09:53:18.000000000 +0200
+@@ -684,8 +684,8 @@
+ case k_HBCICARD_TYPE_1:
+ return _hash2mac1(hash,mac);
+ default:
+- DBG_INFO("LIBCHIPCARD: unknown chip card type (%8x) (%d).",
+- (unsigned int)this,
++ DBG_INFO("LIBCHIPCARD: unknown chip card type (%p) (%d).",
++ this,
+ _type);
+ return false;
+ }
+