aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-02-07 05:38:29 +0800
committerkris <kris@FreeBSD.org>2000-02-07 05:38:29 +0800
commit503b1ce9eee1afa458d91fbaaf7830a5c344dd54 (patch)
tree6de2274d2c2e2ca9afc22ea7c2ddd8db3be5807c
parente3c182f2db1c16ee92ee8b3e26d8df6080a76911 (diff)
downloadfreebsd-ports-gnome-503b1ce9eee1afa458d91fbaaf7830a5c344dd54.tar.gz
freebsd-ports-gnome-503b1ce9eee1afa458d91fbaaf7830a5c344dd54.tar.zst
freebsd-ports-gnome-503b1ce9eee1afa458d91fbaaf7830a5c344dd54.zip
USE_OPENSSL
Assisted by: Jim Bloom <bloom@acm.org>A
-rw-r--r--security/bjorb/Makefile24
-rw-r--r--security/bjorb/files/patch-ac2
2 files changed, 5 insertions, 21 deletions
diff --git a/security/bjorb/Makefile b/security/bjorb/Makefile
index aad973c2f153..3fe97b26dca2 100644
--- a/security/bjorb/Makefile
+++ b/security/bjorb/Makefile
@@ -12,32 +12,16 @@ MASTER_SITES= ftp://ftp.hitachi-ms.co.jp/pub/bjorb/
MAINTAINER= issei@jp.FreeBSD.org
-.if defined(USA_RESIDENT) && ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
-pre-fetch:
- @${ECHO}
- @${ECHO} You must set variable USA_RESIDENT to YES, if you are USA resident
- @${ECHO} or to NO, if you aren\'t USA resident to build this package.
- @${ECHO} You must also have installed RSAREF if you are USA resident.
- @${FALSE}
-.elif defined(USA_RESIDENT)
-.if ${USA_RESIDENT} == YES
-LIB_DEPENDS= rsaref.2:${PORTSDIR}/security/rsaref
-.endif
-.endif
-BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
-LIB_DEPENDS= crypto.1:${PORTSDIR}/security/openssl \
- ssl.1:${PORTSDIR}/security/openssl
-RUN_DEPENDS= openssl:${PORTSDIR}/security/openssl
-
-RESTRICTED= "Cryptography"
+USE_OPENSSL= RSA
.if !defined(BATCH)
INSTALL_TARGET= install certificate
.endif
USE_AUTOCONF= yes
-CFLAGS+= -I${PREFIX}/include/openssl
-CONFIGURE_ARGS= --with-ssltop=${PREFIX} --with-ssllib=${PREFIX}/lib
+CFLAGS+= -I${OPENSSLINC}/openssl
+CONFIGURE_ARGS= --with-ssltop=${OPENSSLBASE} --with-ssllib=${OPENSSLLIB}
+CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
WRKSRC= ${WRKDIR}/${DISTNAME}/src
DOCSRC= ${WRKDIR}/${DISTNAME}
DOCS= ChangeLog \
diff --git a/security/bjorb/files/patch-ac b/security/bjorb/files/patch-ac
index 36933f82a817..3d51b891b711 100644
--- a/security/bjorb/files/patch-ac
+++ b/security/bjorb/files/patch-ac
@@ -35,7 +35,7 @@
- ssllibs="-lssl -lcrypto"
+ AC_MSG_CHECKING([for RSAref library])
+ saved_LIBS="-L$ssllib -lcrypto -lssl"
-+ LIBS="$saved_LIBS -lRSAglue -lrsaref"
++ LIBS="$saved_LIBS -L${LOCALBASE}/lib -lRSAglue -lrsaref"
+ AC_TRY_LINK([], [],
+ [AC_MSG_RESULT(yes); ],
+ [AC_MSG_RESULT(no)]; LIBS="$saved_LIBS")