aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-03-30 03:18:33 +0800
committerriggs <riggs@FreeBSD.org>2015-03-30 03:18:33 +0800
commit511cf851fb71e1f7cfcf1fd9b0a1b6b8203f78a1 (patch)
tree5422e6ad19e75d23766c0af35b0776d35cb44094
parent7371c79da43f677fb092222cc5e99a590eb4ac6b (diff)
downloadfreebsd-ports-gnome-511cf851fb71e1f7cfcf1fd9b0a1b6b8203f78a1.tar.gz
freebsd-ports-gnome-511cf851fb71e1f7cfcf1fd9b0a1b6b8203f78a1.tar.zst
freebsd-ports-gnome-511cf851fb71e1f7cfcf1fd9b0a1b6b8203f78a1.zip
Fix build errors with PortAudio and/or ALSA
PR: 196735 Submitted by: antumdeluge@gmail.com (pr), root@cooltrainer.org (patch) Reviewed by: riggs Approved by: root@cooltrainer.org (maintainer)
-rw-r--r--LEGAL1
-rw-r--r--emulators/snes9x-gtk/Makefile80
-rw-r--r--emulators/snes9x-gtk/pkg-plist5
3 files changed, 34 insertions, 52 deletions
diff --git a/LEGAL b/LEGAL
index fdcad0bef632..1d2de3d85b5b 100644
--- a/LEGAL
+++ b/LEGAL
@@ -278,3 +278,4 @@ gmsh-* cad/gmsh Contact appropriate authors for commercial purposes if includ
gmsh-occ-* cad/gmsh-occ Contact appropriate authors for commercial purposes if including Tetgen or Metis
btsync_* net-p2p/btsync Redistribution forbidden by license
sas2ircu-* sysutils/sas2ircu May not be redistributed. Must accept license to download.
+snes9x-* emulators/snes9x-gtk Commercial users must seek permission from copyright holders.
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 20d46eb293c4..4ef4264afa7b 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snes9x
PORTVERSION= 1.53r81
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://snes9x-gtk.googlecode.com/files/
PKGNAMESUFFIX= -gtk
@@ -12,67 +12,56 @@ DISTNAME= snes9x-1.53-src
MAINTAINER= root@cooltrainer.org
COMMENT= Super Nintendo Entertainment System(SNES) Emulator
+LICENSE= Snes9x
+LICENSE_NAME= Snes9x License
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/docs/snes9x-license.txt
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USE_XORG= x11 sm ice xext
-USES= gettext gmake perl5 desktop-file-utils pkgconfig tar:bzip2
+USES= gettext gmake perl5 desktop-file-utils pkgconfig tar:bzip2 desktop-file-utils
USE_GNOME= gtk20 intltool libglade2 libxml2
GNU_CONFIGURE= yes
-USE_SDL= sdl
+USE_SDL= sdl2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --without-alsa
WRKSRC= ${WRKDIR}/${DISTNAME}/gtk
+NO_CDROM= Commercial users must seek permission from copyright holders.
-OPTIONS_DEFINE= DEBUG OPENGL JMA NETPLAY XV XRANDR
+OPTIONS_DEFINE= DEBUG OPENGL JMA NETPLAY XV XRANDR ALSA PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= JMA NETPLAY XV XRANDR
JMA_DESC= Enable JMA archive decompression support
NETPLAY_DESC= Enable network support
XV_DESC= Enable XVideo output on GTK
XRANDR_DESC= Enable XRandR support on GTK
+PORTAUDIO_DESC= Enable PortAudio support
+GTK2_DESC= Use GTK 2.x interface toolkit
+
+DEBUG_CONFIGURE_WITH= debug
+OPENGL_CONFIGURE_WITH= opengl
+OPENGL_USE= GL=glu
+JMA_CONFIGURE_WITH= jma-decomp
+NETPLAY_CONFIGURE_WITH= netplay
+XV_CONFIGURE_WITH= xv
+XV_USE= XORG=xv
+XRANDR_CONFIGURE_WITH= xrandr
+XRANDR_USE= XORG=xrandr
+ALSA_CONFIGURE_WITH= alsa
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_USES= compiler:c++11-lang
+PORTAUDIO_CONFIGURE_WITH= portaudio
+PORTAUDIO_LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+
+PLIST_FILES= bin/snes9x-gtk \
+ share/pixmaps/snes9x.svg \
+ share/applications/snes9x.desktop
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --with-debug
-.else
-CONFIGURE_ARGS+= --without-debug
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
-CONFIGURE_ARGS+= --with-opengl
-USE_GL= glu
-.else
-CONFIGURE_ARGS+= --without-opengl
-.endif
-
-.if ${PORT_OPTIONS:MJMA}
-CONFIGURE_ARGS+= --with-jma-decomp
-.else
-CONFIGURE_ARGS+= --without-jma-decomp
-.endif
-
-.if ${PORT_OPTIONS:MNETPLAY}
-CONFIGURE_ARGS+= --with-netplay
-.else
-CONFIGURE_ARGS+= --without-netplay
-.endif
-
-.if ${PORT_OPTIONS:MXV}
-CONFIGURE_ARGS+= --with-xv
-USE_XORG+= xv
-.else
-CONFIGURE_ARGS+= --without-xv
-.endif
-
-.if ${PORT_OPTIONS:MXRANDR}
-CONFIGURE_ARGS+= --with-xrandr
-USE_XORG+= xrandr
-.else
-CONFIGURE_ARGS+= --without-xrandr
-.endif
-
.if exists(/usr/lib/libusbhid.a)
CONFIGURE_ARGS+= --with-joystick
.else
@@ -87,7 +76,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/data/snes9x.desktop \
${STAGEDIR}${PREFIX}/share/applications
-post-install:
- -@update-desktop-database
-
.include <bsd.port.post.mk>
diff --git a/emulators/snes9x-gtk/pkg-plist b/emulators/snes9x-gtk/pkg-plist
deleted file mode 100644
index 857627b394f4..000000000000
--- a/emulators/snes9x-gtk/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/snes9x-gtk
-share/pixmaps/snes9x.svg
-share/applications/snes9x.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true