aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-08-31 00:04:42 +0800
committerolivierd <olivierd@FreeBSD.org>2015-08-31 00:04:42 +0800
commit56a811faea485a464e8a9bab880cba09b4b63b05 (patch)
tree044265124eb5e09eb918537c241c5ced9c19892e
parent4c174b1d9d28dda12fc050878a8ef5bd2e0e5a8d (diff)
downloadfreebsd-ports-gnome-56a811faea485a464e8a9bab880cba09b4b63b05.tar.gz
freebsd-ports-gnome-56a811faea485a464e8a9bab880cba09b4b63b05.tar.zst
freebsd-ports-gnome-56a811faea485a464e8a9bab880cba09b4b63b05.zip
- Update to 0.3.1
- Sort USES - Remove unneeded patches
-rw-r--r--x11-toolkits/granite/Makefile14
-rw-r--r--x11-toolkits/granite/distinfo4
-rw-r--r--x11-toolkits/granite/files/patch-CMakeLists.txt33
-rw-r--r--x11-toolkits/granite/files/patch-lib_Widgets_DatePicker.vala11
-rw-r--r--x11-toolkits/granite/files/patch-lib__Application.vala35
-rw-r--r--x11-toolkits/granite/files/patch-lib__Widgets__ContractorView.vala20
-rw-r--r--x11-toolkits/granite/files/patch-lib__Widgets__DynamicNotebook.vala31
-rw-r--r--x11-toolkits/granite/pkg-plist18
8 files changed, 56 insertions, 110 deletions
diff --git a/x11-toolkits/granite/Makefile b/x11-toolkits/granite/Makefile
index 1b9b3878ea68..e7be301ef3b1 100644
--- a/x11-toolkits/granite/Makefile
+++ b/x11-toolkits/granite/Makefile
@@ -3,14 +3,13 @@
#
PORTNAME= granite
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= x11-toolkits
-MASTER_SITES= https://launchpadlibrarian.net/176306383/ \
- https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION:R}/+download/
+MASTER_SITES= https://launchpadlibrarian.net/215905441/ \
+ https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
MAINTAINER= olivierd@FreeBSD.org
-COMMENT= Extensions of Gtk+ toolkit
+COMMENT= Extensions of GTK3 toolkit
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -19,10 +18,11 @@ BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee
RUN_DEPENDS= contractor:${PORTSDIR}/sysutils/contractor
-USE_GCC= yes
-USES= cmake pkgconfig gettext
+USES= cmake gettext pkgconfig tar:xz
USE_GNOME= glib20 gtk30 introspection:build
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
+CFLAGS+= -Wno-return-type
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/granite/distinfo b/x11-toolkits/granite/distinfo
index f98291902ed0..680461200663 100644
--- a/x11-toolkits/granite/distinfo
+++ b/x11-toolkits/granite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (granite-0.3.0.tar.gz) = df950dd79749213971d50316c68edadf1fb3c2151cb7d63f6a6b9edf12084ad1
-SIZE (granite-0.3.0.tar.gz) = 285072
+SHA256 (granite-0.3.1.tar.xz) = 8ec1d61f9aba75f1b3a745e721288b0dfb34cb11d1307be80cef7b0571c2dec6
+SIZE (granite-0.3.1.tar.xz) = 277640
diff --git a/x11-toolkits/granite/files/patch-CMakeLists.txt b/x11-toolkits/granite/files/patch-CMakeLists.txt
index 537833e3e603..cef4a896aeb2 100644
--- a/x11-toolkits/granite/files/patch-CMakeLists.txt
+++ b/x11-toolkits/granite/files/patch-CMakeLists.txt
@@ -1,26 +1,19 @@
---- ./CMakeLists.txt.orig 2014-05-25 19:42:24.000000000 +0000
-+++ ./CMakeLists.txt 2014-07-27 10:49:39.000000000 +0000
-@@ -61,12 +61,18 @@
- --thread
- --target-glib=2.32)
-
--if (CMAKE_SYSTEM_NAME MATCHES "Linux")
-+if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=LINUX)
-+elseif (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
-+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=DragonFly)
-+elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FreeBSD)
-+elseif (${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
-+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=NetBSD)
-+elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
-+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=OpenBSD)
+--- CMakeLists.txt.orig 2015-08-30 10:13:06 UTC
++++ CMakeLists.txt
+@@ -66,7 +66,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux"
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=DRAGON_FLY)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+- set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FFREE_BSD)
++ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FREE_BSD)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=NET_BSD)
+ elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
+@@ -74,7 +74,5 @@ elseif (${CMAKE_SYSTEM_NAME} MATCHES "Op
endif ()
add_subdirectory (lib)
-add_subdirectory (demo)
-add_subdirectory (doc)
add_subdirectory (po)
--add_subdirectory (icons)
-\ No newline at end of file
-+add_subdirectory (icons)
+ add_subdirectory (icons)
diff --git a/x11-toolkits/granite/files/patch-lib_Widgets_DatePicker.vala b/x11-toolkits/granite/files/patch-lib_Widgets_DatePicker.vala
new file mode 100644
index 000000000000..35fc43a2e732
--- /dev/null
+++ b/x11-toolkits/granite/files/patch-lib_Widgets_DatePicker.vala
@@ -0,0 +1,11 @@
+--- lib/Widgets/DatePicker.vala.orig 2015-08-30 10:13:06 UTC
++++ lib/Widgets/DatePicker.vala
+@@ -77,7 +77,7 @@ namespace Granite.Widgets {
+ // Entry properties
+ can_focus = false;
+ editable = false; // user can't edit the entry directly
+- secondary_icon_gicon = new ThemedIcon.with_default_fallbacks ("office-calendar-symbolic");
++ secondary_icon_gicon = new ThemedIcon.with_default_fallbacks ("x-office-calendar-symbolic");
+
+ dropdown.add_events (EventMask.FOCUS_CHANGE_MASK);
+ dropdown.add (calendar);
diff --git a/x11-toolkits/granite/files/patch-lib__Application.vala b/x11-toolkits/granite/files/patch-lib__Application.vala
index cbbfcde92052..efb9404ba3f0 100644
--- a/x11-toolkits/granite/files/patch-lib__Application.vala
+++ b/x11-toolkits/granite/files/patch-lib__Application.vala
@@ -1,24 +1,15 @@
---- ./lib/Application.vala.orig 2014-03-18 20:51:49.000000000 +0000
-+++ ./lib/Application.vala 2014-05-29 09:42:26.000000000 +0000
-@@ -69,6 +69,8 @@
- public Application () {
- #if LINUX
- prctl (15, exec_name, 0, 0, 0);
-+#elif DragonFly || FreeBSD || NetBSD || OpenBSD
-+ setproctitle (exec_name);
- #endif
- Environment.set_prgname (exec_name);
+--- lib/Application.vala.orig 2015-08-30 10:13:06 UTC
++++ lib/Application.vala
+@@ -157,7 +157,11 @@ namespace Granite {
+ message ("Kernel version: %s", (string) un.release);
+ Logger.DisplayLevel = LogLevel.WARN;
-@@ -90,6 +92,12 @@
- #if LINUX
- [CCode (cheader_filename = "sys/prctl.h", cname = "prctl")]
- protected extern static int prctl (int option, string arg2, ulong arg3, ulong arg4, ulong arg5);
-+#elif DragonFly || FreeBSD
-+ [CCode (cheader_filename = "unistd.h", cname = "setproctitle")]
-+ protected extern static void setproctitle (string fmt, ...);
-+#elif NetBSD || OpenBSD
-+ [CCode (cheader_filename = "stdlib.h", cname = "setproctitle")]
-+ protected extern static void setproctitle (string fmt, ...);
- #endif
+- Intl.bindtextdomain (exec_name, build_data_dir + "/locale");
++ Intl.setlocale (LocaleCategory.ALL, "");
++ string langpack_dir = Path.build_path (Path.DIR_SEPARATOR_S, build_data_dir, "locale");
++ Intl.bindtextdomain (exec_name, langpack_dir);
++ Intl.bind_textdomain_codeset (exec_name, "UTF-8");
++ Intl.textdomain (exec_name);
+
+ add_actions ();
- /**
diff --git a/x11-toolkits/granite/files/patch-lib__Widgets__ContractorView.vala b/x11-toolkits/granite/files/patch-lib__Widgets__ContractorView.vala
deleted file mode 100644
index 4b23a1111ed3..000000000000
--- a/x11-toolkits/granite/files/patch-lib__Widgets__ContractorView.vala
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/Widgets/ContractorView.vala.orig 2015-08-02 23:43:12.064726000 +0200
-+++ lib/Widgets/ContractorView.vala 2015-08-02 23:43:58.610804000 +0200
-@@ -35,7 +35,7 @@
- public delegate void ContractCallback ();
- private Gee.HashMap<int, DelegateWrapper?> outsiders;
- private int[] blacklisted_pos;
-- private ListStore list;
-+ private Gtk.ListStore list;
-
- private struct DelegateWrapper { unowned ContractCallback method; }
-
-@@ -73,7 +73,7 @@
- */
- public ContractorView (string filename, string mime, int icon_size = 32, bool show_contract_name = true) {
- /* Setup the ListStore */
-- list = new ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
-+ list = new Gtk.ListStore (2, typeof (Gdk.Pixbuf), typeof (string));
- outsiders = new Gee.HashMap<int, DelegateWrapper?> ();
- this.model = list;
-
diff --git a/x11-toolkits/granite/files/patch-lib__Widgets__DynamicNotebook.vala b/x11-toolkits/granite/files/patch-lib__Widgets__DynamicNotebook.vala
deleted file mode 100644
index 52929ee0c810..000000000000
--- a/x11-toolkits/granite/files/patch-lib__Widgets__DynamicNotebook.vala
+++ /dev/null
@@ -1,31 +0,0 @@
---- lib/Widgets/DynamicNotebook.vala.orig 2014-05-25 21:42:24.000000000 +0200
-+++ lib/Widgets/DynamicNotebook.vala 2015-08-02 23:42:37.151406000 +0200
-@@ -658,10 +658,19 @@
- /**
- * The text shown in the add button tooltip
- */
-+#if VALA_0_26
-+ public string add_button_tooltip {
-+ get { _add_button_tooltip = add_button.tooltip_text; return _add_button_tooltip; }
-+ set { add_button.tooltip_text = value; }
-+ }
-+ // Use temporary field to avoid breaking API this can be dropped while preparing for 0.4
-+ string _add_button_tooltip;
-+#else
- public string add_button_tooltip {
- get { return add_button.tooltip_text; }
- set { add_button.tooltip_text = value; }
- }
-+#endif
-
- public Tab current {
- get { return tabs.nth_data (notebook.get_current_page ()); }
-@@ -918,7 +927,7 @@
- notebook.create_window.connect (on_create_window);
- }
-
-- ~Notebook () {
-+ ~DynamicNotebook () {
- notebook.switch_page.disconnect (on_switch_page);
- notebook.page_added.disconnect (on_page_added);
- notebook.page_removed.disconnect (on_page_removed);
diff --git a/x11-toolkits/granite/pkg-plist b/x11-toolkits/granite/pkg-plist
index 1e14b22cca97..50ff8ef230dd 100644
--- a/x11-toolkits/granite/pkg-plist
+++ b/x11-toolkits/granite/pkg-plist
@@ -2,18 +2,18 @@ include/granite/granite.h
include/granite/widgets-utils.h
lib/girepository-1.0/Granite-1.0.typelib
lib/libgranite.so
-lib/libgranite.so.2
-lib/libgranite.so.2.0.1
+lib/libgranite.so.3
+lib/libgranite.so.3.0.1
libdata/pkgconfig/granite.pc
share/gir-1.0/Granite-1.0.gir
-share/icons/hicolor/16x16/actions/application-menu.svg
share/icons/hicolor/16x16/actions/appointment.svg
-share/icons/hicolor/22x22/actions/application-menu.svg
-share/icons/hicolor/24x24/actions/application-menu.svg
+share/icons/hicolor/16x16/actions/open-menu.svg
+share/icons/hicolor/22x22/actions/open-menu.svg
share/icons/hicolor/24x24/actions/appointment.svg
-share/icons/hicolor/32x32/actions/application-menu.svg
-share/icons/hicolor/48x48/actions/application-menu.svg
-share/icons/hicolor/scalable/actions/application-menu-symbolic.svg
+share/icons/hicolor/24x24/actions/open-menu.svg
+share/icons/hicolor/32x32/actions/open-menu.svg
+share/icons/hicolor/48x48/actions/open-menu.svg
+share/icons/hicolor/scalable/actions/open-menu-symbolic.svg
share/locale/af/LC_MESSAGES/granite.mo
share/locale/am/LC_MESSAGES/granite.mo
share/locale/ar/LC_MESSAGES/granite.mo
@@ -42,6 +42,7 @@ share/locale/he/LC_MESSAGES/granite.mo
share/locale/hi/LC_MESSAGES/granite.mo
share/locale/hr/LC_MESSAGES/granite.mo
share/locale/hu/LC_MESSAGES/granite.mo
+share/locale/hy/LC_MESSAGES/granite.mo
share/locale/id/LC_MESSAGES/granite.mo
share/locale/it/LC_MESSAGES/granite.mo
share/locale/ja/LC_MESSAGES/granite.mo
@@ -50,6 +51,7 @@ share/locale/lb/LC_MESSAGES/granite.mo
share/locale/lt/LC_MESSAGES/granite.mo
share/locale/lv/LC_MESSAGES/granite.mo
share/locale/ms/LC_MESSAGES/granite.mo
+share/locale/my/LC_MESSAGES/granite.mo
share/locale/nb/LC_MESSAGES/granite.mo
share/locale/nl/LC_MESSAGES/granite.mo
share/locale/nn/LC_MESSAGES/granite.mo