aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-06-19 17:33:31 +0800
committerasami <asami@FreeBSD.org>1997-06-19 17:33:31 +0800
commit572ebadc03b51379db830a10558e0442d696135b (patch)
tree1bee85eb85a45afd2ca156a99e4383c003f4fb92
parente6fb02edfc8970b0a6ab1773d25d3f4796b3ee07 (diff)
downloadfreebsd-ports-gnome-572ebadc03b51379db830a10558e0442d696135b.tar.gz
freebsd-ports-gnome-572ebadc03b51379db830a10558e0442d696135b.tar.zst
freebsd-ports-gnome-572ebadc03b51379db830a10558e0442d696135b.zip
REALLY make this compile and install correctly. Apparently the
XFree86-3.3 imake config files can't handle IncSubDir having more than one component ("X11/Xaw3d" in this case), so work around it by explicitly creating a symlink tree from post-extract (ugh).
-rw-r--r--x11-toolkits/Xaw3d/Makefile5
-rw-r--r--x11-toolkits/Xaw3d/files/patch-aa9
2 files changed, 12 insertions, 2 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 5c48b0866f56..081b912f52cb 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 November 1994
# Whom: asami
#
-# $Id: Makefile,v 1.12 1996/11/18 09:55:01 asami Exp $
+# $Id: Makefile,v 1.13 1997/06/12 01:36:35 asami Exp $
#
DISTNAME= Xaw3d-1.3
@@ -17,7 +17,8 @@ WRKSRC= ${WRKDIR}/xc/lib/Xaw3d
USE_IMAKE= yes
post-extract:
- /bin/ln -sf export/include ${WRKSRC}/X11
+ ${MKDIR} ${WRKSRC}/X11/Xaw3d
+ cd ${WRKSRC}/X11/Xaw3d; ln -sf ../../*.h .
post-install:
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/x11-toolkits/Xaw3d/files/patch-aa b/x11-toolkits/Xaw3d/files/patch-aa
index 2802c234786d..32b717f502dd 100644
--- a/x11-toolkits/Xaw3d/files/patch-aa
+++ b/x11-toolkits/Xaw3d/files/patch-aa
@@ -1,5 +1,14 @@
--- ./Imakefile.org Wed May 29 08:38:40 1996
+++ ./Imakefile Mon Aug 5 22:46:04 1996
+@@ -7,7 +7,7 @@
+ #define HasSharedData YES
+ #define LibName Xaw3d
+ #define SoRev SOXAWREV
+-#define IncSubdir Xaw3d
++#define IncSubdir X11/Xaw3d
+
+ #ifdef LinuxArchitecture
+ JUMP_ROOT_Xaw3d = $(AWIDGETSRC)3d
@@ -38,9 +38,9 @@
LINTLIBS = $(LINTXLIB) $(LINTXTOOL)