aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-04-29 08:11:21 +0800
committeracm <acm@FreeBSD.org>2009-04-29 08:11:21 +0800
commit5a8d10b33f32364ef08f0c16358b91aaff4ca79d (patch)
tree61da39dbd66156e528812367e295537b5fe7df7a
parent1520f78a800879d748703a5c95ac73361d416943 (diff)
downloadfreebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.tar.gz
freebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.tar.zst
freebsd-ports-gnome-5a8d10b33f32364ef08f0c16358b91aaff4ca79d.zip
- New port: games/naev and games/naev-data
NAEV is a 2d action/rpg space game that combines elements from the action, rpg and simulation genres. WWW: http://code.google.com/p/naev/
-rw-r--r--games/Makefile2
-rw-r--r--games/naev-data/Makefile35
-rw-r--r--games/naev-data/distinfo3
-rw-r--r--games/naev-data/pkg-descr4
-rw-r--r--games/naev/Makefile51
-rw-r--r--games/naev/distinfo3
-rw-r--r--games/naev/files/patch-Makefile16
-rw-r--r--games/naev/files/pkg-message.in11
-rw-r--r--games/naev/pkg-descr4
9 files changed, 129 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5244c3e2b835..41585422b271 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -531,6 +531,8 @@
SUBDIR += mvdsv
SUBDIR += nInvaders
SUBDIR += nadar
+ SUBDIR += naev
+ SUBDIR += naev-data
SUBDIR += nazghul
SUBDIR += nehquake
SUBDIR += nethack32
diff --git a/games/naev-data/Makefile b/games/naev-data/Makefile
new file mode 100644
index 000000000000..1269fcdde1c5
--- /dev/null
+++ b/games/naev-data/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: naev-data
+# Date created: 2009-04-26
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 0.3.9
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= naev-
+DISTNAME= ${PORTNAME:S/^/n/}-${PORTVERSION}
+EXTRACT_SUFX= #
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Naev game data file
+
+PROJECTHOST= ${PKGNAMEPREFIX:S/-//}
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX:S/-//}
+PLIST_FILES= share/${PKGNAMEPREFIX:S/-//}/${PORTNAME:S/^/n/}-${PORTVERSION}
+PLIST_DIRS= share/${PKGNAMEPREFIX:S/-//}
+
+do-extract:
+ @@${MKDIR} ${WRKSRC}
+ @${CP} ${_DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${DISTFILES} ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/naev-data/distinfo b/games/naev-data/distinfo
new file mode 100644
index 000000000000..257620d9d3ae
--- /dev/null
+++ b/games/naev-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (naev/ndata-0.3.9) = 83dd92bdf1f06bf9634db9df9c6dda0a
+SHA256 (naev/ndata-0.3.9) = a66efe693e12e0b028baca32f8e39adc423562cfb79123e891489d598a51ae17
+SIZE (naev/ndata-0.3.9) = 75841558
diff --git a/games/naev-data/pkg-descr b/games/naev-data/pkg-descr
new file mode 100644
index 000000000000..83dbc6a78516
--- /dev/null
+++ b/games/naev-data/pkg-descr
@@ -0,0 +1,4 @@
+NAEV is a 2d action/rpg space game that combines elements from the action, rpg
+and simulation genres (data file).
+
+WWW: http://code.google.com/p/naev/
diff --git a/games/naev/Makefile b/games/naev/Makefile
new file mode 100644
index 000000000000..f9206e2f87a4
--- /dev/null
+++ b/games/naev/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: naev
+# Date created: 2009-04-26
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= naev
+PORTVERSION= 0.3.9
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A 2d action/rpg space game
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/ndata-${PORTVERSION}:${PORTSDIR}/games/naev-data
+
+USE_BZIP2= yes
+USE_DOS2UNIX= conf.example
+USE_GL= gl
+USE_GMAKE= yes
+USE_GNOME= libxml2
+USE_SDL= sdl image mixer
+
+PLIST_FILES= bin/${PORTNAME}
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%DOCSDIR%%/conf.example
+PLIST_DIRS= %%DOCSDIR%%
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's|%%DATADIR%%|${DATADIR}|g' -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf.example ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/naev/distinfo b/games/naev/distinfo
new file mode 100644
index 000000000000..dd5d5c56f13e
--- /dev/null
+++ b/games/naev/distinfo
@@ -0,0 +1,3 @@
+MD5 (naev/naev-0.3.9.tar.bz2) = 964ad3d816a677a7f060bae8e93fb0fd
+SHA256 (naev/naev-0.3.9.tar.bz2) = c98618b517fb729ed06995eec8a02e6d0a4f95de2b7a073385acde9849765f54
+SIZE (naev/naev-0.3.9.tar.bz2) = 881254
diff --git a/games/naev/files/patch-Makefile b/games/naev/files/patch-Makefile
new file mode 100644
index 000000000000..70eca2f1266f
--- /dev/null
+++ b/games/naev/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile 2009-04-24 14:27:38.000000000 -0500
++++ Makefile 2009-04-28 17:32:14.000000000 -0500
+@@ -9,11 +9,11 @@
+ #
+ # Possible choices: LINUX|FREEBSD|WIN32|MACOSX
+ #
+-OS ?= LINUX
++OS ?= FREEBSD
+
+
+ # Data path
+-#NDATA_DEF := \"../ndata\"
++NDATA_DEF := \"%%DATADIR%%/ndata-%%PORTVERSION%%\"
+
+
+ ifeq ($(OS),LINUX)
diff --git a/games/naev/files/pkg-message.in b/games/naev/files/pkg-message.in
new file mode 100644
index 000000000000..c39502c02138
--- /dev/null
+++ b/games/naev/files/pkg-message.in
@@ -0,0 +1,11 @@
+###############################################################################
+
+The NAEV space game was installed
+
+1) You can find the conf.lua config file into your ~/.naev/ directory
+
+2) See the example of config file at %%DOCSDIR%%/conf.example
+
+3) Enjoy it :)
+
+###############################################################################
diff --git a/games/naev/pkg-descr b/games/naev/pkg-descr
new file mode 100644
index 000000000000..985f1c60e03a
--- /dev/null
+++ b/games/naev/pkg-descr
@@ -0,0 +1,4 @@
+NAEV is a 2d action/rpg space game that combines elements from the action, rpg
+and simulation genres.
+
+WWW: http://code.google.com/p/naev/