aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-21 00:01:36 +0800
committerpav <pav@FreeBSD.org>2005-07-21 00:01:36 +0800
commit5b8ffecefe68916cb0d50ea32037694edf1c8709 (patch)
tree561e44679e9d3beff185d1f266d5c5de141fe6d1
parent12da3cab52dd1ed6ab0451a9ac83dad25fdc23b5 (diff)
downloadfreebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.tar.gz
freebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.tar.zst
freebsd-ports-gnome-5b8ffecefe68916cb0d50ea32037694edf1c8709.zip
"Tux, of Math Command" ("TuxMath," for short) is an educational arcade game
starring Tux, the Linux mascot! Based on the classic arcade game "Missile Command," Tux must defend his cities. In this case, though, he must do it by solving math problems. PR: ports/83747 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
-rw-r--r--games/Makefile1
-rw-r--r--games/tuxmath/Makefile45
-rw-r--r--games/tuxmath/distinfo2
-rw-r--r--games/tuxmath/files/patch-Makefile27
-rw-r--r--games/tuxmath/pkg-descr10
-rw-r--r--games/tuxmath/pkg-plist104
6 files changed, 189 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index dd2765df8f86..86cc6c3b7db9 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -513,6 +513,7 @@
SUBDIR += ttt
SUBDIR += tux-aqfh
SUBDIR += tuxkart
+ SUBDIR += tuxmath
SUBDIR += tuxpaint
SUBDIR += tuxpaint-fonts
SUBDIR += tuxpaint-stamps
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
new file mode 100644
index 000000000000..155487b42252
--- /dev/null
+++ b/games/tuxmath/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tuxmath
+# Date created: 14 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxmath
+DISTVERSION= 2001.09.07-0102
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Educational arcade game starring Tux
+
+USE_GMAKE= yes
+USE_SDL= image mixer sdl
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-extract:
+# Remove CVS and .xvpics directories
+.for d in CVS .xvpics
+ @${FIND} ${WRKSRC} -type d -name ${d} -print0 | \
+ ${XARGS} -0 ${RM} -rf
+.endfor
+
+post-install:
+# Fix permissions
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644
+ @${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|/usr/share/tuxmath|${DATADIR}| ; \
+ s|\(BIN_PREFIX=\).*|\1${PREFIX}/bin/| ; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/games/tuxmath/distinfo b/games/tuxmath/distinfo
new file mode 100644
index 000000000000..47b46310e895
--- /dev/null
+++ b/games/tuxmath/distinfo
@@ -0,0 +1,2 @@
+MD5 (tuxmath-2001.09.07-0102.tar.gz) = 435ba5d937106ca8b7da46c1a95a0d8c
+SIZE (tuxmath-2001.09.07-0102.tar.gz) = 1339967
diff --git a/games/tuxmath/files/patch-Makefile b/games/tuxmath/files/patch-Makefile
new file mode 100644
index 000000000000..58b0a5944cf7
--- /dev/null
+++ b/games/tuxmath/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Fri Sep 7 04:40:21 2001
++++ Makefile Thu Jul 14 19:46:18 2005
+@@ -6,7 +6,7 @@
+ # 2001.Aug.26 - 2001.Sep.07
+
+
+-CFLAGS=-Wall -O2 $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -DDEBUG \
++CFLAGS+= $(SDL_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" -DDEBUG \
+ -DVERSION=\"$(VERSION)\" -D$(SOUND)SOUND
+
+ SDL_CFLAGS=$(shell sdl-config --cflags)
+@@ -30,14 +30,10 @@
+
+ install:
+ @echo "COPYING BINARY TO $(BIN_PREFIX)"
+- cp tuxmath $(BIN_PREFIX)
+- chown root.root $(BIN_PREFIX)/tuxmath
+- chmod a+rx,g-w,o-w $(BIN_PREFIX)/tuxmath
++ $(BSD_INSTALL_PROGRAM) tuxmath $(BIN_PREFIX)
+ @echo "COPYING DATA FILES TO $(DATA_PREFIX)"
+ mkdir -p $(DATA_PREFIX)
+ cp -r data/* $(DATA_PREFIX)
+- chown -R root.root $(DATA_PREFIX)
+- chmod -R a+rX,g-w,o-w $(DATA_PREFIX)
+
+ clean:
+ -rm tuxmath
diff --git a/games/tuxmath/pkg-descr b/games/tuxmath/pkg-descr
new file mode 100644
index 000000000000..b4494e23d725
--- /dev/null
+++ b/games/tuxmath/pkg-descr
@@ -0,0 +1,10 @@
+"Tux, of Math Command" ("TuxMath," for short) is an educational arcade game
+starring Tux, the Linux mascot!
+
+Based on the classic arcade game "Missile Command," Tux must defend his
+cities. In this case, though, he must do it by solving math problems.
+
+WWW: http://www.newbreedsoftware.com/tuxmath/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/tuxmath/pkg-plist b/games/tuxmath/pkg-plist
new file mode 100644
index 000000000000..837a39d08efa
--- /dev/null
+++ b/games/tuxmath/pkg-plist
@@ -0,0 +1,104 @@
+bin/tuxmath
+%%DATADIR%%/images/alpha.png
+%%DATADIR%%/images/backgrounds/0.jpg
+%%DATADIR%%/images/backgrounds/1.jpg
+%%DATADIR%%/images/backgrounds/2.jpg
+%%DATADIR%%/images/backgrounds/3.jpg
+%%DATADIR%%/images/backgrounds/4.jpg
+%%DATADIR%%/images/cities/cdead-blue.png
+%%DATADIR%%/images/cities/cdead-green.png
+%%DATADIR%%/images/cities/cdead-orange.png
+%%DATADIR%%/images/cities/cdead-red.png
+%%DATADIR%%/images/cities/city-blue.png
+%%DATADIR%%/images/cities/city-green.png
+%%DATADIR%%/images/cities/city-orange.png
+%%DATADIR%%/images/cities/city-red.png
+%%DATADIR%%/images/cities/csplode-blue-1.png
+%%DATADIR%%/images/cities/csplode-blue-2.png
+%%DATADIR%%/images/cities/csplode-blue-3.png
+%%DATADIR%%/images/cities/csplode-blue-4.png
+%%DATADIR%%/images/cities/csplode-blue-5.png
+%%DATADIR%%/images/cities/csplode-green-1.png
+%%DATADIR%%/images/cities/csplode-green-2.png
+%%DATADIR%%/images/cities/csplode-green-3.png
+%%DATADIR%%/images/cities/csplode-green-4.png
+%%DATADIR%%/images/cities/csplode-green-5.png
+%%DATADIR%%/images/cities/csplode-orange-1.png
+%%DATADIR%%/images/cities/csplode-orange-2.png
+%%DATADIR%%/images/cities/csplode-orange-3.png
+%%DATADIR%%/images/cities/csplode-orange-4.png
+%%DATADIR%%/images/cities/csplode-orange-5.png
+%%DATADIR%%/images/cities/csplode-red-1.png
+%%DATADIR%%/images/cities/csplode-red-2.png
+%%DATADIR%%/images/cities/csplode-red-3.png
+%%DATADIR%%/images/cities/csplode-red-4.png
+%%DATADIR%%/images/cities/csplode-red-5.png
+%%DATADIR%%/images/cities/shields.png
+%%DATADIR%%/images/comets/comet1.png
+%%DATADIR%%/images/comets/comet2.png
+%%DATADIR%%/images/comets/comet3.png
+%%DATADIR%%/images/comets/cometex1.png
+%%DATADIR%%/images/comets/cometex2.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/options-devel.jpg
+%%DATADIR%%/images/status/cmd_credits.png
+%%DATADIR%%/images/status/cmd_options.png
+%%DATADIR%%/images/status/cmd_play.png
+%%DATADIR%%/images/status/cmd_quit.png
+%%DATADIR%%/images/status/demo-small.png
+%%DATADIR%%/images/status/demo.png
+%%DATADIR%%/images/status/gameover.png
+%%DATADIR%%/images/status/keypad.png
+%%DATADIR%%/images/status/lednums.png
+%%DATADIR%%/images/status/loading.png
+%%DATADIR%%/images/status/nbs.png
+%%DATADIR%%/images/status/numbers.png
+%%DATADIR%%/images/status/nums.png
+%%DATADIR%%/images/status/paused.png
+%%DATADIR%%/images/status/score.png
+%%DATADIR%%/images/status/standby.png
+%%DATADIR%%/images/status/title.png
+%%DATADIR%%/images/status/tux4kids.png
+%%DATADIR%%/images/status/tux_helmet1.png
+%%DATADIR%%/images/status/tux_helmet2.png
+%%DATADIR%%/images/status/tux_helmet3.png
+%%DATADIR%%/images/status/wave.png
+%%DATADIR%%/images/tux/console.png
+%%DATADIR%%/images/tux/tux-console1.png
+%%DATADIR%%/images/tux/tux-console2.png
+%%DATADIR%%/images/tux/tux-console3.png
+%%DATADIR%%/images/tux/tux-console4.png
+%%DATADIR%%/images/tux/tux-drat.png
+%%DATADIR%%/images/tux/tux-egypt1.png
+%%DATADIR%%/images/tux/tux-egypt2.png
+%%DATADIR%%/images/tux/tux-fist1.png
+%%DATADIR%%/images/tux/tux-fist2.png
+%%DATADIR%%/images/tux/tux-kiss1.png
+%%DATADIR%%/images/tux/tux-kiss2.png
+%%DATADIR%%/images/tux/tux-relax1.png
+%%DATADIR%%/images/tux/tux-relax2.png
+%%DATADIR%%/images/tux/tux-sit.png
+%%DATADIR%%/images/tux/tux-yay1.png
+%%DATADIR%%/images/tux/tux-yay2.png
+%%DATADIR%%/images/tux/tux-yes1.png
+%%DATADIR%%/images/tux/tux-yes2.png
+%%DATADIR%%/images/tux/tux-yipe.png
+%%DATADIR%%/sounds/alarm.wav
+%%DATADIR%%/sounds/buzz.wav
+%%DATADIR%%/sounds/click.wav
+%%DATADIR%%/sounds/explosion.wav
+%%DATADIR%%/sounds/game.mod
+%%DATADIR%%/sounds/game2.mod
+%%DATADIR%%/sounds/game3.mod
+%%DATADIR%%/sounds/laser.wav
+%%DATADIR%%/sounds/pop.wav
+%%DATADIR%%/sounds/shieldsdown.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/images/ufos
+@dirrm %%DATADIR%%/images/tux
+@dirrm %%DATADIR%%/images/status
+@dirrm %%DATADIR%%/images/comets
+@dirrm %%DATADIR%%/images/cities
+@dirrm %%DATADIR%%/images/backgrounds
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%