aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-10-01 19:44:04 +0800
committertg <tg@FreeBSD.org>2001-10-01 19:44:04 +0800
commit5dcb04c4f01e031f339a3bbaaca6f20393ffae87 (patch)
tree27d0ef57936563f71f6aaa26cfa410bae7c808cf
parenta54c435c001f4e4aea55f4ea827cd6b48aeda2fa (diff)
downloadfreebsd-ports-gnome-5dcb04c4f01e031f339a3bbaaca6f20393ffae87.tar.gz
freebsd-ports-gnome-5dcb04c4f01e031f339a3bbaaca6f20393ffae87.tar.zst
freebsd-ports-gnome-5dcb04c4f01e031f339a3bbaaca6f20393ffae87.zip
New port pantomime. Pantomime is a mail/MIME handling library for GNUstep.
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pantomime/Makefile47
-rw-r--r--mail/pantomime/distinfo1
-rw-r--r--mail/pantomime/pkg-comment1
-rw-r--r--mail/pantomime/pkg-descr1
-rw-r--r--mail/pantomime/pkg-plist56
6 files changed, 107 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 13885e66022a..bfb90551fd79 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -132,6 +132,7 @@
SUBDIR += p5-Mail-Sendmail
SUBDIR += p5-Mail-Tools
SUBDIR += p5-Mail-Verify
+ SUBDIR += pantomime
SUBDIR += pathalias
SUBDIR += perdition
SUBDIR += pflogsumm
diff --git a/mail/pantomime/Makefile b/mail/pantomime/Makefile
new file mode 100644
index 000000000000..4bac818a64ec
--- /dev/null
+++ b/mail/pantomime/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Pantomime
+# Date created: 17 Sep 2001
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pantomime
+PORTVERSION= 0.4.0
+CATEGORIES= mail
+MASTER_SITES= http://www.gnustep.it/nicola/Applications/
+DISTNAME= Pantomime-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${XGPSBUNDLEDIR}/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
+RUN_DEPENDS= ${XGPSBUNDLEDIR}/libgnustep-xgps:${PORTSDIR}/x11-toolkits/gnustep-xgps
+
+PREFIX= ${LOCALBASE}/GNUstep
+WRKSRC= ${WRKDIR}/Pantomime
+USE_NEWGCC= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+
+XGPSBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-xgps.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>
diff --git a/mail/pantomime/distinfo b/mail/pantomime/distinfo
new file mode 100644
index 000000000000..d747b31ef6e4
--- /dev/null
+++ b/mail/pantomime/distinfo
@@ -0,0 +1 @@
+MD5 (Pantomime-0.4.0.tar.gz) = 16f7b2c6a2e96ce6101909c70475bd51
diff --git a/mail/pantomime/pkg-comment b/mail/pantomime/pkg-comment
new file mode 100644
index 000000000000..3c8e3a97ca31
--- /dev/null
+++ b/mail/pantomime/pkg-comment
@@ -0,0 +1 @@
+Mail/MIME handling library for GNUstep
diff --git a/mail/pantomime/pkg-descr b/mail/pantomime/pkg-descr
new file mode 100644
index 000000000000..7f0689d99d74
--- /dev/null
+++ b/mail/pantomime/pkg-descr
@@ -0,0 +1 @@
+Mail/MIME handling library for GNUstep.
diff --git a/mail/pantomime/pkg-plist b/mail/pantomime/pkg-plist
new file mode 100644
index 000000000000..7020d5c16a7e
--- /dev/null
+++ b/mail/pantomime/pkg-plist
@@ -0,0 +1,56 @@
+Local/Headers/Pantomime/Charset.h
+Local/Headers/Pantomime/Constants.h
+Local/Headers/Pantomime/Flags.h
+Local/Headers/Pantomime/Folder.h
+Local/Headers/Pantomime/IMAPCacheManager.h
+Local/Headers/Pantomime/IMAPCacheObject.h
+Local/Headers/Pantomime/IMAPFolder.h
+Local/Headers/Pantomime/IMAPMessage.h
+Local/Headers/Pantomime/IMAPStore.h
+Local/Headers/Pantomime/ISO8859_1.h
+Local/Headers/Pantomime/ISO8859_10.h
+Local/Headers/Pantomime/ISO8859_11.h
+Local/Headers/Pantomime/ISO8859_13.h
+Local/Headers/Pantomime/ISO8859_14.h
+Local/Headers/Pantomime/ISO8859_15.h
+Local/Headers/Pantomime/ISO8859_2.h
+Local/Headers/Pantomime/ISO8859_3.h
+Local/Headers/Pantomime/ISO8859_4.h
+Local/Headers/Pantomime/ISO8859_5.h
+Local/Headers/Pantomime/ISO8859_6.h
+Local/Headers/Pantomime/ISO8859_7.h
+Local/Headers/Pantomime/ISO8859_8.h
+Local/Headers/Pantomime/ISO8859_9.h
+Local/Headers/Pantomime/InternetAddress.h
+Local/Headers/Pantomime/LocalFolder.h
+Local/Headers/Pantomime/LocalMessage.h
+Local/Headers/Pantomime/LocalStore.h
+Local/Headers/Pantomime/Message.h
+Local/Headers/Pantomime/MimeBodyPart.h
+Local/Headers/Pantomime/MimeMultipart.h
+Local/Headers/Pantomime/MimeUtility.h
+Local/Headers/Pantomime/NSStringExtensions.h
+Local/Headers/Pantomime/POP3CacheManager.h
+Local/Headers/Pantomime/POP3CacheObject.h
+Local/Headers/Pantomime/POP3Folder.h
+Local/Headers/Pantomime/POP3Message.h
+Local/Headers/Pantomime/POP3Store.h
+Local/Headers/Pantomime/Parser.h
+Local/Headers/Pantomime/Part.h
+Local/Headers/Pantomime/SMTP.h
+Local/Headers/Pantomime/Sendmail.h
+Local/Headers/Pantomime/Service.h
+Local/Headers/Pantomime/Store.h
+Local/Headers/Pantomime/Transport.h
+Local/Headers/Pantomime/elm_defs.h
+Local/Headers/Pantomime/elm_lib.h
+Local/Headers/Pantomime/parseaddrs.h
+Local/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPantomime.so
+Local/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPantomime.so.1
+Local/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu/libPantomime.so.1.0.0
+@dirrm Local/Libraries/%%GNU_ARCH%%/%%OPSYS%%/gnu-gnu-gnu
+@dirrm Local/Libraries/%%GNU_ARCH%%/%%OPSYS%%
+@dirrm Local/Libraries/%%GNU_ARCH%%
+@dirrm Local/Libraries
+@dirrm Local/Headers/Pantomime
+@dirrm Local/Headers