aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-14 23:53:48 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-14 23:53:48 +0800
commit5dfe02757d588297caa086de52647eaa3b50bb42 (patch)
tree7c09470400f03b33153d1f94c7d98a246c93f0d7
parent3975bad9a1d9838302299569f88875dae026735f (diff)
downloadfreebsd-ports-gnome-5dfe02757d588297caa086de52647eaa3b50bb42.tar.gz
freebsd-ports-gnome-5dfe02757d588297caa086de52647eaa3b50bb42.tar.zst
freebsd-ports-gnome-5dfe02757d588297caa086de52647eaa3b50bb42.zip
add hafiye 1.0
Multi Platform Customizable TCP/IP Packet Sniffer
-rw-r--r--security/Makefile1
-rw-r--r--security/hafiye/Makefile29
-rw-r--r--security/hafiye/distinfo1
-rw-r--r--security/hafiye/pkg-comment1
-rw-r--r--security/hafiye/pkg-descr18
-rw-r--r--security/hafiye/pkg-plist10
6 files changed, 60 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5e1ddc412590..602224fd8b85 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -69,6 +69,7 @@
SUBDIR += gringotts
SUBDIR += gtk-knocker
SUBDIR += gtkportscan
+ SUBDIR += hafiye
SUBDIR += hashish
SUBDIR += heimdal
SUBDIR += hlfl
diff --git a/security/hafiye/Makefile b/security/hafiye/Makefile
new file mode 100644
index 000000000000..6f24e494e0db
--- /dev/null
+++ b/security/hafiye/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: hafiye
+# Date Created: Aug 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= hafiye
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.enderunix.org/hafiye/ \
+ http://www.acikkod.org/hafiye/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+MAKE_ENV= LDFLAGS="-lpcap"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g ; s|^CFLAGS|#CFLAGS|g ; \
+ s|^LDFLAGS|#LDFLAGS|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hafiye ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/KB/* ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/security/hafiye/distinfo b/security/hafiye/distinfo
new file mode 100644
index 000000000000..b8959eb817a8
--- /dev/null
+++ b/security/hafiye/distinfo
@@ -0,0 +1 @@
+MD5 (hafiye-1.0.tar.gz) = 5537acb500e9c78d448d7a9dea46f560
diff --git a/security/hafiye/pkg-comment b/security/hafiye/pkg-comment
new file mode 100644
index 000000000000..94719ac1bb0b
--- /dev/null
+++ b/security/hafiye/pkg-comment
@@ -0,0 +1 @@
+Multi Platform Customizable TCP/IP Packet Sniffer
diff --git a/security/hafiye/pkg-descr b/security/hafiye/pkg-descr
new file mode 100644
index 000000000000..4b80ba1576b1
--- /dev/null
+++ b/security/hafiye/pkg-descr
@@ -0,0 +1,18 @@
+When I looked at the source code for various famous sniffers, I've noticed
+that they all had all seperate .C files for interpreting various protocols.
+Why not have a sniffer that can understand user-supplied protocol details?
+Here it is.
+
+When fired, Hafiye first visits each sub-directory under its knowledge-base
+directory and opens to see whether it is a protocol knowledge-base file. If
+so, It loads the necessary information from that file and places it into its
+memory space. After constructing the supplied knowledge-base, Hafiye starts
+looping for receiving packets. When a packet arrives, it demultiplexes the
+layers according to its knowledge-base and prints protocol-based information.
+
+Features
+ - Multi Platform Support (Posix Compliant)
+ - Customizable Protocol Definitions (Layer II, III and IV)
+ - Customizable Packet Interpretation (Layer II, III and IV)
+
+WWW: http://www.enderunix.org/hafiye/
diff --git a/security/hafiye/pkg-plist b/security/hafiye/pkg-plist
new file mode 100644
index 000000000000..c5e0fa92e1c2
--- /dev/null
+++ b/security/hafiye/pkg-plist
@@ -0,0 +1,10 @@
+bin/hafiye
+share/hafiye/LII/IP
+share/hafiye/LIII/ICMP
+share/hafiye/LIII/TCP
+share/hafiye/LIII/UDP
+share/hafiye/LIV/DNS
+@dirrm share/hafiye/LII
+@dirrm share/hafiye/LIII
+@dirrm share/hafiye/LIV
+@dirrm share/hafiye