aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-02-25 00:31:26 +0800
committerdinoex <dinoex@FreeBSD.org>2004-02-25 00:31:26 +0800
commit6033162f58ccb8834b290e4c96289e9b7eb4a558 (patch)
treedd391108f814cb938d325bf56f6c17377472b014
parent50c84dbd2c566601ad161305a8cd3d55d38ab01f (diff)
downloadfreebsd-ports-gnome-6033162f58ccb8834b290e4c96289e9b7eb4a558.tar.gz
freebsd-ports-gnome-6033162f58ccb8834b290e4c96289e9b7eb4a558.tar.zst
freebsd-ports-gnome-6033162f58ccb8834b290e4c96289e9b7eb4a558.zip
- suppress pkg-message when STANDALONE_POP3 is defined (while building)
PR: 63309 Submitted by: Linh Pham - suppress pkg-message and pkg-deinstall when STANDALONE_POP3 is defined so the package will print neither. - adds CONFLICTS with own variants.
-rw-r--r--mail/popa3d/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index 3675d7061229..b7bef9d2341d 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -25,16 +25,21 @@ ALL_TARGET= popa3d
MAN8= popa3d.8
PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
+.if defined(STANDALONE_POP3)
+PLIST_SUB+= STANDALONE_POP3=""
+CONFLICTS?= popa3d-0.* popa3d-before-sendmail-0.*
+PKGMESSAGE= ${NONEXISTENT}
+PKGDEINSTALL= ${NONEXISTENT}
+.else
+PLIST_SUB+= STANDALONE_POP3="@comment "
+.endif
.if defined(SMTP_AFTER_POP3)
EXTRA_PATCHES+= ${FILESDIR}/pop-before-sendmail.patch
PLIST_SUB+= SMTP_AFTER_POP3=""
+CONFLICTS?= popa3d-0.* popa3d-standalone-0.*
.else
PLIST_SUB+= SMTP_AFTER_POP3="@comment "
-.endif
-.if defined(STANDALONE_POP3)
-PLIST_SUB+= STANDALONE_POP3=""
-.else
-PLIST_SUB+= STANDALONE_POP3="@comment "
+CONFLICTS?= popa3d-standalone-0.* popa3d-before-sendmail-0.*
.endif
.if defined(STANDALONE_POP3)
@@ -85,8 +90,10 @@ do-install:
.endif
.endif
+.if !defined(STANDALONE_POP3)
post-install:
@ ${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>