aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-07-06 19:29:13 +0800
committerkwm <kwm@FreeBSD.org>2005-07-06 19:29:13 +0800
commit60825e09e7112f837a9028dfefc482bf5d914ee7 (patch)
treeff763a4e27cd11be2de9fd80b68f50bf6c1e9bd6
parent9a8894dd82a86e15ded0f24d7826998446667497 (diff)
downloadfreebsd-ports-gnome-60825e09e7112f837a9028dfefc482bf5d914ee7.tar.gz
freebsd-ports-gnome-60825e09e7112f837a9028dfefc482bf5d914ee7.tar.zst
freebsd-ports-gnome-60825e09e7112f837a9028dfefc482bf5d914ee7.zip
Add wavpack.
Wavepack is a completely open audio compression format providing lossless, high-quality lossy, and a unique hybrid compression mode. In the default lossless mode no original information is lost, so there is no change of degradation. Compression in this mode is between 30% an 70%. For more info see the website http://www.wavpack.com
-rw-r--r--CVSROOT/modules1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/wavpack/Makefile29
-rw-r--r--audio/wavpack/distinfo2
-rw-r--r--audio/wavpack/pkg-descr15
-rw-r--r--audio/wavpack/pkg-plist11
6 files changed, 59 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index a6846a215519..81101368b6a8 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -12113,6 +12113,7 @@ washerdryer ports/x11-clocks/washerdryer
watchdog ports/sysutils/watchdog
wavbreaker ports/audio/wavbreaker
waveplay ports/audio/waveplay
+wavpack ports/audio/wavpack
wavplay ports/audio/wavplay
wb ports/mbone/wb
wb0 ports/www/wb0
diff --git a/audio/Makefile b/audio/Makefile
index 268dfb604a17..bd650da25a95 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -478,6 +478,7 @@
SUBDIR += vsound
SUBDIR += wavbreaker
SUBDIR += waveplay
+ SUBDIR += wavpack
SUBDIR += wavplay
SUBDIR += wmalbum
SUBDIR += wmcdplay
diff --git a/audio/wavpack/Makefile b/audio/wavpack/Makefile
new file mode 100644
index 000000000000..afe1a8a45156
--- /dev/null
+++ b/audio/wavpack/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wavpack
+# Date created: Fri Jun 24 20:30:04 CEST 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wavpack
+PORTVERSION= 4.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kwm
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Compress (and restore) both 16 and 24-bit audio files in .wav format
+
+USE_LIBTOOL_VER=15
+USE_BZIP2= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/wavpack/distinfo b/audio/wavpack/distinfo
new file mode 100644
index 000000000000..06efb442bf55
--- /dev/null
+++ b/audio/wavpack/distinfo
@@ -0,0 +1,2 @@
+MD5 (wavpack-4.2.tar.bz2) = 702cf0492f97c83e35973944ec083ab8
+SIZE (wavpack-4.2.tar.bz2) = 278576
diff --git a/audio/wavpack/pkg-descr b/audio/wavpack/pkg-descr
new file mode 100644
index 000000000000..3723cb0c7890
--- /dev/null
+++ b/audio/wavpack/pkg-descr
@@ -0,0 +1,15 @@
+WavPack allows users to compress (and restore) both 16 and 24-bit audio files
+in the .WAV format. It also supports multichannel streams and high frequency
+sampling rates. Like other lossless compression schemes the data reduction
+varies with the source, but it is generally between 25% and 50% for typical
+popular music and somewhat better than that for classical music and other
+sources with greater dynamic range.
+
+WavPack also incorporates a unique "hybrid" mode that provides all the
+advantages of lossless compression with an additional bonus. Instead of
+creating a single file, this mode creates both a relatively small, high-quality
+lossy file that can be used all by itself, and a "correction" file that (when
+combined with the lossy file) provides full lossless restoration. For some
+users, this means never having to choose between lossless and lossy compression.
+
+WWW: http://www.wavpack.com/
diff --git a/audio/wavpack/pkg-plist b/audio/wavpack/pkg-plist
new file mode 100644
index 000000000000..bd0d35a9e50c
--- /dev/null
+++ b/audio/wavpack/pkg-plist
@@ -0,0 +1,11 @@
+bin/wavpack
+bin/wvunpack
+include/wavpack/md5.h
+include/wavpack/unpack3.h
+include/wavpack/wavpack.h
+include/wavpack/wputils.h
+lib/libwavpack.a
+lib/libwavpack.so
+lib/libwavpack.so.0
+libdata/pkgconfig/wavpack.pc
+@dirrm include/wavpack