aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-16 01:18:09 +0800
committeraaron <aaron@FreeBSD.org>2006-05-16 01:18:09 +0800
commit651c0650c82f1ee48ebafbf10ed9f09330e229a9 (patch)
tree4e952959014f359546984f3d1a7b6fa69e525adf
parent508789c2e9e5f492a59b8d9c558b7129f15e8d58 (diff)
downloadfreebsd-ports-gnome-651c0650c82f1ee48ebafbf10ed9f09330e229a9.tar.gz
freebsd-ports-gnome-651c0650c82f1ee48ebafbf10ed9f09330e229a9.tar.zst
freebsd-ports-gnome-651c0650c82f1ee48ebafbf10ed9f09330e229a9.zip
Adding port math/p5-Math-Series, a Perl extension dealing with mathematic series
Approved by: tobez (implicit)
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Series/Makefile26
-rw-r--r--math/p5-Math-Series/distinfo3
-rw-r--r--math/p5-Math-Series/pkg-descr28
-rw-r--r--math/p5-Math-Series/pkg-plist5
5 files changed, 63 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e2be70aa9ef5..418efa43fda0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -188,6 +188,7 @@
SUBDIR += p5-Math-Random-MT
SUBDIR += p5-Math-Round
SUBDIR += p5-Math-Sequence
+ SUBDIR += p5-Math-Series
SUBDIR += p5-Math-SimpleVariable
SUBDIR += p5-Math-Spline
SUBDIR += p5-Math-Symbolic
diff --git a/math/p5-Math-Series/Makefile b/math/p5-Math-Series/Makefile
new file mode 100644
index 000000000000..8c2c95089a77
--- /dev/null
+++ b/math/p5-Math-Series/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Math-Series
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Series
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension dealing with mathematic series
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/Sequence.pm:${PORTSDIR}/math/p5-Math-Sequence
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Series.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Series/distinfo b/math/p5-Math-Series/distinfo
new file mode 100644
index 000000000000..cf0dbb5f59dd
--- /dev/null
+++ b/math/p5-Math-Series/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Series-1.01.tar.gz) = 1ab394433e6614333e263e209677ae0a
+SHA256 (Math-Series-1.01.tar.gz) = 7313442021d459a5b387dae4effc258ee3db755a111f9fbbe9bb1aca1352570a
+SIZE (Math-Series-1.01.tar.gz) = 5762
diff --git a/math/p5-Math-Series/pkg-descr b/math/p5-Math-Series/pkg-descr
new file mode 100644
index 000000000000..9d9ecdfddbc0
--- /dev/null
+++ b/math/p5-Math-Series/pkg-descr
@@ -0,0 +1,28 @@
+Math::Series defines a class for simple mathematic series with a recursive
+definition such as x_(n+1) = 1 / (x_n + 1). Such a recursive definition is
+treated as a sequence whose elements will be added to form a series. You
+can refer to the previous sequence element as well as to the current index
+in the series. Creation of a Math::Series object is described below in the
+paragraph about the constructor.
+
+Math::Series uses Math::Symbolic to parse and modify the recursive
+sequence definitions. That means you specify the sequence as a string
+which is parsed by Math::Symbolic. Alternatively, you can pass the
+constructor a Math::Symbolic tree directly.
+
+Because Math::Series uses Math::Symbolic for its implementation, all
+results will be Math::Symbolic objects which may contain other variables
+than the sequence variable and the iterator variable.
+
+Each Math::Series object is an iterator to iterate over the elements of
+the series starting at the first element (which was specified by the
+starting element, the second argument to the new() constructor). It offers
+facilities to cache all calculated elements and access any element
+directly, though unless the element has been cached in a previous
+calculation, this is just a shortcut for repeated use of the iterator.
+
+Every element in the series may only access its predecessor, not the
+elements before that.
+
+WWW: http://search.cpan.org/dist/Math-Series
+Author: Steffen Mueller <series-module@steffen-mueller.net>
diff --git a/math/p5-Math-Series/pkg-plist b/math/p5-Math-Series/pkg-plist
new file mode 100644
index 000000000000..52e4e638273b
--- /dev/null
+++ b/math/p5-Math-Series/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Series.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Series/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Series
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math