aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-13 14:19:01 +0800
committerbapt <bapt@FreeBSD.org>2011-09-13 14:19:01 +0800
commit656131623cecc4d24ae910ec9aa0384a008bbb29 (patch)
tree69702c9349cf88f2dc67223a31c48a8827f00697
parentd06bce2bae6a0c5332571ff1e1ae770f678ab953 (diff)
downloadfreebsd-ports-gnome-656131623cecc4d24ae910ec9aa0384a008bbb29.tar.gz
freebsd-ports-gnome-656131623cecc4d24ae910ec9aa0384a008bbb29.tar.zst
freebsd-ports-gnome-656131623cecc4d24ae910ec9aa0384a008bbb29.zip
Fix bad usage of sed
Fix typo This should fix the plist problems Reported by: kwm, pointyhat (pav)
-rw-r--r--editors/libreoffice/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index bb1b1d9ab4b2..2f3b96ae6a3d 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -421,13 +421,14 @@ post-install:
.for subdir in application-registry applications icons mime mime-info mimelnk
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s share/${subdir} \( -type f -o -type l \) -print >> ${PLISTF}
@cd ${LODESTDIR}/${PREFIX}/ && ${FIND} -d share/${subdir} -type d \
- -exec ${ECHO_CMD} "@exec ${RMDIR} %D/{} 2>/dev/null || ${TRUE}" \; >> ${PLISTD}
+ -exec ${ECHO_CMD} "@unexec ${RMDIR} %D/{} 2>/dev/null || ${TRUE}" \; >> ${PLISTD}
.endfor
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s bin \( -type f -o -type l \) -print >> ${PLISTF}
#Fix .desktop files
- @${FIND} ${LODESTDIR}/${PREFIX} -name *.desktop -type f -exec ${SED} -i"" -e 's|office34|office|g; s|office3.4|office|g' {} \;
+ @${FIND} ${LODESTDIR}/${PREFIX} -name *.desktop -type f -exec ${SED} -i .bak -e 's|office34|office|g; s|office3.4|office|g' {} \;
+ @${FIND} ${LODESTDIR}/${PREFIX} -name *.desktop.bak -delete
.if defined(WITH_GTK) || defined(WITH_GNOME)
@${ECHO_CMD} "@exec ${LOCALBASE}/bin/update-desktop-database > /dev/null || ${TRUE}" >> ${TMPPLIST}