aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-02 06:01:53 +0800
committermiwi <miwi@FreeBSD.org>2008-11-02 06:01:53 +0800
commit656382fc94ad0694cad381d5ba9fa3db90843824 (patch)
treeed71ad751143189b8e5f46c8f70946ae783204d2
parentac4b001be37f06c273bf758a3149f915db07b1da (diff)
downloadfreebsd-ports-gnome-656382fc94ad0694cad381d5ba9fa3db90843824.tar.gz
freebsd-ports-gnome-656382fc94ad0694cad381d5ba9fa3db90843824.tar.zst
freebsd-ports-gnome-656382fc94ad0694cad381d5ba9fa3db90843824.zip
PyFITS provides an interface to FITS formatted files
under the Python scripting language. It is useful for interactive data analysis and for writing analysis scripts in Python using FITS files as either input or output. PyFITS is a development project of the Science Software Branch at the Space Telescope Science Institute. WWW: http://www.stsci.edu/resources/software_hardware/pyfits PR: ports/128456 Submitted by: Wen Heping <wenheping at gmail.com>
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-pyfits/Makefile23
-rw-r--r--astro/py-pyfits/distinfo3
-rw-r--r--astro/py-pyfits/pkg-descr8
-rw-r--r--astro/py-pyfits/pkg-plist13
5 files changed, 48 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 752f6a3f6437..fc33cfc4afa5 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -56,6 +56,7 @@
SUBDIR += pp3
SUBDIR += ptiger
SUBDIR += py-metar
+ SUBDIR += py-pyfits
SUBDIR += pyephem
SUBDIR += pyweather
SUBDIR += rmap
diff --git a/astro/py-pyfits/Makefile b/astro/py-pyfits/Makefile
new file mode 100644
index 000000000000..0a68dfd7bc29
--- /dev/null
+++ b/astro/py-pyfits/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pyfits
+# Date created: 2008-10-28
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyfits
+PORTVERSION= 1.3
+CATEGORIES= astro python
+MASTER_SITES= http://www.stsci.edu/resources/software_hardware/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Interface to FITS Formatted Files
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/astro/py-pyfits/distinfo b/astro/py-pyfits/distinfo
new file mode 100644
index 000000000000..43f9000ad470
--- /dev/null
+++ b/astro/py-pyfits/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyfits-1.3.tar.gz) = 59c3c8c714336eab7760b7d320e124c3
+SHA256 (pyfits-1.3.tar.gz) = a6b01c9d75e7955765019581700bd6ac344457b327522facedaf4cff9e86093c
+SIZE (pyfits-1.3.tar.gz) = 3425265
diff --git a/astro/py-pyfits/pkg-descr b/astro/py-pyfits/pkg-descr
new file mode 100644
index 000000000000..a71e57ab8673
--- /dev/null
+++ b/astro/py-pyfits/pkg-descr
@@ -0,0 +1,8 @@
+PyFITS provides an interface to FITS formatted files
+under the Python scripting language. It is useful for
+interactive data analysis and for writing analysis
+scripts in Python using FITS files as either input or
+output. PyFITS is a development project of the Science
+Software Branch at the Space Telescope Science Institute.
+
+WWW: http://www.stsci.edu/resources/software_hardware/pyfits
diff --git a/astro/py-pyfits/pkg-plist b/astro/py-pyfits/pkg-plist
new file mode 100644
index 000000000000..5465ad1365af
--- /dev/null
+++ b/astro/py-pyfits/pkg-plist
@@ -0,0 +1,13 @@
+%%PYTHON_SITELIBDIR%%/pyfits/NA_pyfits.py
+%%PYTHON_SITELIBDIR%%/pyfits/NA_pyfits.pyc
+%%PYTHON_SITELIBDIR%%/pyfits/NA_pyfits.pyo
+%%PYTHON_SITELIBDIR%%/pyfits/NP_pyfits.py
+%%PYTHON_SITELIBDIR%%/pyfits/NP_pyfits.pyc
+%%PYTHON_SITELIBDIR%%/pyfits/NP_pyfits.pyo
+%%PYTHON_SITELIBDIR%%/pyfits/__init__.py
+%%PYTHON_SITELIBDIR%%/pyfits/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pyfits/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pyfits/rec.py
+%%PYTHON_SITELIBDIR%%/pyfits/rec.pyc
+%%PYTHON_SITELIBDIR%%/pyfits/rec.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/pyfits