aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-04 03:43:44 +0800
committersat <sat@FreeBSD.org>2007-04-04 03:43:44 +0800
commit6586bcbf02b80ce20a5d0419d64f90d62344e09e (patch)
tree16696cbc4bc2a96ae02f296db5a47fe47cf2ba4a
parent3d329db488718586e0ec75f5ea61301758079dab (diff)
downloadfreebsd-ports-gnome-6586bcbf02b80ce20a5d0419d64f90d62344e09e.tar.gz
freebsd-ports-gnome-6586bcbf02b80ce20a5d0419d64f90d62344e09e.tar.zst
freebsd-ports-gnome-6586bcbf02b80ce20a5d0419d64f90d62344e09e.zip
Add port graphics/mtpaint:
mtPaint is a simple GTK+1/2 painting program designed for creating icons and pixel based artwork. It can edit indexed palette or 24 bit RGB images and offers basic painting and palette manipulation tools. It also has several other more powerful features such as channels, layers and animation. Due to its simplicity and lack of dependencies it runs well on GNU/Linux, Windows and older PC hardware. WWW: http://mtpaint.sourceforge.net/ Author: Dmitry Groshev <wjaguar@users.sourceforge.net> Inspired by: chinsan
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mtpaint/Makefile37
-rw-r--r--graphics/mtpaint/distinfo3
-rw-r--r--graphics/mtpaint/pkg-descr9
-rw-r--r--graphics/mtpaint/pkg-plist23
5 files changed, 73 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9c860a19a07c..81f2909112d6 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -418,6 +418,7 @@
SUBDIR += mirage
SUBDIR += morpheus
SUBDIR += moth
+ SUBDIR += mtpaint
SUBDIR += multivideo
SUBDIR += mxp
SUBDIR += netpbm
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
new file mode 100644
index 000000000000..49e73c6675e1
--- /dev/null
+++ b/graphics/mtpaint/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mtpaint
+# Date created: 3 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtpaint
+PORTVERSION= 3.11
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple painting program
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20
+HAS_CONFIGURE= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
+ --locale=${PREFIX}/share/locale gif jpeg tiff slow \
+ gtk2 intl man
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-o /dev/null|-o `mktemp -t /tmp`|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/mtpaint/distinfo b/graphics/mtpaint/distinfo
new file mode 100644
index 000000000000..26fc382e7624
--- /dev/null
+++ b/graphics/mtpaint/distinfo
@@ -0,0 +1,3 @@
+MD5 (mtpaint-3.11.tar.bz2) = ad26359e731b4dc383de2e95e46932df
+SHA256 (mtpaint-3.11.tar.bz2) = 8158e47ef3e721f9340eec60e8ff98f8d86cf5aebfcfabef8f82afcdb6d6bb0f
+SIZE (mtpaint-3.11.tar.bz2) = 296541
diff --git a/graphics/mtpaint/pkg-descr b/graphics/mtpaint/pkg-descr
new file mode 100644
index 000000000000..19aa58893010
--- /dev/null
+++ b/graphics/mtpaint/pkg-descr
@@ -0,0 +1,9 @@
+mtPaint is a simple GTK+1/2 painting program designed for creating icons
+and pixel based artwork. It can edit indexed palette or 24 bit RGB images
+and offers basic painting and palette manipulation tools. It also has
+several other more powerful features such as channels, layers and
+animation. Due to its simplicity and lack of dependencies it runs well on
+GNU/Linux, Windows and older PC hardware.
+
+WWW: http://mtpaint.sourceforge.net/
+Author: Dmitry Groshev <wjaguar@users.sourceforge.net>
diff --git a/graphics/mtpaint/pkg-plist b/graphics/mtpaint/pkg-plist
new file mode 100644
index 000000000000..c81f63581143
--- /dev/null
+++ b/graphics/mtpaint/pkg-plist
@@ -0,0 +1,23 @@
+bin/mtpaint
+share/locale/cs/LC_MESSAGES/mtpaint.mo
+share/locale/de_DE/LC_MESSAGES/mtpaint.mo
+share/locale/es/LC_MESSAGES/mtpaint.mo
+share/locale/fr/LC_MESSAGES/mtpaint.mo
+share/locale/pl/LC_MESSAGES/mtpaint.mo
+share/locale/pt/LC_MESSAGES/mtpaint.mo
+share/locale/pt_BR/LC_MESSAGES/mtpaint.mo
+share/locale/sk/LC_MESSAGES/mtpaint.mo
+share/locale/tr/LC_MESSAGES/mtpaint.mo
+share/locale/zh_TW/LC_MESSAGES/mtpaint.mo
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/de_DE/LC_MESSAGES
+@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW