aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2009-07-21 15:59:55 +0800
committerale <ale@FreeBSD.org>2009-07-21 15:59:55 +0800
commit65ccc2b79f97fb283e4f8204c44b1a60f221469b (patch)
treeec0b866b932493db53145cedeb796eb57d98c9d1
parent075abdc6d88beda76d1e085281508cc756314d2f (diff)
downloadfreebsd-ports-gnome-65ccc2b79f97fb283e4f8204c44b1a60f221469b.tar.gz
freebsd-ports-gnome-65ccc2b79f97fb283e4f8204c44b1a60f221469b.tar.zst
freebsd-ports-gnome-65ccc2b79f97fb283e4f8204c44b1a60f221469b.zip
Add slave port for upcoming MySQL 5.4.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBD-mysql54/Makefile18
2 files changed, 19 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7ad298b02767..33eb7592f063 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -295,6 +295,7 @@
SUBDIR += p5-DBD-mysql41
SUBDIR += p5-DBD-mysql50
SUBDIR += p5-DBD-mysql51
+ SUBDIR += p5-DBD-mysql54
SUBDIR += p5-DBD-mysql60
SUBDIR += p5-DBI
SUBDIR += p5-DBI-Shell
diff --git a/databases/p5-DBD-mysql54/Makefile b/databases/p5-DBD-mysql54/Makefile
new file mode 100644
index 000000000000..2df08406dd21
--- /dev/null
+++ b/databases/p5-DBD-mysql54/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: p5-DBD-mysql54
+# Date created: 21 Jul 2009
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= 54
+
+COMMENT= MySQL 5.4 driver for the Perl5 Database Interface (DBI)
+
+CONFLICTS= p5-Mysql-modules-[0-9]* p5-DBD-mysql-[0-9]* p5-DBD-mysql4[0-9]-[0-9]* p5-DBD-mysql5[01]-[0-9]* p5-DBD-mysql6[0-9]-[0-9]*
+
+WANT_MYSQL_VER= 54
+
+MASTERDIR= ${.CURDIR}/../p5-DBD-mysql
+
+.include "${MASTERDIR}/Makefile"