aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-09-23 08:27:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-09-23 08:27:22 +0800
commit66daf06c1b3b75a1e15b34a318480ad0c65492fd (patch)
treeda9f276800d9fe490a4454d8f80daa9b0489a3df
parent5decc47274f3f15948116fc3a93330bc73e38582 (diff)
downloadfreebsd-ports-gnome-66daf06c1b3b75a1e15b34a318480ad0c65492fd.tar.gz
freebsd-ports-gnome-66daf06c1b3b75a1e15b34a318480ad0c65492fd.tar.zst
freebsd-ports-gnome-66daf06c1b3b75a1e15b34a318480ad0c65492fd.zip
- Update to 0.101
-rw-r--r--games/springlobby/Makefile5
-rw-r--r--games/springlobby/distinfo6
-rw-r--r--games/springlobby/files/patch-CMakeLists.txt15
3 files changed, 17 insertions, 9 deletions
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index 9c86f199fb14..9822735d6eb1 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= springlobby
-PORTVERSION= 0.80
-PORTREVISION= 1
+PORTVERSION= 0.101
CATEGORIES= games net
MASTER_SITES= http://www.springlobby.info/tarballs/ \
http://mirror.amdmi3.ru/distfiles/
@@ -41,7 +40,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if !defined(WITHOUT_TORRENT)
-LIB_DEPENDS+= torrent-rasterbar.5:${PORTSDIR}/net-p2p/libtorrent-rasterbar-14
+LIB_DEPENDS+= torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15
.else
CMAKE_ARGS+= -DOPTION_TORRENT_SYSTEM:BOOL=OFF
.endif
diff --git a/games/springlobby/distinfo b/games/springlobby/distinfo
index b68fd822afcf..a38508c4e4d2 100644
--- a/games/springlobby/distinfo
+++ b/games/springlobby/distinfo
@@ -1,3 +1,3 @@
-MD5 (springlobby-0.80.tar.bz2) = 7710e10dc54cad8549dab4889d2478f6
-SHA256 (springlobby-0.80.tar.bz2) = d03f644b8faa7d6a26d65653eceac05cd7e60100869aa911cbee6846dc5abcb2
-SIZE (springlobby-0.80.tar.bz2) = 1646183
+MD5 (springlobby-0.101.tar.bz2) = f4b5a0b0cc60c57cd958da24ce08bfa2
+SHA256 (springlobby-0.101.tar.bz2) = eb8cb36ee1f26276b50e208b981bbfbdb42a5cd605dcc745d2d54ab7f70db3c1
+SIZE (springlobby-0.101.tar.bz2) = 1685301
diff --git a/games/springlobby/files/patch-CMakeLists.txt b/games/springlobby/files/patch-CMakeLists.txt
index f8966020e937..a5020274adbe 100644
--- a/games/springlobby/files/patch-CMakeLists.txt
+++ b/games/springlobby/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- CMakeLists.txt.orig 2010-04-10 03:37:25.000000000 +0400
-+++ CMakeLists.txt 2010-04-15 19:08:24.000000000 +0400
+--- CMakeLists.txt.orig 2010-07-20 01:38:35.000000000 +0400
++++ CMakeLists.txt 2010-07-30 16:21:01.000000000 +0400
@@ -92,7 +92,6 @@
# Did we find wxWidgets ? This condition will fail for as long as the internal Vars do not point to the proper wxWidgets Configuration.
IF(wxWidgets_FOUND)
@@ -27,7 +27,16 @@
ELSE ( OPTION_SOUND )
# Disable sound.
ADD_DEFINITIONS( -DDISABLE_SOUND )
-@@ -174,6 +176,7 @@
+@@ -171,7 +173,7 @@
+ IF( Boost_FOUND )
+ link_directories( ${Boost_LIB_DIR} )
+ INCLUDE_DIRECTORIES( ${Boost_INCLUDE_DIR} )
+- SET( SL_BOOST_LIBS boost_system-mt )
++ SET( SL_BOOST_LIBS boost_system )
+ ELSE()
+ MESSAGE( FATAL_ERROR "boost library not found! Please install the package or toggle OPTION_TORRENT_SYSTEM to OFF")
+ ENDIF()
+@@ -185,6 +187,7 @@
LIST( APPEND SLSharedWithSettings ${curlSRC} )
ELSE( OPTION_TORRENT_SYSTEM )
ADD_DEFINITIONS( -DNO_TORRENT_SYSTEM )