aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-12-24 14:13:15 +0800
committersergei <sergei@FreeBSD.org>2003-12-24 14:13:15 +0800
commit67ccb36776760e08d1095f558bbe8d4fa9d54219 (patch)
tree4f376f86b26ee6198cd3bfef74cd0ce507009260
parent8047138f46c2765589a53d2940ef7b785b639213 (diff)
downloadfreebsd-ports-gnome-67ccb36776760e08d1095f558bbe8d4fa9d54219.tar.gz
freebsd-ports-gnome-67ccb36776760e08d1095f558bbe8d4fa9d54219.tar.zst
freebsd-ports-gnome-67ccb36776760e08d1095f558bbe8d4fa9d54219.zip
Add xfce4-fsguard-plugin 0.2.0:
Written by Andre Lerche, this plugin checks the chosen mountpoint for free disk space. It displays 4 different icons (red, yellow, green, unknown) and a message box, depending on the free space. The amount of free disk space is visible in a tooltip. If you left-click on its icon, it opens the mountpoint directory in the file manager. Author: Andre Lerche <a.lerche@gmx.net> WWW: http://xfce-goodies.berlios.de/ PR: 60421 Submitted by: Matt Lancereau <matt@rimasec.net>
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/xfce4-fsguard-plugin/Makefile30
-rw-r--r--sysutils/xfce4-fsguard-plugin/distinfo1
-rw-r--r--sysutils/xfce4-fsguard-plugin/pkg-descr10
-rw-r--r--sysutils/xfce4-fsguard-plugin/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c3fb436bf6b6..ca86ace2d0e7 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -399,6 +399,7 @@
SUBDIR += xcpustate
SUBDIR += xdu
SUBDIR += xfce4-battery-plugin
+ SUBDIR += xfce4-fsguard-plugin
SUBDIR += xfce4-mcs-manager
SUBDIR += xfce4-mcs-plugins
SUBDIR += xfce4-minicmd-plugin
diff --git a/sysutils/xfce4-fsguard-plugin/Makefile b/sysutils/xfce4-fsguard-plugin/Makefile
new file mode 100644
index 000000000000..975a6bb06526
--- /dev/null
+++ b/sysutils/xfce4-fsguard-plugin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xfce4-fsguard-plugin
+# Date created: 2003-12-20
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-fsguard-plugin
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+
+MAINTAINER= matt@rimasec.net
+COMMENT= XFce4 panel plugin to check a mountpoint for free disk space
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-fsguard-plugin/distinfo b/sysutils/xfce4-fsguard-plugin/distinfo
new file mode 100644
index 000000000000..97311a35380f
--- /dev/null
+++ b/sysutils/xfce4-fsguard-plugin/distinfo
@@ -0,0 +1 @@
+MD5 (xfce4-fsguard-plugin-0.2.0.tar.gz) = 410ab680141905fa6775ecc1f050c51c
diff --git a/sysutils/xfce4-fsguard-plugin/pkg-descr b/sysutils/xfce4-fsguard-plugin/pkg-descr
new file mode 100644
index 000000000000..6d6e0d56fe8e
--- /dev/null
+++ b/sysutils/xfce4-fsguard-plugin/pkg-descr
@@ -0,0 +1,10 @@
+Written by Andre Lerche, this plugin checks the
+chosen mountpoint for free disk space.
+It displays 4 different icons (red, yellow, green, unknown)
+and a message box, depending on the free space.
+The amount of free disk space is visible in a tooltip.
+If you left-click on its icon, it opens the
+mountpoint directory in the file manager.
+
+Author: Andre Lerche <a.lerche@gmx.net>
+WWW: http://xfce-goodies.berlios.de/
diff --git a/sysutils/xfce4-fsguard-plugin/pkg-plist b/sysutils/xfce4-fsguard-plugin/pkg-plist
new file mode 100644
index 000000000000..197be7ddfc55
--- /dev/null
+++ b/sysutils/xfce4-fsguard-plugin/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+lib/xfce4/panel-plugins/libfsguard.so
+lib/xfce4/panel-plugins/libfsguard.la
+lib/xfce4/panel-plugins/libfsguard.a
+@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true