aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2012-10-21 20:12:54 +0800
committersumikawa <sumikawa@FreeBSD.org>2012-10-21 20:12:54 +0800
commit6994bb35cfc9b55559d07349918a5e690be8ab61 (patch)
tree65098b4fef4f0d3cc0124283abc06188663606a7
parent56abdad41da46a3bfebc79ffbb71ebb7dd9b4824 (diff)
downloadfreebsd-ports-gnome-6994bb35cfc9b55559d07349918a5e690be8ab61.tar.gz
freebsd-ports-gnome-6994bb35cfc9b55559d07349918a5e690be8ab61.tar.zst
freebsd-ports-gnome-6994bb35cfc9b55559d07349918a5e690be8ab61.zip
Make works with perl5.16
Feature safe: yes Submitted by: Cy Schubert <Cy.Schubert@komquats.com>
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/racoon2/files/patch-pskgen-pskgen.in18
2 files changed, 19 insertions, 1 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 745be5bef256..e2805be7a577 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= racoon2
PORTVERSION= 20100526a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.racoon2.wide.ad.jp/pub/racoon2/
EXTRACT_SUFX= .tgz
diff --git a/security/racoon2/files/patch-pskgen-pskgen.in b/security/racoon2/files/patch-pskgen-pskgen.in
new file mode 100644
index 000000000000..bb6ff6077b22
--- /dev/null
+++ b/security/racoon2/files/patch-pskgen-pskgen.in
@@ -0,0 +1,18 @@
+--- pskgen/pskgen.in.orig 2005-09-15 23:52:20.000000000 -0700
++++ pskgen/pskgen.in 2012-10-19 22:21:12.364329713 -0700
+@@ -59,8 +59,13 @@
+ exit 0;
+ }
+
+-require 'getopts.pl';
+-do Getopts('rs:o:di:he:d');
++if ($] > 5.014002) {
++ use Getopt::Std;
++ getopts('rs:o:di:he:d');
++} else {
++ require 'getopts.pl';
++ do Getopts('rs:o:di:he:d');
++}
+ $output = '-';
+ $output = $opt_o if ($opt_o);
+