aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-10-31 05:07:49 +0800
committerflz <flz@FreeBSD.org>2007-10-31 05:07:49 +0800
commit6a050aa5613601903c271f5e5580b06fe69aca9e (patch)
tree5c35340f7c9384d3d1b8ebc55473c1baabf5c949
parentf9d743ed6fee2411b3c9c53bea5c2dfa00234ef8 (diff)
downloadfreebsd-ports-gnome-6a050aa5613601903c271f5e5580b06fe69aca9e.tar.gz
freebsd-ports-gnome-6a050aa5613601903c271f5e5580b06fe69aca9e.tar.zst
freebsd-ports-gnome-6a050aa5613601903c271f5e5580b06fe69aca9e.zip
Add patch that fixes a buffer overflow.
Requested by: miwi Approved by: portmgr (pav, erwin)
-rw-r--r--x11-fonts/libXfont/Makefile1
-rw-r--r--x11-fonts/libXfont/files/patch-src_fontfile_catalogue.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-fonts/libXfont/Makefile b/x11-fonts/libXfont/Makefile
index d255b420bc3a..5e57f7cf2fff 100644
--- a/x11-fonts/libXfont/Makefile
+++ b/x11-fonts/libXfont/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libXfont
PORTVERSION= 1.3.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-fonts
diff --git a/x11-fonts/libXfont/files/patch-src_fontfile_catalogue.c b/x11-fonts/libXfont/files/patch-src_fontfile_catalogue.c
new file mode 100644
index 000000000000..f25280eef906
--- /dev/null
+++ b/x11-fonts/libXfont/files/patch-src_fontfile_catalogue.c
@@ -0,0 +1,11 @@
+--- src/fontfile/catalogue.c.orig
++++ src/fontfile/catalogue.c
+@@ -156,7 +156,7 @@ CatalogueRescan (FontPathElementPtr fpe)
+ while (entry = readdir(dir), entry != NULL)
+ {
+ snprintf(link, sizeof link, "%s/%s", path, entry->d_name);
+- len = readlink(link, dest, sizeof dest);
++ len = readlink(link, dest, sizeof dest - 1);
+ if (len < 0)
+ continue;
+