aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-05-09 11:44:23 +0800
committerswills <swills@FreeBSD.org>2011-05-09 11:44:23 +0800
commit6ab4d8e00c8e3721d0e279284a9772e190a99681 (patch)
tree5c01549eede07dabf53d03a8c05b6584765a10e2
parent12bb5d41c2c3228fa32235e1d67eb274c40e656f (diff)
downloadfreebsd-ports-gnome-6ab4d8e00c8e3721d0e279284a9772e190a99681.tar.gz
freebsd-ports-gnome-6ab4d8e00c8e3721d0e279284a9772e190a99681.tar.zst
freebsd-ports-gnome-6ab4d8e00c8e3721d0e279284a9772e190a99681.zip
Read-Eval-Print-Loop on die and/or warn
WWW: http://search.cpan.org/dist/Carp-REPL/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Carp-REPL/Makefile36
-rw-r--r--devel/p5-Carp-REPL/distinfo2
-rw-r--r--devel/p5-Carp-REPL/pkg-descr3
-rw-r--r--devel/p5-Carp-REPL/pkg-plist10
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f6184dea5da7..f1154587b1eb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1223,6 +1223,7 @@
SUBDIR += p5-Carp-Clan
SUBDIR += p5-Carp-Clan-Share
SUBDIR += p5-Carp-Datum
+ SUBDIR += p5-Carp-REPL
SUBDIR += p5-Cdk
SUBDIR += p5-Check-ISA
SUBDIR += p5-Child
diff --git a/devel/p5-Carp-REPL/Makefile b/devel/p5-Carp-REPL/Makefile
new file mode 100644
index 000000000000..27c1d8f6aa6a
--- /dev/null
+++ b/devel/p5-Carp-REPL/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Carp-REPL
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp-REPL
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SARTAK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Read-Eval-Print-Loop on die and/or warn
+
+BUILD_DEPENDS= devel/p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Devel-LexAlias>=0:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ p5-Devel-REPL>=0:${PORTSDIR}/devel/p5-Devel-REPL \
+ p5-Devel-StackTrace-WithLexicals>0:${PORTSDIR}/devel/p5-Devel-StackTrace-WithLexicals \
+ p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS= devel/p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Devel-LexAlias>=0:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ p5-Devel-REPL>=0:${PORTSDIR}/devel/p5-Devel-REPL \
+ p5-Devel-StackTrace-WithLexicals>0:${PORTSDIR}/devel/p5-Devel-StackTrace-WithLexicals \
+ p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Carp::REPL.3 Devel::REPL::Plugin::Carp::REPL.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Carp-REPL/distinfo b/devel/p5-Carp-REPL/distinfo
new file mode 100644
index 000000000000..8e0b9e9bf2d9
--- /dev/null
+++ b/devel/p5-Carp-REPL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Carp-REPL-0.15.tar.gz) = 036eba86df2576a56917a01f7f6830425bfd9c286755d611115cbe806a1639ee
+SIZE (Carp-REPL-0.15.tar.gz) = 23690
diff --git a/devel/p5-Carp-REPL/pkg-descr b/devel/p5-Carp-REPL/pkg-descr
new file mode 100644
index 000000000000..c70a8751bd0b
--- /dev/null
+++ b/devel/p5-Carp-REPL/pkg-descr
@@ -0,0 +1,3 @@
+Read-Eval-Print-Loop on die and/or warn
+
+WWW: http://search.cpan.org/dist/Carp-REPL/
diff --git a/devel/p5-Carp-REPL/pkg-plist b/devel/p5-Carp-REPL/pkg-plist
new file mode 100644
index 000000000000..0596ca7d5832
--- /dev/null
+++ b/devel/p5-Carp-REPL/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/REPL/.packlist
+%%SITE_PERL%%/Devel/REPL/Plugin/Carp/REPL.pm
+%%SITE_PERL%%/Carp/REPL.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/REPL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin/Carp
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin
+@dirrmtry %%SITE_PERL%%/Devel/REPL
+@dirrmtry %%SITE_PERL%%/Devel
+@dirrmtry %%SITE_PERL%%/Carp