aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2008-12-19 23:30:18 +0800
committerglarkin <glarkin@FreeBSD.org>2008-12-19 23:30:18 +0800
commit6beb31e86afa05e5204d97195fc720b1d87bd19c (patch)
tree21301c9e2ac7f8efba11efca48bd2000b3ac5d45
parente5e82d4087c7250f88d482dda57db70a29c369e7 (diff)
downloadfreebsd-ports-gnome-6beb31e86afa05e5204d97195fc720b1d87bd19c.tar.gz
freebsd-ports-gnome-6beb31e86afa05e5204d97195fc720b1d87bd19c.tar.zst
freebsd-ports-gnome-6beb31e86afa05e5204d97195fc720b1d87bd19c.zip
- Removed php5-pcre dependency since it's part of the PHP base port now
- Added MySQLi dependency configuration option - Bumped PORTREVISION PR: ports/129698 Submitted by: Till Klampaeckel <till at php dot net>
-rw-r--r--www/zend-framework/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index 60ef64189188..f3cd09ed6046 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ZendFramework
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/ GENTOO/distfiles
@@ -14,7 +15,7 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= A framework for developing PHP web applications
NO_BUILD= yes
-USE_PHP= pcre spl
+USE_PHP= spl
WANT_PHP_WEB= yes
USE_GETTEXT= yes
@@ -24,6 +25,7 @@ OPTIONS= \
EDOJO "Install embedded Dojo" On \
PDOJO "Install Dojo from ports" Off \
MYSQL "Install MySQL PDO support" Off \
+ MYSQLI "Install MySQLi support" Off \
DBLIB "Install DBLIB PDO support" Off \
PGSQL "Install PostgreSQL PDO support" Off \
OCI "Install Oracle OCI 8 PDO support" Off \
@@ -78,6 +80,10 @@ USE_PHP+= bcmath bitset json posix
USE_PHP+= pdo_mysql
.endif
+.if defined(WITH_MYSQLI)
+USE_PHP+= mysqli
+.endif
+
.if defined(WITH_DBLIB)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php5-pdo_dblib
.endif