aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-09-11 07:38:38 +0800
committerkris <kris@FreeBSD.org>2006-09-11 07:38:38 +0800
commit6d07dc037a91d5ef2c8a71923ec31052ada5ecd3 (patch)
tree31a4a9252d452feefac128b831b1440dea56bf79
parent1a6646b9208f8befe5112876cbb568530db24cc4 (diff)
downloadfreebsd-ports-gnome-6d07dc037a91d5ef2c8a71923ec31052ada5ecd3.tar.gz
freebsd-ports-gnome-6d07dc037a91d5ef2c8a71923ec31052ada5ecd3.tar.zst
freebsd-ports-gnome-6d07dc037a91d5ef2c8a71923ec31052ada5ecd3.zip
BROKEN on 7.0: Does not compile
-rw-r--r--devel/libpdel/Makefile8
-rw-r--r--lang/gpc/Makefile4
-rw-r--r--net-p2p/libbt/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/devel/libpdel/Makefile b/devel/libpdel/Makefile
index 861828a22382..c0cad825be40 100644
--- a/devel/libpdel/Makefile
+++ b/devel/libpdel/Makefile
@@ -19,4 +19,10 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
+
+.if ${OSVERSION} >= 700019
+BROKEN= Does not compile on FreeBSD >= 7.0
+.endif
+
+.include <bsd.port.pre.mk>
diff --git a/lang/gpc/Makefile b/lang/gpc/Makefile
index 0a897b07cbac..f0e4b08eab20 100644
--- a/lang/gpc/Makefile
+++ b/lang/gpc/Makefile
@@ -50,6 +50,10 @@ GCC_VER?= 3.4.3
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
+.if ${OSVERSION} >= 700019
+BROKEN= does not compile on FreeBSD >= 7.0
+.endif
+
post-extract:
@${MV} ${WRKDIR}/${DISTNAME}/p ${WRKSRC}/gcc
diff --git a/net-p2p/libbt/Makefile b/net-p2p/libbt/Makefile
index 535b1c38f3cc..2fd16cdab973 100644
--- a/net-p2p/libbt/Makefile
+++ b/net-p2p/libbt/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
PORTDOCS= protocol-ext.txt protocol.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700019
+BROKEN= Does not compile on FreeBSD >= 7.0
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ \@CPPFLAGS\@ |' ${WRKSRC}/src/Makefile.in
@@ -45,4 +51,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>