aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2012-10-16 17:32:51 +0800
committeradamw <adamw@FreeBSD.org>2012-10-16 17:32:51 +0800
commit6e136ab77e018e0a5b25909da3e4d19fe6e78775 (patch)
treef3b701cba7e0f8b0aaf1d6992b1a949dbc1b397f
parent6a0bcaf16a455fc7037d20fad8aaf9b87c0a70ce (diff)
downloadfreebsd-ports-gnome-6e136ab77e018e0a5b25909da3e4d19fe6e78775.tar.gz
freebsd-ports-gnome-6e136ab77e018e0a5b25909da3e4d19fe6e78775.tar.zst
freebsd-ports-gnome-6e136ab77e018e0a5b25909da3e4d19fe6e78775.zip
Rather than using cp -R and warning about umask values, use cpio.
As a result, this picks up an .htaccess in DOCSDIR that we were missing before. Also, prevent a patch remnant from getting installed. PORTREVISION bumped for plist change. Feature safe: yes
-rw-r--r--mail/squirrelmail/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 51356158b8a4..3ba29ffd1fef 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squirrelmail
PORTVERSION= 1.4.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
MASTER_SITES= SF/${PORTNAME}/stable/${PORTVERSION}
DISTNAME= ${PORTNAME}-webmail-${PORTVERSION}
@@ -40,7 +40,7 @@ PLIST_SUB= PORTVERSION=${PORTVERSION} \
SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= SQUIRRELDIR=${SQUIRRELDIR} SMUSER=${SMUSER} SMGROUP=${SMGROUP}
-PORTDOCS= *
+PORTDOCS= * .htaccess
CONFLICTS= squirreloutlook-[0-9]*
@@ -82,7 +82,7 @@ post-patch:
# Rearrange the documentation
do-build:
@${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
- @cd ${WRKSRC} ; for f in `find plugins -name "README*" -or \
+ @cd ${WRKSRC} ; for f in `${FIND} plugins -name "README*" -or \
-name INSTALL -or -name CHANGES -or -name HISTORY`; \
do \
${MKDIR} doc/`dirname $$f` ; \
@@ -93,26 +93,23 @@ do-build:
${MV} plugins/squirrelspell/doc/* doc/plugins/squirrelspell ; \
${RM} -f doc/plugins/squirrelspell/index.php ; \
${RM} -rf plugins/squirrelspell/doc
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
@${ECHO} "left_refresh=300" >> ${WRKSRC}/data/default_pref
@${MV} ${WRKSRC}/config/config_local.php ${WRKSRC}/config/config_local.php.sample
-pre-install:
- @${ECHO} "Your umask should be lax while installing this. Like, 022 or something."
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
${MKDIR} ${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${FILESDIR}/111.clean-squirrelmail ${PREFIX}/etc/periodic/daily
${MKDIR} ${SQUIRRELDIR}
- @${CP} -pv ${WRKSRC}/index.php ${SQUIRRELDIR}
- @${CP} -pv ${WRKSRC}/configure ${SQUIRRELDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.php ${SQUIRRELDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/configure ${SQUIRRELDIR}
.for DIR in class config data functions help images include locale plugins po src themes
- @${CP} -rpv ${WRKSRC}/${DIR} ${SQUIRRELDIR}
+ cd ${WRKSRC} && ${FIND} ${DIR} | ${CPIO} -pdmu --quiet ${SQUIRRELDIR}
.endfor
${CHOWN} -R ${SMUSER}:${SMGROUP} ${SQUIRRELDIR}/data
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- @${CP} -Rv ${WRKSRC}/doc/* ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${FIND} . | ${CPIO} -pdmu --quiet ${DOCSDIR}
.endif
post-install: