aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-06-04 01:08:20 +0800
committermiwi <miwi@FreeBSD.org>2010-06-04 01:08:20 +0800
commit6e5b83d0d4a699c09c9c8154d2b69b57d52a9020 (patch)
tree044d8a995ee69dbbd1bb5d4927a55b881d82ad87
parentc6d350b94f6aef4a3b15a1be1504dbfb00285e15 (diff)
downloadfreebsd-ports-gnome-6e5b83d0d4a699c09c9c8154d2b69b57d52a9020.tar.gz
freebsd-ports-gnome-6e5b83d0d4a699c09c9c8154d2b69b57d52a9020.tar.zst
freebsd-ports-gnome-6e5b83d0d4a699c09c9c8154d2b69b57d52a9020.zip
Re-Tail is a command line program which is intended as an intelligent
incremental logfile reader. It will read a file or group of files given on the command line, and output any changes since last time it read the file(s) in question. It will attempt to compensate if the filesize changes unexpectedly, and will also attempt to compensate if the file contents changes as well. It is not a very complex program. WWW: http://xjack.org/retail/ PR: ports/146849 Submitted by: Oleg Ginzburg
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/retail/Makefile27
-rw-r--r--sysutils/retail/distinfo3
-rw-r--r--sysutils/retail/files/patch-Makefile.in12
-rw-r--r--sysutils/retail/pkg-descr8
5 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 311eb2fd594e..24d1f1db3197 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -688,6 +688,7 @@
SUBDIR += rename
SUBDIR += reoback
SUBDIR += respond
+ SUBDIR += retail
SUBDIR += rfstool
SUBDIR += rmonitor
SUBDIR += roottail
diff --git a/sysutils/retail/Makefile b/sysutils/retail/Makefile
new file mode 100644
index 000000000000..6b877121116f
--- /dev/null
+++ b/sysutils/retail/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: retail
+# Date created: 19 May 2010
+# Whom: Oleg Ginzburg
+#
+# $FreeBSD$
+#
+
+PORTNAME= retail
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils
+MASTER_SITES= http://xjack.org/retail/download/ \
+ http://itdev.spb.ru/mirror/
+
+MAINTAINER= oleg.ginzburg@nevosoft.ru
+COMMENT= A program for incremental logfile reader
+
+GNU_CONFIGURE= yes
+MAN1= retail.1
+PLIST_FILES= bin/retail
+
+post-configure:
+ ${REINPLACE_CMD} -e 's/%.o: %.c \*.h ..\/config.h//g' ${WRKSRC}/src/Makefile
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/retail.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/sysutils/retail/distinfo b/sysutils/retail/distinfo
new file mode 100644
index 000000000000..c69970ab6f0c
--- /dev/null
+++ b/sysutils/retail/distinfo
@@ -0,0 +1,3 @@
+MD5 (retail-1.0.0.tar.gz) = 0ed31b68b8841ede620ed210c58fc81a
+SHA256 (retail-1.0.0.tar.gz) = e79c8c6c572867aad07a8cae632cbd9ffa4202805e5bbaa6c2710a6cf00a35b7
+SIZE (retail-1.0.0.tar.gz) = 57979
diff --git a/sysutils/retail/files/patch-Makefile.in b/sysutils/retail/files/patch-Makefile.in
new file mode 100644
index 000000000000..e21a30296ed5
--- /dev/null
+++ b/sysutils/retail/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+--- Makefile.in-orig 2010-05-23 01:04:54.000000000 +0400
++++ Makefile.in 2010-05-23 01:05:04.000000000 +0400
+@@ -1,6 +1,8 @@
+ default:
+ cd src ; make
+
++all: default
++
+ clean:
+ cd src ; make clean
+ rm -f *~
+
diff --git a/sysutils/retail/pkg-descr b/sysutils/retail/pkg-descr
new file mode 100644
index 000000000000..c90425b4ca46
--- /dev/null
+++ b/sysutils/retail/pkg-descr
@@ -0,0 +1,8 @@
+Re-Tail is a command line program which is intended as an intelligent
+incremental logfile reader. It will read a file or group of files
+given on the command line, and output any changes since last time it
+read the file(s) in question. It will attempt to compensate if the
+filesize changes unexpectedly, and will also attempt to compensate if
+the file contents changes as well. It is not a very complex program.
+
+WWW: http://xjack.org/retail/