aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:42:00 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:42:00 +0800
commit6effeae4c003a42fdcc16f76b0d65a0700d28b2c (patch)
tree180c24e2a592c7552bb4e6f3ebd8f0dfb93865c5
parentee2a46e64389336902aaef27b40695eb6d563197 (diff)
downloadfreebsd-ports-gnome-6effeae4c003a42fdcc16f76b0d65a0700d28b2c.tar.gz
freebsd-ports-gnome-6effeae4c003a42fdcc16f76b0d65a0700d28b2c.tar.zst
freebsd-ports-gnome-6effeae4c003a42fdcc16f76b0d65a0700d28b2c.zip
Add p5-Proc-Background 1.01, perl interface to running background
processes.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Proc-Background/Makefile25
-rw-r--r--devel/p5-Proc-Background/distinfo1
-rw-r--r--devel/p5-Proc-Background/pkg-comment1
-rw-r--r--devel/p5-Proc-Background/pkg-descr10
-rw-r--r--devel/p5-Proc-Background/pkg-plist7
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 48fc5943d72d..a46f20773bd6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -260,6 +260,7 @@
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
SUBDIR += p5-PerlMenu
+ SUBDIR += p5-Proc-Background
SUBDIR += p5-Proc-Simple
SUBDIR += p5-ReadLine-Gnu
SUBDIR += p5-ReadLine-Perl
diff --git a/devel/p5-Proc-Background/Makefile b/devel/p5-Proc-Background/Makefile
new file mode 100644
index 000000000000..c09bc30df31f
--- /dev/null
+++ b/devel/p5-Proc-Background/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Proc-Background
+# Date created: Wed Jan 3 10:32:39 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Background
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN1PREFIX= ${PREFIX}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= timed-process.1
+MAN3= Proc::Background.3 Proc::Background::Win32.3 Proc::Background::Unix.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Proc-Background/distinfo b/devel/p5-Proc-Background/distinfo
new file mode 100644
index 000000000000..34b14ca5f415
--- /dev/null
+++ b/devel/p5-Proc-Background/distinfo
@@ -0,0 +1 @@
+MD5 (Proc-Background-1.01.tar.gz) = 2b0bd0daa393565eaf95381e142c9f12
diff --git a/devel/p5-Proc-Background/pkg-comment b/devel/p5-Proc-Background/pkg-comment
new file mode 100644
index 000000000000..a23ea2f6bf52
--- /dev/null
+++ b/devel/p5-Proc-Background/pkg-comment
@@ -0,0 +1 @@
+Perl interface to running background processes
diff --git a/devel/p5-Proc-Background/pkg-descr b/devel/p5-Proc-Background/pkg-descr
new file mode 100644
index 000000000000..40bfe77c48e1
--- /dev/null
+++ b/devel/p5-Proc-Background/pkg-descr
@@ -0,0 +1,10 @@
+This is the Proc::Generic package. It provides a generic interface to
+running background processes. Through this interface, users can run
+background processes on different operating systems without concerning
+themselves about the specifics of doing this. Users of this package
+create new Proc::Generic objects that provide an object oriented
+interface to process management.
+
+Author: Blair Zajac <blair@akamai.com>
+
+--will
diff --git a/devel/p5-Proc-Background/pkg-plist b/devel/p5-Proc-Background/pkg-plist
new file mode 100644
index 000000000000..007b301a4f68
--- /dev/null
+++ b/devel/p5-Proc-Background/pkg-plist
@@ -0,0 +1,7 @@
+bin/timed-process
+lib/perl5/site_perl/%%PERL_VER%%/Proc/Background.pm
+lib/perl5/site_perl/%%PERL_VER%%/Proc/Background/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/Proc/Background/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Background/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Background
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Proc/Background