aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2005-01-09 19:27:56 +0800
committerolgeni <olgeni@FreeBSD.org>2005-01-09 19:27:56 +0800
commit6f7e09417ba550b429cc25f269ab93d4b8c7c15b (patch)
treec03562010886a6c3738b3f3861955e58f0a90097
parent52e4cb8d5a17d03f38db24caf579092de2c89f2b (diff)
downloadfreebsd-ports-gnome-6f7e09417ba550b429cc25f269ab93d4b8c7c15b.tar.gz
freebsd-ports-gnome-6f7e09417ba550b429cc25f269ab93d4b8c7c15b.tar.zst
freebsd-ports-gnome-6f7e09417ba550b429cc25f269ab93d4b8c7c15b.zip
Fix HIPE support. Looks like GNU make is picking up ARCH from
environment, even if it is defined in the Makefile. Given that FreeBSD's ARCH is "i386" and Erlang's ARCH is "x86", some substitutions did fail leading to a strange compiler failure[0]. Also fix a file:format_error call that produces an incorrect error message[1]. Obtained from: Brian Buchanan <bwb(at)holo.org> [0] Obtained from: Vlad Dumitrescu <vlad_dumitrescu(at)hotmail.com> [1]
-rw-r--r--lang/erlang/Makefile5
-rw-r--r--lang/erlang/files/patch-lib_kernel_src_application__controller.erl14
-rw-r--r--lang/erlang14/Makefile5
-rw-r--r--lang/erlang14/files/patch-lib_kernel_src_application__controller.erl14
4 files changed, 34 insertions, 4 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 2098042ee87b..3d98cdb9cd00 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r10b2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/ \
@@ -45,7 +45,8 @@ ONLY_FOR_ARCHS= i386
REINPLACE_ARGS= -i
CONFIGURE_TARGET= # Empty
-CONFIGURE_ARGS+= --enable-threads
+CONFIGURE_ARGS+= --enable-threads --enable-hipe
+NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
.include <bsd.port.pre.mk>
diff --git a/lang/erlang/files/patch-lib_kernel_src_application__controller.erl b/lang/erlang/files/patch-lib_kernel_src_application__controller.erl
new file mode 100644
index 000000000000..2c9afc934e5c
--- /dev/null
+++ b/lang/erlang/files/patch-lib_kernel_src_application__controller.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/kernel/src/application_controller.erl.orig
++++ lib/kernel/src/application_controller.erl
+@@ -1398,7 +1398,7 @@
+ FName = atom_to_list(Name) ++ ".app",
+ case code:where_is_file(FName) of
+ non_existing ->
+- {error, {file:format_error({error,enoent}), FName}};
++ {error, {file:format_error(enoent), FName}};
+ FullName ->
+ case file:consult(FullName) of
+ {ok, [Application]} ->
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 2098042ee87b..3d98cdb9cd00 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r10b2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/ \
@@ -45,7 +45,8 @@ ONLY_FOR_ARCHS= i386
REINPLACE_ARGS= -i
CONFIGURE_TARGET= # Empty
-CONFIGURE_ARGS+= --enable-threads
+CONFIGURE_ARGS+= --enable-threads --enable-hipe
+NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
.include <bsd.port.pre.mk>
diff --git a/lang/erlang14/files/patch-lib_kernel_src_application__controller.erl b/lang/erlang14/files/patch-lib_kernel_src_application__controller.erl
new file mode 100644
index 000000000000..2c9afc934e5c
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_kernel_src_application__controller.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/kernel/src/application_controller.erl.orig
++++ lib/kernel/src/application_controller.erl
+@@ -1398,7 +1398,7 @@
+ FName = atom_to_list(Name) ++ ".app",
+ case code:where_is_file(FName) of
+ non_existing ->
+- {error, {file:format_error({error,enoent}), FName}};
++ {error, {file:format_error(enoent), FName}};
+ FullName ->
+ case file:consult(FullName) of
+ {ok, [Application]} ->