aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2007-05-28 22:39:03 +0800
committergarga <garga@FreeBSD.org>2007-05-28 22:39:03 +0800
commit6ff5810e5a4b8b76f87937d9e11f7d1ad26802da (patch)
tree8d7f9af0179a5eedeb3493411053c09dc9d766c2
parent23a94fd8edea438b389e5bbf215e49e70c6a823d (diff)
downloadfreebsd-ports-gnome-6ff5810e5a4b8b76f87937d9e11f7d1ad26802da.tar.gz
freebsd-ports-gnome-6ff5810e5a4b8b76f87937d9e11f7d1ad26802da.tar.zst
freebsd-ports-gnome-6ff5810e5a4b8b76f87937d9e11f7d1ad26802da.zip
- Make arc, arj, lha and unzoo achives support dependency as OPTIONS enabled by
default. Clamav can run fine without these guys. PORTREVISION bump is not needed since final package is the same. PR: ports/113087 Submitted by: baptiste.daroussin@gmail.com
-rw-r--r--security/clamav/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 22761b04984c..6a26bcb8a03c 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -15,12 +15,12 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Command line virus scanner written entirely in C
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
- arj:${PORTSDIR}/archivers/arj \
- unzoo:${PORTSDIR}/archivers/unzoo \
- arc:${PORTSDIR}/archivers/arc
-OPTIONS= MILTER "Compile the milter interface" Off \
+OPTIONS= ARC "Enable arch archives support" On \
+ ARJ "Enable arj archives support" On \
+ LHA "Enable lha archives support" On \
+ UNZOO "Enavle zoo archives support" On \
+ MILTER "Compile the milter interface" Off \
LDAP "libmilter was built with LDAP" Off \
CURL "Support URL downloading" Off \
STDERR "Print logs to stderr instead of stdout" Off \
@@ -116,6 +116,19 @@ PTHREAD_LIBS= -lthr
PTHREAD_LIBS= -pthread
.endif
+.if !defined(WITHOUT_ARC)
+RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
+.endif
+.if !defined(WITHOUT_ARJ)
+RUN_DEPENDS+= arj:${PORTSDIR}/archivers/arj
+.endif
+.if !defined(WITHOUT_LHA)
+RUN_DEPENDS+= lha:${PORTSDIR}/archivers/lha
+.endif
+.if !defined(WITHOUT_UNZOO)
+RUN_DEPENDS+= unzoo:${PORTSDIR}/archivers/unzoo
+.endif
+
.if defined(WITH_MILTER)
USE_RC_SUBR+= clamav-milter
.if defined(WITH_LDAP) && exists(${LOCALBASE}/lib/libldap.so)