aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-15 06:46:22 +0800
committerpav <pav@FreeBSD.org>2008-03-15 06:46:22 +0800
commit70b2b2baf5981a47639c6925fb8fec456d1b389a (patch)
treedda26a6484352ee233e291e6d09e53ebcc5f2ad2
parente338dff046c281779a30c98b86219957d8de7c39 (diff)
downloadfreebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.tar.gz
freebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.tar.zst
freebsd-ports-gnome-70b2b2baf5981a47639c6925fb8fec456d1b389a.zip
(Committing on behalf of stas)
- Fix adesklets breakage after an imlib2 update. Somehow, it started to detect iconv installed, but fails to link the binary properly. Also fix some other configure syntax errors. Pointy hat to: me (for not testing everything before commit) Reported by: pav, erwin
-rw-r--r--deskutils/adesklets/Makefile2
-rw-r--r--deskutils/adesklets/files/patch-configure50
2 files changed, 50 insertions, 2 deletions
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index fbd5b32828bc..8255c1931f27 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -23,6 +23,7 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_XLIB= yes
USE_EFL= imlib2
+USE_ICONV= yes
WANT_PERL= yes
MAN1= adesklets.1 \
@@ -34,6 +35,7 @@ INFO= adesklets \
SUB_FILES= pkg-message
INSTALLS_EGGINFO= yes
+LDFLAGS+= -liconv
.if !defined(WITHOUT_PERL)
USE_PERL5= yes
diff --git a/deskutils/adesklets/files/patch-configure b/deskutils/adesklets/files/patch-configure
index 96fc0c3d7722..b8915ff11115 100644
--- a/deskutils/adesklets/files/patch-configure
+++ b/deskutils/adesklets/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2006-03-31 03:19:07.000000000 +0200
-+++ configure 2007-12-21 21:37:27.000000000 +0100
+--- configure.orig 2006-03-31 05:19:07.000000000 +0400
++++ configure 2008-03-15 00:14:53.000000000 +0300
@@ -5352,7 +5352,8 @@
UNAME_REDUX=`uname -r -s | sed 's/\..*//' 2> /dev/null`
if test "$UNAME_REDUX" != 'FreeBSD 5' && \
@@ -10,3 +10,49 @@
then
cat >>confdefs.h <<\_ACEOF
+@@ -6735,13 +6736,13 @@
+ echo "${ECHO_T}no" >&6
+ fi
+
+-if ! test x$PKG_CONFIG = "x" ; then
++if ! test "x$PKG_CONFIG" = "x" ; then
+ if $PKG_CONFIG --exists fontconfig 2> /dev/null; then
+ FONTCONFIG_LIBS=`pkg-config --libs fontconfig`
+ FONTCONFIG_CFLAGS=`pkg-config --cflags fontconfig`
+ fi
+ fi
+-if test x$FONTCONFIG_LIBS = "x"; then
++if test "x$FONTCONFIG_LIBS" = "x"; then
+ FONTCONFIG_LIBS=-lfontconfig
+ fi
+ LIBS="$LIBS $FONTCONFIG_LIBS"
+@@ -7367,11 +7368,11 @@
+ IMLIB2_LIBS="`$IMLIB2_CONFIG $imlib2_config_args --libs`"
+
+ imlib2_config_major_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+).*/\1/'`
+ imlib2_config_minor_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+).*/\2/'`
+ imlib2_config_micro_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+)\.([0-9]+).*/\3/'`
+ imlib2_wanted_major_version="1"
+ imlib2_wanted_minor_version="1"
+ imlib2_wanted_micro_version="2"
+@@ -7441,11 +7442,11 @@
+ echo $ECHO_N "checking for imlib2 - version >= 1.2.0... $ECHO_C" >&6
+
+ imlib2_config_major_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+).*/\1/'`
+ imlib2_config_minor_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+).*/\2/'`
+ imlib2_config_micro_version=`$IMLIB2_CONFIG $imlib2_config_args \
+- --version | sed 's/[^0-9]*\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
++ --version | sed -E -e 's/[^0-9]*([0-9]+)\.([0-9]+)\.([0-9]+).*/\3/'`
+ imlib2_wished_major_version="1"
+ imlib2_wished_minor_version="2"
+ imlib2_wished_micro_version="0"
an>1-1/+7 * Sort entries.knu2002-11-281-1/+1 * Update to 2.3.20021126.des2002-11-272-2/+2 * Force ${PREFIX}/news/spool during package building.des2002-11-263-6/+6 * Update to 0.4.14pat2002-11-252-2/+2 * Update to 0.13.2.90.marcus2002-11-223-8/+8 * Both ports need perl to configure (see configure looks for theedwin2002-11-213-0/+3 * * Pass maintainership to Matthias Andree.naddy2002-11-134-3/+28 * This is no longer needed.marcus2002-11-111-0/+0 * Update to 0.13.2.marcus2002-11-113-26/+2 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-1128-28/+14 * Update to the version 6_15_8-05-quimbytaoka2002-11-098-64/+14 * use #ifndef to disabledinoex2002-11-081-1/+1 * Hopefully avoid a problem with CURRENTdinoex2002-11-081-2/+12 * Revision 1.33 of sys/sys/signal.h changed the visibilityedwin2002-11-071-0/+52 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-0728-14/+28 * PERL -> REINPLACEedwin2002-11-041-1/+2 * - reorder patchesdinoex2002-11-0423-253/+443 * Ports didn't build without USE_PERL5=yesedwin2002-11-041-0/+1 * Use standard %%PORTDOCS%% mechanism instead of using a different PLIST iftom2002-11-043-15/+6 * Fix typoes on MAINTAINER address.perky2002-11-021-1/+1 * Unbreak news/nn on -current. From patch-submission:edwin2002-10-291-4/+18 * This port is i386-only. [1]arved2002-10-252-2/+2 * Fix a bug where new headers could not be loaded. Bump PORTREVISION.marcus2002-10-222-0/+24 * Fix build on current (comment out bogus duplicate declarations)kris2002-10-212-4/+31 * Quiet portlint.marcus2002-10-161-1/+1 * Rename patch-Makefile to patch-Makefile.in to correctly reflect the filemarcus2002-10-161-0/+0 * Update to 0.13.1.marcus2002-10-164-76/+8 * This port was marked FORBIDDEN 13 months ago because it no longer works.kris2002-10-136-40/+0 * Fix build on -current (use TMPDIR environment variable to get preferredkris2002-10-131-15/+27 * update mastersiteijliao2002-10-111-2/+2 * Update maintainer addressperky2002-10-081-1/+1 * Deploy GNOMENG infrastructurelioux2002-10-061-7/+2 * Update to 4.4.6dinoex2002-10-063-3/+5 * - Update to 4.3.1dinoex2002-10-065-93/+75 * find->${FIND},xargs->${XARGS}ijliao2002-09-291-1/+1 * Update to 1.9.27, fixing a bug that caused leafnode tobrian2002-09-253-8/+9 * Update to 1.9.26brian2002-09-213-5/+7 * GNOME has just changed the layout of their FTP site. This resulted inmarcus2002-09-212-2/+2 * Update to 6_15_8-03-quimbytaoka2002-09-206-2/+10 * upgrade to 0.4.13ijliao2002-09-202-2/+2 * upgrade to 4.2ijliao2002-09-205-74/+12 * correct path in startup scriptijliao2002-09-192-2/+3 * Fix the charset tag for ISO locales. Thanks tomarcus2002-09-172-0/+31 * Upgrade to 2.1.3.obrien2002-09-112-6/+8 * Update to version 2.1.2.obrien2002-09-075-146/+18 * * Upgrade to 2.1.1.obraun2002-09-065-32/+26 * Set maintainership to ports@.obraun2002-09-052-2/+2 * - Update to version 0.21kevlo2002-09-052-6/+4 * This port should probably be put to rest, since I don't thinkhoek2002-09-052-4/+1 * Previous shlib update should have also bumped PORTREVISION (remindedhoek2002-09-021-0/+1 * Update libuu shared lib dependency to version 2hoek2002-09-021-1/+1 * Bump PORTREVISIONdinoex2002-09-011-1/+1 * change binary installation path for cnewsdinoex2002-09-014-4/+4 * Fix ``make install''brian2002-09-012-2/+1 * Update to 1.9.25brian2002-09-013-13/+41 * Deploy USE_GNOMENG infrastructurelioux2002-08-301-1/+2 * Directory layouts of py-gtk and py-gnome packages have been changed, so thatsobomax2002-08-291-1/+1 * Remove -Wl,--export-dynamic from the list of LDFLAGS. This caused strangemarcus2002-08-242-3/+31 * Add slrnface 1.2, shows X-Faces from slrn in X11 terminal emulator.obraun2002-08-239-0/+84 * Change MAINTAINER to my FreeBSD address.obraun2002-08-211-1/+1 * Add pan2.marcus2002-08-201-0/+1 * Add pan2 after a repo-copy from pan. pan2 is the GNOME 2 news readermarcus2002-08-208-26/+66 * change my email address to leeym@FreeBSD.orgleeym2002-08-191-1/+1 * add multisuck 1.0.3ijliao2002-08-116-0/+40 * Fix MASTER_SITE.marcus2002-08-082-4/+4 * Remove FORBIDDEN. I fixed the referenced bug two months agonectar2002-08-081-2/+0 * Mark FORBIDDEN: the author of nn says it has a remote security bugtrevor2002-08-081-0/+2 * Update to 1.4.8 + fix a security vulnerability.petef2002-08-053-3/+86 * - update to 0.3.1petef2002-08-053-4/+8 * Transmit CR+LF instead of LF as line terminator. This fixes a problemknu2002-08-032-0/+75 * Chase shlib rev of devel/gettextade2002-08-023-3/+3 * add MASTER_SITE_ISC (1) and apply themijliao2002-08-013-3/+6 * Share newspost with the world.roberto2002-07-301-0/+1 * Newspost is a full-featured Usenet binary autoposter. It is meant asroberto2002-07-305-0/+49 * * update to cleanfeed-20020501naddy2002-07-304-37/+4 * Update to 3.0.1pat2002-07-264-133/+121 * Fix a Linebreakdinoex2002-07-231-1/+2 * - Update to 4.4.5dinoex2002-07-233-2/+15 * Fix a build problem on STABLE/CURRENTdinoex2002-07-231-15/+25 * Update to 0.11.4.sobomax2002-07-186-30/+32 * Upgrade to 1.9.24brian2002-07-165-16/+19 * doesn't build with gcc > 3.0ijliao2002-07-151-0/+1 * Add mail to CATEGORIES, pyne is also a MUA.anders2002-07-151-1/+1 * Another USE_GNOMENG vict^Wuser. This port get very impressive benefit fromsobomax2002-07-122-12/+8 * add cleanscore 0.9.8.1ijliao2002-07-116-0/+43 * fixing make + replacing PERL by REINPLACE_CMDijliao2002-07-082-2/+14 * ${PERL} -> ${REINPLACE_CMD}ijliao2002-06-241-2/+3 * ${PERL} -> ${REINPLACE_CMD}ijliao2002-06-241-2/+4 * Replace ${PERL} with ${REINPLACE_CMD}ijliao2002-06-233-3/+6 * Add nget 0.19.1, an auto-resuming command line nntp file grabber.will2002-06-236-0/+51 * Upgrade to 2.3.20020620.des2002-06-212-2/+3 * - Get rid of PERL and use SEDdinoex2002-06-163-9/+12 * Fix build on current.kris2002-06-162-0/+22 * Add t-gnus after repo-copy.kris2002-06-161-0/+1 * Update the version to 6_15_7-01-quimby (based on Oort Gnus v0.07)taoka2002-06-1122-1394/+1022 * Repair some clearly incorrect code found while lookingnectar2002-06-101-0/+27 * Lay off the crack and bump PORTREVISION properly.nectar2002-06-101-1/+2 * Fix remotely exploitable format string vulnerability.nectar2002-06-102-4/+11 * Mark FORBIDDEN due to remotely exploitable format string vulnerability.nectar2002-06-101-0/+2 * Upgrade to 2.3.20020609.des2002-06-102-2/+2 * Try grouping of MASTER_SITESdinoex2002-06-091-2/+3 * Clean up style, use tabs instead of spaces.petef2002-06-091-13/+12 * Add nnap.petef2002-06-091-0/+1 * A small program that implements just enough of the NNTP protocolroberto2002-06-095-0/+37 * Respect NOPORTDOCSkris2002-06-072-3/+6 * Fix a format string vulnerability.cy2002-06-052-0/+12 * - get rid of duplicate code in Makefiles.dinoex2002-06-011-11/+1 * Upgrade to 2.3.20020530.des2002-05-312-2/+2 * Upgrade to 1.5.12ache2002-05-255-40/+15 * Unbroke on bento and make it compliant with GNOME hier.sobomax2002-05-222-3/+29 * BROKEN: Does not compile on -current; manpage does not build on -stablekris2002-05-181-0/+2 * BROKEN: does not package correctlykris2002-05-171-0/+2 * Don't support running with perl4 any more.obrien2002-05-171-6/+0 * Update port to 5.5h2jedgar2002-05-082-3/+3 * Allow suck build with SSL in the base if its new enouth,dinoex2002-05-081-2/+2 * Upgrade to 2.3.20020507des2002-05-082-2/+2 * Upgrade to 2.3.3.des2002-05-084-6/+4 * Chase openssl shlib version increase.sobomax2002-05-071-1/+1 * Add NewsCache, a GPLed cache server for USENET News.anders2002-05-048-0/+79 * Update to 1.9.22brian2002-05-033-8/+18