aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-10-06 07:13:42 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-10-06 07:13:42 +0800
commit726720e909b7ff4b2af91a8bed49e19fa5e50f18 (patch)
tree319eeaf451366052ebc7c2347c6cddd68ebe36e1
parentb283ce3a949a5d34ee2cd2f28047decfc513bfa9 (diff)
downloadfreebsd-ports-gnome-726720e909b7ff4b2af91a8bed49e19fa5e50f18.tar.gz
freebsd-ports-gnome-726720e909b7ff4b2af91a8bed49e19fa5e50f18.tar.zst
freebsd-ports-gnome-726720e909b7ff4b2af91a8bed49e19fa5e50f18.zip
- bsd.port.mk adds CFLAGS to CONFIGURE_ENV but not if you reference it directly
in the Makefile. Even if you use bsd.port.(pre|post).mk. - This re-fixes WITH_MYSQL=yes WITH_MYSQL_VER=55 after ale@ really fixed database/mysql55-client, databases/mysql55-server include/mysql layout. This is a very non default config, so no PORTREVISION bump PR: ports/146276
-rw-r--r--devel/apr1/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 7fd75a4e7798..56b43acf23e9 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -230,7 +230,7 @@ run-autotools::
${SETENV} ${CONFIGURE_ENV} ${SH} \
./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}
cd ${APU_WRKDIR}; \
- ${SETENV} ${CONFIGURE_ENV} ${SH} \
+ ${SETENV} ${CONFIGURE_ENV} CFLAGS="${CFLAGS}" ${SH} \
./configure ${CONFIGURE_ARGS} ${APU_CONF_ARGS}
do-configure:
@@ -256,6 +256,6 @@ debug_autoconf:
@${ECHO} "LIBTOOL_LIBEXECDIR: ${LIBTOOL_LIBEXECDIR}"
@${ECHO} "LIBTOOL_M4: ${LIBTOOL_M4}"
@${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_CONF_ARGS}"
- @${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
+ @${ECHO} "${SETENV} ${CONFIGURE_ENV} CFLAGS="${CFLAGS}" ${SH} ./configure ${CONFIGURE_ARGS} ${APR_UTIL_CONF_ARGS}"
.include <bsd.port.mk>