aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-05-21 03:02:08 +0800
committeraraujo <araujo@FreeBSD.org>2008-05-21 03:02:08 +0800
commit72eaa4ed1060a05286b740ae69f3313c236d6d8f (patch)
treeb54307d54111595d71238e6860ce749368a2df2f
parent075f4a4a5f4f2646d5045b68381b6af5b0cb2962 (diff)
downloadfreebsd-ports-gnome-72eaa4ed1060a05286b740ae69f3313c236d6d8f.tar.gz
freebsd-ports-gnome-72eaa4ed1060a05286b740ae69f3313c236d6d8f.tar.zst
freebsd-ports-gnome-72eaa4ed1060a05286b740ae69f3313c236d6d8f.zip
- Fixed some errors introduced during the upgrade from version 0.6.1 to 0.7.0.
- Bump PORTREVISION. Reported by: pointyhat via erwin, pav Submitted by: Paul Schmehl <pauls@utdallas.edu> (maintainer)
-rw-r--r--security/sguil-sensor/Makefile2
-rw-r--r--security/sguil-sensor/files/example_agent.sh.in34
-rw-r--r--security/sguil-sensor/files/pads_agent.sh.in34
-rw-r--r--security/sguil-sensor/files/pcap_agent.sh.in34
-rw-r--r--security/sguil-sensor/files/sancp_agent.sh.in34
-rw-r--r--security/sguil-sensor/files/sensor_agent.sh.in34
-rw-r--r--security/sguil-sensor/files/snort_agent.sh.in34
7 files changed, 171 insertions, 35 deletions
diff --git a/security/sguil-sensor/Makefile b/security/sguil-sensor/Makefile
index d564fb529bfe..ff3b1edfa316 100644
--- a/security/sguil-sensor/Makefile
+++ b/security/sguil-sensor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sguil-sensor
PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= sguil
diff --git a/security/sguil-sensor/files/example_agent.sh.in b/security/sguil-sensor/files/example_agent.sh.in
new file mode 100644
index 000000000000..ffa1cdb649a2
--- /dev/null
+++ b/security/sguil-sensor/files/example_agent.sh.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: example_agent
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable example_agent:
+# example_agent_enable (bool): Set to YES to enable example_agent
+# Default: NO
+# example_agent_conf (str): Example_agent configuration file
+# Default: %%PREFIX%%/etc/%%SGUILDIR%%/example_agent.conf
+# example_agent_flags (str): Default: -D
+#
+
+. %%RC_SUBR%%
+
+load_rc_config example_agent
+
+#set defaults
+example_agent_enable=${example_agent_enable:-"NO"}
+example_agent_conf=${example_agent_conf:-"%%PREFIX%%/etc/%%SGUILDIR%%/example_agent.conf"}
+example_agent_flags=${example_agent_flags:-"-D"}
+
+name="example_agent"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/%%SGUILDIR%%/example_agent.tcl"
+command_args="-c ${example_agent_conf} ${example_agent_flags}"
+procname="%%PREFIX%%/bin/tclsh8.4"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
+
+run_rc_command "$1"
diff --git a/security/sguil-sensor/files/pads_agent.sh.in b/security/sguil-sensor/files/pads_agent.sh.in
new file mode 100644
index 000000000000..542e5a0b6ec0
--- /dev/null
+++ b/security/sguil-sensor/files/pads_agent.sh.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: pads_agent
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable pads_agent:
+# pads_agent_enable (bool): Set to YES to enable pads_agent
+# Default: NO
+# pads_agent_conf (str): Pads_agent configuration file
+# Default: %%PREFIX%%/etc/%%SGUILDIR%%/pads_agent.conf
+# pads_agent_flags (str): Default: -D
+#
+
+. %%RC_SUBR%%
+
+load_rc_config pads_agent
+
+#set defaults
+pads_agent_enable=${pads_agent_enable:-"NO"}
+pads_agent_conf=${pads_agent_conf:-"%%PREFIX%%/etc/%%SGUILDIR%%/pads_agent.conf"}
+pads_agent_flags=${pads_agent_flags:-"-D"}
+
+name="pads_agent"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/%%SGUILDIR%%/pads_agent.tcl"
+command_args="-c ${pads_agent_conf} ${pads_agent_flags}"
+procname="%%PREFIX%%/bin/tclsh8.4"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
+
+run_rc_command "$1"
diff --git a/security/sguil-sensor/files/pcap_agent.sh.in b/security/sguil-sensor/files/pcap_agent.sh.in
new file mode 100644
index 000000000000..848d5a0c7655
--- /dev/null
+++ b/security/sguil-sensor/files/pcap_agent.sh.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: pcap_agent
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable pcap_agent:
+# pcap_agent_enable (bool): Set to YES to enable pcap_agent
+# Default: NO
+# pcap_agent_conf (str): Pcap_agent configuration file
+# Default: %%PREFIX%%/etc/%%SGUILDIR%%/pcap_agent.conf
+# pcap_agent_flags (str): Default: -D
+#
+
+. %%RC_SUBR%%
+
+load_rc_config pcap_agent
+
+#set defaults
+pcap_agent_enable=${pcap_agent_enable:-"NO"}
+pcap_agent_conf=${pcap_agent_conf:-"%%PREFIX%%/etc/%%SGUILDIR%%/pcap_agent.conf"}
+pcap_agent_flags=${pcap_agent_flags:-"-D"}
+
+name="pcap_agent"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/%%SGUILDIR%%/pcap_agent.tcl"
+command_args="-c ${pcap_agent_conf} ${pcap_agent_flags}"
+procname="%%PREFIX%%/bin/tclsh8.4"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
+
+run_rc_command "$1"
diff --git a/security/sguil-sensor/files/sancp_agent.sh.in b/security/sguil-sensor/files/sancp_agent.sh.in
new file mode 100644
index 000000000000..b2f6bcb007d9
--- /dev/null
+++ b/security/sguil-sensor/files/sancp_agent.sh.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: sancp_agent
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable sancp_agent:
+# sancp_agent_enable (bool): Set to YES to enable sancp_agent
+# Default: NO
+# sancp_agent_conf (str): Sancp_agent configuration file
+# Default: %%PREFIX%%/etc/%%SGUILDIR%%/sancp_agent.conf
+# sancp_agent_flags (str): Default: -D
+#
+
+. %%RC_SUBR%%
+
+load_rc_config sancp_agent
+
+#set defaults
+sancp_agent_enable=${sancp_agent_enable:-"NO"}
+sancp_agent_conf=${sancp_agent_conf:-"%%PREFIX%%/etc/%%SGUILDIR%%/sancp_agent.conf"}
+sancp_agent_flags=${sancp_agent_flags:-"-D"}
+
+name="sancp_agent"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/%%SGUILDIR%%/sancp_agent.tcl"
+command_args="-c ${sancp_agent_conf} ${sancp_agent_flags}"
+procname="%%PREFIX%%/bin/tclsh8.4"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
+
+run_rc_command "$1"
diff --git a/security/sguil-sensor/files/sensor_agent.sh.in b/security/sguil-sensor/files/sensor_agent.sh.in
deleted file mode 100644
index 4f24bc65d83e..000000000000
--- a/security/sguil-sensor/files/sensor_agent.sh.in
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-
-# PROVIDE: sensor_agent
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-
-# Add the following lines to /etc/rc.conf to enable sensor_agent:
-# sensor_agent_enable (bool): Set to YES to enable sensor_agent
-# Default: NO
-# sensor_agent_flags (str): Extra flags passed to sensor_agent
-# Default: -D
-# sensor_agent_conf (str): Sensor_agent configuration file
-# Default: %%PREFIX%%/etc/sensor_agent.conf
-#
-
-. %%RC_SUBR%%
-
-name="sensor_agent"
-rcvar=`set_rcvar`
-command="%%PREFIX%%/bin/%%SGUILDIR%%/sensor_agent.tcl"
-procname="%%PREFIX%%/bin/tclsh8.4"
-pidfile="/var/run/${name}.pid"
-check_pidfile="${pidfile} ${procname} /bin/sh"
-
-[ -z "$sensor_agent_enable" ] && sensor_agent_enable="NO"
-[ -z "$sensor_agent_conf" ] && sensor_agent_conf="%%PREFIX%%/etc/sensor_agent.conf"
-[ -z "$sensor_agent_flags" ] && sensor_agent_flags="-D"
-
-[ -n "$sensor_agent_conf" ] && sensor_agent_flags="$sensor_agent_flags -c $sensor_agent_conf"
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/security/sguil-sensor/files/snort_agent.sh.in b/security/sguil-sensor/files/snort_agent.sh.in
new file mode 100644
index 000000000000..a013470b7ee1
--- /dev/null
+++ b/security/sguil-sensor/files/snort_agent.sh.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: snort_agent
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable snort_agent:
+# snort_agent_enable (bool): Set to YES to enable snort_agent
+# Default: NO
+# snort_agent_conf (str): Snort_agent configuration file
+# Default: %%PREFIX%%/etc/%%SGUILDIR%%/snort_agent.conf
+# snort_agent_flags (str): Default: -D
+#
+
+. %%RC_SUBR%%
+
+load_rc_config snort_agent
+
+#set defaults
+snort_agent_enable=${snort_agent_enable:-"NO"}
+snort_agent_conf=${snort_agent_conf:-"%%PREFIX%%/etc/%%SGUILDIR%%/snort_agent.conf"}
+snort_agent_flags=${snort_agent_flags:-"-D"}
+
+name="snort_agent"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/%%SGUILDIR%%/snort_agent.tcl"
+command_args="-c ${snort_agent_conf} ${snort_agent_flags}"
+procname="%%PREFIX%%/bin/tclsh8.4"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
+
+run_rc_command "$1"