aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-10-27 14:17:10 +0800
committerkris <kris@FreeBSD.org>2003-10-27 14:17:10 +0800
commit731b566a6c55593424dd044411e0208eef835c47 (patch)
treef0dbb638a2f741c9e1135ac637d525813ddcf1d9
parentc1c9048b33821235e9fa0d99c0afb70d7f9237d9 (diff)
downloadfreebsd-ports-gnome-731b566a6c55593424dd044411e0208eef835c47.tar.gz
freebsd-ports-gnome-731b566a6c55593424dd044411e0208eef835c47.tar.zst
freebsd-ports-gnome-731b566a6c55593424dd044411e0208eef835c47.zip
BROKEN on 5.x: broken by new ATA driver
-rw-r--r--audio/dagrab/Makefile8
-rw-r--r--audio/xmms-cdread/Makefile8
-rw-r--r--emulators/wine-devel/Makefile4
-rw-r--r--emulators/wine/Makefile4
4 files changed, 22 insertions, 2 deletions
diff --git a/audio/dagrab/Makefile b/audio/dagrab/Makefile
index cfb174f6272c..c6ae02238423 100644
--- a/audio/dagrab/Makefile
+++ b/audio/dagrab/Makefile
@@ -21,4 +21,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dagrab ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/dagrab.1 ${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501106
+BROKEN= "Broken by new ATA driver"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/xmms-cdread/Makefile b/audio/xmms-cdread/Makefile
index 0c5f1f176552..fdeadab26db6 100644
--- a/audio/xmms-cdread/Makefile
+++ b/audio/xmms-cdread/Makefile
@@ -24,4 +24,10 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501106
+BROKEN= "Broken by new ATA driver"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 99c6bea648ed..1316ffd26f9d 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -36,6 +36,10 @@ USE_REINPLACE= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.x"
.endif
+.if ${OSVERSION} >= 501106
+BROKEN= "Broken by new ATA driver"
+.endif
+
.if defined(DEBUG)
STRIP=
.else
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 99c6bea648ed..1316ffd26f9d 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -36,6 +36,10 @@ USE_REINPLACE= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.x"
.endif
+.if ${OSVERSION} >= 501106
+BROKEN= "Broken by new ATA driver"
+.endif
+
.if defined(DEBUG)
STRIP=
.else