aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2007-02-04 01:42:00 +0800
committernobutaka <nobutaka@FreeBSD.org>2007-02-04 01:42:00 +0800
commit735199baf1ae7c37320738e932a5a88b0568a1ab (patch)
treeb9322a5eeb24215d99a6ec5526970031628a30f3
parent5dea52ab663b8e4676a2f3721ffa3442c4ec15f2 (diff)
downloadfreebsd-ports-gnome-735199baf1ae7c37320738e932a5a88b0568a1ab.tar.gz
freebsd-ports-gnome-735199baf1ae7c37320738e932a5a88b0568a1ab.tar.zst
freebsd-ports-gnome-735199baf1ae7c37320738e932a5a88b0568a1ab.zip
Respect PTHREAD_LIBS.
Submitted by: nork
-rw-r--r--www/w3m/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 09e09eea95ae..ab7a9f9fae31 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -93,14 +93,14 @@ CONFIGURE_ARGS+= --enable-keymap=lynx
.if defined(WITH_THREADING)
.if ${OSVERSION} < 502102
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
.else
# Use -lpthread instead of ${PTHREAD_LIBS} to link libpthread
# and libc before libgc.
# This is necessary to avoid build error with boehm-gc with REDIRECT and
# THREADING options.
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lpthread -lc"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/} -lc"
.endif
.else
CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include"