aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-01 06:45:23 +0800
committeredwin <edwin@FreeBSD.org>2003-04-01 06:45:23 +0800
commit73b0b71d1aa7536c6b629310c9842b228a0a3277 (patch)
treec9098327d333668e766372e74f3ac21e71e59af9
parentd47dfe8b78882513b8d7863f50be84ced75d0310 (diff)
downloadfreebsd-ports-gnome-73b0b71d1aa7536c6b629310c9842b228a0a3277.tar.gz
freebsd-ports-gnome-73b0b71d1aa7536c6b629310c9842b228a0a3277.tar.zst
freebsd-ports-gnome-73b0b71d1aa7536c6b629310c9842b228a0a3277.zip
New ports: mail/jamlib
These are a collection of subroutines that encapsulate much of the format-specific and tedious details of the JAM message base format. The idea is that application programmers by using these routines can concentrate on the more high-level issues of their programs instead of worrying about their JAM routines. PR: ports/45467 Submitted by: Cyril Margorin <cyrilm@immo.ru>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/jamlib/Makefile50
-rw-r--r--mail/jamlib/distinfo1
-rw-r--r--mail/jamlib/pkg-descr7
-rw-r--r--mail/jamlib/pkg-plist6
5 files changed, 65 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index e5942359b2f5..b48f6d4730a6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -91,6 +91,7 @@
SUBDIR += imp3
SUBDIR += isoqlog
SUBDIR += isync
+ SUBDIR += jamlib
SUBDIR += junkfilter
SUBDIR += kbiff
SUBDIR += kiltdown
diff --git a/mail/jamlib/Makefile b/mail/jamlib/Makefile
new file mode 100644
index 000000000000..3dd5de8b45f3
--- /dev/null
+++ b/mail/jamlib/Makefile
@@ -0,0 +1,50 @@
+# Ports collection makefile for: jamlib
+# Date created: 14 November 2002
+# Whom: CyrilM <cyrilm@tower.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jamlib
+PORTVERSION= 1.4.6
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jamlib
+
+MAINTAINER= cyrilm@tower.pp.ru
+COMMENT= A JAM subroutine library
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL= yes
+NO_INSTALL_MANPAGES= yes
+INSTALLS_SHLIB= yes
+
+MAN3= JAM_AddEmptyMessage.3 \
+ JAM_AddMessage.3 \
+ JAM_ChangeMsgHeader.3 \
+ JAM_ClearMsgHeader.3 \
+ JAM_CloseMB.3 \
+ JAM_Crc32.3 \
+ JAM_CreateMB.3 \
+ JAM_DelSubPacket.3 \
+ JAM_DeleteMessage.3 \
+ JAM_Errno.3 \
+ JAM_FindUser.3 \
+ JAM_GetMBSize.3 \
+ JAM_GetSubfield.3 \
+ JAM_GetSubfield_R.3 \
+ JAM_LockMB.3 \
+ JAM_NewSubPacket.3 \
+ JAM_OpenMB.3 \
+ JAM_PutSubfield.3 \
+ JAM_ReadLastRead.3 \
+ JAM_ReadMBHeader.3 \
+ JAM_ReadMsgHeader.3 \
+ JAM_ReadMsgText.3 \
+ JAM_RemoveMB.3 \
+ JAM_UnlockMB.3 \
+ JAM_WriteLastRead.3 \
+ JAM_WriteMBHeader.3 \
+ jamlib.3
+
+.include <bsd.port.mk>
diff --git a/mail/jamlib/distinfo b/mail/jamlib/distinfo
new file mode 100644
index 000000000000..fa7fc359c4f9
--- /dev/null
+++ b/mail/jamlib/distinfo
@@ -0,0 +1 @@
+MD5 (jamlib-1.4.6.tar.gz) = 995b84930e0c9c417347fc25842f1005
diff --git a/mail/jamlib/pkg-descr b/mail/jamlib/pkg-descr
new file mode 100644
index 000000000000..8c8c037f5885
--- /dev/null
+++ b/mail/jamlib/pkg-descr
@@ -0,0 +1,7 @@
+These are a collection of subroutines that encapsulate much of the
+format-specific and tedious details of the JAM message base format.
+The idea is that application programmers by using these routines can
+concentrate on the more high-level issues of their programs instead
+of worrying about their JAM routines.
+
+WWW: http://hell.binec.ru/crashecho
diff --git a/mail/jamlib/pkg-plist b/mail/jamlib/pkg-plist
new file mode 100644
index 000000000000..94b7c85d7622
--- /dev/null
+++ b/mail/jamlib/pkg-plist
@@ -0,0 +1,6 @@
+include/jamlib/jam.h
+lib/libjam.so.2
+lib/libjam.so
+lib/libjam.la
+lib/libjam.a
+@dirrm include/jamlib