aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-18 10:36:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-18 10:36:27 +0800
commit73d10a84ea65e51e22d4c41f6caa9255844688d0 (patch)
tree65e62a1c1885feecd8f0a7be59a75a749a4fafe2
parentb5edb82537642a6043967004e61e26c6133f63a1 (diff)
downloadfreebsd-ports-gnome-73d10a84ea65e51e22d4c41f6caa9255844688d0.tar.gz
freebsd-ports-gnome-73d10a84ea65e51e22d4c41f6caa9255844688d0.tar.zst
freebsd-ports-gnome-73d10a84ea65e51e22d4c41f6caa9255844688d0.zip
Fix build with clang/libc++
-rw-r--r--devel/libclaw/Makefile2
-rw-r--r--devel/libclaw/files/patch-claw-impl-box__2d.tpp13
-rw-r--r--devel/libclaw/files/patch-claw-impl-rectangle.tpp11
-rw-r--r--devel/libclaw/files/patch-claw-impl-socket__stream.tpp20
-rw-r--r--games/plee-the-bear/Makefile1
-rw-r--r--games/plee-the-bear/files/patch-bear-engine-core-src-engine-model-code-model__action.cpp11
-rw-r--r--games/plee-the-bear/files/patch-bear-engine-core-src-engine-script-code-script__runner.cpp11
-rw-r--r--games/plee-the-bear/files/patch-plee-the-bear-src-ptb-expr-impl-boolean__player__function.tpp11
8 files changed, 78 insertions, 2 deletions
diff --git a/devel/libclaw/Makefile b/devel/libclaw/Makefile
index 57cd3327e082..d212657796f9 100644
--- a/devel/libclaw/Makefile
+++ b/devel/libclaw/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
USES= cmake gettext
CMAKE_ARGS= -DCLAW_CMAKE_MODULES_INSTALL_PATH="${DATADIR}/cmake"
USE_LDCONFIG= yes
-USE_GCC= yes
+#USE_GCC= yes
post-patch:
@${REINPLACE_CMD} -e '/subdirs/ s|doc||' ${WRKSRC}/CMakeLists.txt
diff --git a/devel/libclaw/files/patch-claw-impl-box__2d.tpp b/devel/libclaw/files/patch-claw-impl-box__2d.tpp
new file mode 100644
index 000000000000..14068036e2af
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-box__2d.tpp
@@ -0,0 +1,13 @@
+--- claw/impl/box_2d.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/box_2d.tpp 2013-09-14 02:59:04.591227299 +0400
+@@ -136,8 +136,8 @@
+ claw::math::box_2d<U> claw::math::box_2d<T>::cast_value_type_to() const
+ {
+ return claw::math::box_2d<U>
+- ( first_point.cast_value_type_to<U>(),
+- second_point.cast_value_type_to<U>() );
++ ( first_point.template cast_value_type_to<U>(),
++ second_point.template cast_value_type_to<U>() );
+ } // box_2d::cast_value_type_to()
+
+ /*----------------------------------------------------------------------------*/
diff --git a/devel/libclaw/files/patch-claw-impl-rectangle.tpp b/devel/libclaw/files/patch-claw-impl-rectangle.tpp
new file mode 100644
index 000000000000..56371294f060
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-rectangle.tpp
@@ -0,0 +1,11 @@
+--- claw/impl/rectangle.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/rectangle.tpp 2013-09-14 02:57:21.105226690 +0400
+@@ -140,7 +140,7 @@
+ claw::math::rectangle<U> claw::math::rectangle<T>::cast_value_type_to() const
+ {
+ return claw::math::rectangle<U>
+- ( position.cast_value_type_to<U>(), (U)width, (U)height );
++ ( position.template cast_value_type_to<U>(), (U)width, (U)height );
+ } // rectangle::cast_value_type_to()
+
+ /*----------------------------------------------------------------------------*/
diff --git a/devel/libclaw/files/patch-claw-impl-socket__stream.tpp b/devel/libclaw/files/patch-claw-impl-socket__stream.tpp
new file mode 100644
index 000000000000..776ceb9429f0
--- /dev/null
+++ b/devel/libclaw/files/patch-claw-impl-socket__stream.tpp
@@ -0,0 +1,20 @@
+--- claw/impl/socket_stream.tpp.orig 2013-07-03 23:34:38.000000000 +0400
++++ claw/impl/socket_stream.tpp 2013-09-14 03:12:49.742226665 +0400
+@@ -37,7 +37,7 @@
+ template<typename CharT, typename Traits>
+ claw::net::basic_socket_stream<CharT, Traits>::basic_socket_stream
+ ( int read_delay )
+- : m_buffer(read_delay)
++ : std::basic_iostream<CharT, Traits>(&m_buffer), m_buffer(read_delay)
+ {
+ this->init(&m_buffer);
+ } // basic_socket_stream::basic_socket_stream()
+@@ -53,7 +53,7 @@
+ template<typename CharT, typename Traits>
+ claw::net::basic_socket_stream<CharT, Traits>::basic_socket_stream
+ ( const char* address, int port, int read_delay )
+- : m_buffer(read_delay)
++ : std::basic_iostream<CharT, Traits>(&m_buffer), m_buffer(read_delay)
+ {
+ this->init(&m_buffer);
+ open(address, port);
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index 3b9723604a82..63f4e1c3a9dc 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -25,7 +25,6 @@ USE_GL= gl glu
WANT_GNOME= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USE_GCC= yes
USES= cmake
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
diff --git a/games/plee-the-bear/files/patch-bear-engine-core-src-engine-model-code-model__action.cpp b/games/plee-the-bear/files/patch-bear-engine-core-src-engine-model-code-model__action.cpp
new file mode 100644
index 000000000000..fff2d9666eb4
--- /dev/null
+++ b/games/plee-the-bear/files/patch-bear-engine-core-src-engine-model-code-model__action.cpp
@@ -0,0 +1,11 @@
+--- bear-engine/core/src/engine/model/code/model_action.cpp.orig 2011-07-17 23:01:25.000000000 +0400
++++ bear-engine/core/src/engine/model/code/model_action.cpp 2013-09-14 03:46:40.203322514 +0400
+@@ -396,7 +396,7 @@
+ bear::engine::model_action::get_snapshot_const_iterator_at
+ ( universe::time_type t ) const
+ {
+- if ( claw::real_number<universe::time_type>(t) > get_duration() )
++ if ( (double)claw::real_number<universe::time_type>(t) > get_duration() )
+ return m_snapshot.end();
+ else if ( m_snapshot.empty() )
+ return m_snapshot.end();
diff --git a/games/plee-the-bear/files/patch-bear-engine-core-src-engine-script-code-script__runner.cpp b/games/plee-the-bear/files/patch-bear-engine-core-src-engine-script-code-script__runner.cpp
new file mode 100644
index 000000000000..1cdd9d32fbaf
--- /dev/null
+++ b/games/plee-the-bear/files/patch-bear-engine-core-src-engine-script-code-script__runner.cpp
@@ -0,0 +1,11 @@
+--- bear-engine/core/src/engine/script/code/script_runner.cpp.orig 2011-07-17 23:01:25.000000000 +0400
++++ bear-engine/core/src/engine/script/code/script_runner.cpp 2013-09-17 23:44:12.620520919 +0400
+@@ -108,7 +108,7 @@
+ bool done(false);
+
+ while ( !done && (m_current_call != m_sequence.end()) )
+- if ( claw::real_number<universe::time_type>(m_current_call->date) > m_date )
++ if ( claw::real_number<universe::time_type>(m_current_call->date) > claw::real_number<universe::time_type>(m_date) )
+ done = true;
+ else
+ {
diff --git a/games/plee-the-bear/files/patch-plee-the-bear-src-ptb-expr-impl-boolean__player__function.tpp b/games/plee-the-bear/files/patch-plee-the-bear-src-ptb-expr-impl-boolean__player__function.tpp
new file mode 100644
index 000000000000..92be3e21aaf5
--- /dev/null
+++ b/games/plee-the-bear/files/patch-plee-the-bear-src-ptb-expr-impl-boolean__player__function.tpp
@@ -0,0 +1,11 @@
+--- plee-the-bear/src/ptb/expr/impl/boolean_player_function.tpp.orig 2011-07-17 23:01:25.000000000 +0400
++++ plee-the-bear/src/ptb/expr/impl/boolean_player_function.tpp 2013-09-18 00:33:39.358695760 +0400
+@@ -37,7 +37,7 @@
+ template<typename FunctionType>
+ ptb::boolean_player_function<FunctionType>::boolean_player_function
+ ( unsigned int player_index, const bear::engine::level_globals* g )
+- : m_player_index(player_index), m_player(NULL), m_level_globals(g)
++ : m_player_index(player_index), m_player(), m_level_globals(g)
+ {
+ search_player();
+ } // boolean_player_function::boolean_player_function()