aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2008-03-09 08:26:01 +0800
committerhq <hq@FreeBSD.org>2008-03-09 08:26:01 +0800
commit778dff8b31df3a47f0da90488042bc912c5c1f3f (patch)
treefabc265e05a1ef5454d59a7e16ab8f2fb809c7f8
parent62fadb120fbaeaa80511abcef46f96a62cbbd4b7 (diff)
downloadfreebsd-ports-gnome-778dff8b31df3a47f0da90488042bc912c5c1f3f.tar.gz
freebsd-ports-gnome-778dff8b31df3a47f0da90488042bc912c5c1f3f.tar.zst
freebsd-ports-gnome-778dff8b31df3a47f0da90488042bc912c5c1f3f.zip
Hudson monitors executions of repeated jobs, such as building a software
project or jobs run by cron. Among those things, current Hudson focuses on the following two jobs: 1. Building/testing software projects continuously, just like CruiseControl or DamageControl. In a nutshell, Hudson provides an easy-to-use so-called continuous integration system, making it easier for developers to integrate changes to the project, and making it easier for users to obtain a fresh build. The automated, continuous build increases the productivity. 2. Monitoring executions of externally-run jobs, such as cron jobs and procmail jobs, even those that are run on a remote machine. For example, with cron, all you receive is regular e-mails that capture the output, and it is up to you to look at them diligently and notice when it broke. Hudson keeps those outputs and makes it easy for you to notice when something is wrong. WWW: https://hudson.dev.java.net/
-rw-r--r--www/Makefile1
-rw-r--r--www/hudson/Makefile31
-rw-r--r--www/hudson/distinfo3
-rw-r--r--www/hudson/pkg-descr17
-rw-r--r--www/hudson/pkg-message7
5 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f28dc57ad685..94a63154e991 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -249,6 +249,7 @@
SUBDIR += httpgrabber
SUBDIR += httptunnel
SUBDIR += httrack
+ SUBDIR += hudson
SUBDIR += hydra
SUBDIR += hypermail
SUBDIR += igal
diff --git a/www/hudson/Makefile b/www/hudson/Makefile
new file mode 100644
index 000000000000..dedb8bd323bd
--- /dev/null
+++ b/www/hudson/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: hudson
+# Date created: 2008-03-08
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hudson
+PORTVERSION= 1.190
+CATEGORIES= www java devel
+MASTER_SITES= https://hudson.dev.java.net/files/documents/2402/88879/
+DISTNAME= hudson
+EXTRACT_SUFX= .war
+EXTRACT_ONLY=
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= An extensible continuous integration engine
+
+RUN_DEPENDS= ${LOCALBASE}/etc/rc.d/tomcat6:${PORTSDIR}/www/tomcat6
+
+NO_BUILD= yes
+
+WEBAPP_SUBDIR= apache-tomcat6.0/webapps
+WEBAPP_DIR= ${PREFIX}/${WEBAPP_SUBDIR}
+
+PLIST_FILES= ${WEBAPP_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WEBAPP_DIR}/
+
+.include <bsd.port.mk>
diff --git a/www/hudson/distinfo b/www/hudson/distinfo
new file mode 100644
index 000000000000..393866208392
--- /dev/null
+++ b/www/hudson/distinfo
@@ -0,0 +1,3 @@
+MD5 (hudson.war) = 8ffe926355af090139334074edef2b61
+SHA256 (hudson.war) = 75f3459e547b6de0a2cc645d3c2d24d5ce9b452db021bfe7be6abd7deac94491
+SIZE (hudson.war) = 17255393
diff --git a/www/hudson/pkg-descr b/www/hudson/pkg-descr
new file mode 100644
index 000000000000..e27e095da95d
--- /dev/null
+++ b/www/hudson/pkg-descr
@@ -0,0 +1,17 @@
+Hudson monitors executions of repeated jobs, such as building a software
+project or jobs run by cron. Among those things, current Hudson focuses on the
+following two jobs:
+
+ 1. Building/testing software projects continuously, just like CruiseControl
+ or DamageControl. In a nutshell, Hudson provides an easy-to-use so-called
+ continuous integration system, making it easier for developers to integrate
+ changes to the project, and making it easier for users to obtain a fresh
+ build. The automated, continuous build increases the productivity.
+
+ 2. Monitoring executions of externally-run jobs, such as cron jobs and
+ procmail jobs, even those that are run on a remote machine. For example, with
+ cron, all you receive is regular e-mails that capture the output, and it is
+ up to you to look at them diligently and notice when it broke. Hudson keeps
+ those outputs and makes it easy for you to notice when something is wrong.
+
+WWW: https://hudson.dev.java.net/
diff --git a/www/hudson/pkg-message b/www/hudson/pkg-message
new file mode 100644
index 000000000000..5662bceca8b6
--- /dev/null
+++ b/www/hudson/pkg-message
@@ -0,0 +1,7 @@
+In order to save configuration and builds, Hudson needs HUDSON_HOME to be
+defined.
+
+For example, to use /home/hudson/ and provided this directory already exists,
+you may add the following to /erc/rc.conf:
+
+tomcat60_java_opts="-DHUDSON_HOME=/home/hudson"