aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-12 13:04:27 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-12 13:04:27 +0800
commit78e7c8edb76a3155e6930af4fdff3ab557a61b2f (patch)
treec434b129e92285a3d7322ddfcd7a1fb6c48299a0
parent93ac338b3ead33c6be1470db13d57f688244b52f (diff)
downloadfreebsd-ports-gnome-78e7c8edb76a3155e6930af4fdff3ab557a61b2f.tar.gz
freebsd-ports-gnome-78e7c8edb76a3155e6930af4fdff3ab557a61b2f.tar.zst
freebsd-ports-gnome-78e7c8edb76a3155e6930af4fdff3ab557a61b2f.zip
RSP plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64-rsp/Makefile46
-rw-r--r--emulators/mupen64-rsp/distinfo2
-rw-r--r--emulators/mupen64-rsp/files/patch-Makefile21
-rw-r--r--emulators/mupen64-rsp/pkg-descr15
-rw-r--r--emulators/mupen64-rsp/pkg-message9
6 files changed, 94 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c3ca3e7f9e5b..76807f1ed92f 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -66,6 +66,7 @@
SUBDIR += mupen64-gln64
SUBDIR += mupen64-input
SUBDIR += mupen64-rice
+ SUBDIR += mupen64-rsp
SUBDIR += osf1_base
SUBDIR += p-interp
SUBDIR += pcemu
diff --git a/emulators/mupen64-rsp/Makefile b/emulators/mupen64-rsp/Makefile
new file mode 100644
index 000000000000..84e0f61959f3
--- /dev/null
+++ b/emulators/mupen64-rsp/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mupen64-rsp
+# Date created: 10.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
+PKGNAMESUFFIX= -rsp
+DISTNAME= hack_azi_rsp_hle
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= RSP plugin for Mupen64
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= mupen64_hle_rsp_azimer
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-rsp/distinfo b/emulators/mupen64-rsp/distinfo
new file mode 100644
index 000000000000..9108c3177eb3
--- /dev/null
+++ b/emulators/mupen64-rsp/distinfo
@@ -0,0 +1,2 @@
+MD5 (hack_azi_rsp_hle.tar.bz2) = 9eb823e0f4a62c8ef0428dabf3f01370
+SIZE (hack_azi_rsp_hle.tar.bz2) = 38268
diff --git a/emulators/mupen64-rsp/files/patch-Makefile b/emulators/mupen64-rsp/files/patch-Makefile
new file mode 100644
index 000000000000..6431c19a6264
--- /dev/null
+++ b/emulators/mupen64-rsp/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Sat Jul 3 18:52:25 2004
++++ Makefile Wed Aug 11 10:53:40 2004
+@@ -1,11 +1,11 @@
+-CC = gcc
+-CFLAGS = -DUSE_GTK `gtk-config --cflags` -O3 -mcpu=athlon \
+- -ffast-math -funroll-loops -fomit-frame-pointer
++#CC = gcc
++#CFLAGS = -DUSE_GTK `gtk-config --cflags` -O3 -mcpu=athlon \
++# -ffast-math -funroll-loops -fomit-frame-pointer
+ #CFLAGS = -DUSE_GTK `gtk-config --cflags` -g -fPIC
+-CXX = g++
+-CXXFLAGS = $(CFLAGS)
+-LD = g++
+-LDFLAGS =
++#CXX = g++
++#CXXFLAGS = $(CFLAGS)
++#LD = g++
++#LDFLAGS =
+
+ TARGET = mupen64_hle_rsp_azimer.so
+ OBJECTS = main.o disasm.o jpeg.o ucode1.o ucode2.o ucode3.o ucode3mp3.o
diff --git a/emulators/mupen64-rsp/pkg-descr b/emulators/mupen64-rsp/pkg-descr
new file mode 100644
index 000000000000..20062e7d53b6
--- /dev/null
+++ b/emulators/mupen64-rsp/pkg-descr
@@ -0,0 +1,15 @@
+RSP plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-rsp/pkg-message b/emulators/mupen64-rsp/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-rsp/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------