aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-01-13 11:38:22 +0800
committerrm <rm@FreeBSD.org>2012-01-13 11:38:22 +0800
commit795595d41a9b235111d57fe03e179376c9f911ed (patch)
tree02e8f1046a8efc1ff0a009ef4f109610cf5e4977
parentf634d804b9c17819f4af6a844552c50fc7fccc33 (diff)
downloadfreebsd-ports-gnome-795595d41a9b235111d57fe03e179376c9f911ed.tar.gz
freebsd-ports-gnome-795595d41a9b235111d57fe03e179376c9f911ed.tar.zst
freebsd-ports-gnome-795595d41a9b235111d57fe03e179376c9f911ed.zip
- let it build with stock gcc
- optionify ipod and mtp support (default on) PR: 164043 Submitted by: Axel Gonzalez <loox at e-shell dot net> Approved by: maintainer
-rw-r--r--audio/clementine-player/Makefile27
-rw-r--r--audio/clementine-player/files/patch-src-devices-cddadevice.h15
-rw-r--r--audio/clementine-player/files/patch-src-devices-cddalister.cpp16
3 files changed, 45 insertions, 13 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 1dd59059e362..531482675ae5 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clementine
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -player
@@ -19,13 +20,8 @@ LICENSE= GPLv3
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
notify.4:${PORTSDIR}/devel/libnotify \
xine.1:${PORTSDIR}/multimedia/libxine \
- mtp.11:${PORTSDIR}/audio/libmtp \
- usbmuxd.1:${PORTSDIR}/comms/usbmuxd \
- imobiledevice.1:${PORTSDIR}/comms/libimobiledevice \
- gpod.7:${PORTSDIR}/audio/libgpod \
qjson.0:${PORTSDIR}/devel/qjson
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
- chrpath:${PORTSDIR}/devel/chrpath
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
PROJECTHOST= ${PORTNAME}${PKGNAMESUFFIX}
@@ -35,17 +31,17 @@ USE_GL= glew
USE_QT_VER= 4
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build \
linguist_build network sql opengl dbus qtestlib corelib
-USE_GCC= 4.6+
+USE_GCC= 4.2+
INSTALLS_ICONS= yes
USE_GSTREAMER= gio ogg mp3 flac soup vorbis
MAKE_JOBS_UNSAFE= yes
-GCC_LIBS= "${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}"
-CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib" \
- -DCMAKE_SKIP_RPATH:BOOL=ON
+CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib"
OPTIONS= VISUALISATION "Visualisations from projectM" off \
- LASTFM "Support Last.fm service (requires ruby)" on
+ LASTFM "Support Last.fm service (requires ruby)" on \
+ GPOD "iPod support" on \
+ MTP "MTP device support" on
.include <bsd.port.pre.mk>
@@ -60,7 +56,12 @@ PLIST_SUB+= VSL="@comment "
LIB_DEPENDS+= lastfm.0:${PORTSDIR}/audio/liblastfm
.endif
-post-build:
- ${LOCALBASE}/bin/chrpath -r "${GCC_LIBS}" "${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}"
+.if defined(WITH_GPOD)
+LIB_DEPENDS+= gpod.7:${PORTSDIR}/audio/libgpod
+.endif
+
+.if defined(WITH_MTP)
+LIB_DEPENDS+= mtp.11:${PORTSDIR}/audio/libmtp
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/clementine-player/files/patch-src-devices-cddadevice.h b/audio/clementine-player/files/patch-src-devices-cddadevice.h
new file mode 100644
index 000000000000..bdf7ce8d24e6
--- /dev/null
+++ b/audio/clementine-player/files/patch-src-devices-cddadevice.h
@@ -0,0 +1,15 @@
+--- src/devices/cddadevice.h.orig 2012-01-11 22:39:56.000000000 -0600
++++ src/devices/cddadevice.h 2012-01-11 22:40:33.000000000 -0600
+@@ -18,10 +18,10 @@
+ #ifndef CDDADEVICE_H
+ #define CDDADEVICE_H
+
+-#include <cdio/cdio.h>
+-#include <gst/cdda/gstcddabasesrc.h>
+ #include <QMutex>
+
++#include <cdio/cdio.h>
++#include <gst/cdda/gstcddabasesrc.h>
+ #include "connecteddevice.h"
+ #include "core/song.h"
+ #include "musicbrainz/musicbrainzclient.h"
diff --git a/audio/clementine-player/files/patch-src-devices-cddalister.cpp b/audio/clementine-player/files/patch-src-devices-cddalister.cpp
new file mode 100644
index 000000000000..934092a3683e
--- /dev/null
+++ b/audio/clementine-player/files/patch-src-devices-cddalister.cpp
@@ -0,0 +1,16 @@
+--- src/devices/cddalister.cpp.orig 2012-01-11 22:39:03.000000000 -0600
++++ src/devices/cddalister.cpp 2012-01-11 22:39:22.000000000 -0600
+@@ -15,12 +15,12 @@
+ along with Clementine. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+-#include <cdio/cdio.h>
+ #include <QFileInfo>
+ #include <QMutex>
+ #include <QThread>
+ #include <QWaitCondition>
+
++#include <cdio/cdio.h>
+ #include "cddalister.h"
+ #include "core/logging.h"
+ #include "core/song.h"