aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-02-23 00:23:29 +0800
committerdinoex <dinoex@FreeBSD.org>2009-02-23 00:23:29 +0800
commit7a34b38d41354ccc597f37e15e14da5dada74c00 (patch)
tree80c055eaa34568c55ebda3a3de01004e6460d3af
parent667f7aece5f3acfc6ca96552ad768674016c5251 (diff)
downloadfreebsd-ports-gnome-7a34b38d41354ccc597f37e15e14da5dada74c00.tar.gz
freebsd-ports-gnome-7a34b38d41354ccc597f37e15e14da5dada74c00.tar.zst
freebsd-ports-gnome-7a34b38d41354ccc597f37e15e14da5dada74c00.zip
- convert for USE_TK, USE_TCL
-rw-r--r--deskutils/abacus/Makefile6
-rw-r--r--irc/zircon/Makefile11
2 files changed, 7 insertions, 10 deletions
diff --git a/deskutils/abacus/Makefile b/deskutils/abacus/Makefile
index cc9108322d9f..45b4d4d15455 100644
--- a/deskutils/abacus/Makefile
+++ b/deskutils/abacus/Makefile
@@ -18,11 +18,11 @@ PATCHFILES= ${PORTNAME}-${PORTVERSION}.patch.gz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Spread sheet for X Window System
-LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
- tk82.1:${PORTSDIR}/x11-toolkits/tk82
-
USE_GMAKE= yes
USE_XORG= x11
+USE_TK= 82
+USE_TCL= 82
+
MAKE_ENV= LDFLAGS="${LDFLAGS}"
CFLAGS+= -I$(LOCALBASE)/include \
-I$(LOCALBASE)/include/tcl8.2 \
diff --git a/irc/zircon/Makefile b/irc/zircon/Makefile
index 6c904950aab6..a7ef543de4c9 100644
--- a/irc/zircon/Makefile
+++ b/irc/zircon/Makefile
@@ -19,17 +19,14 @@ COMMENT= An X11 interface to Internet Relay Chat
# zircon will start with tk84, but a lot of functions won't work
# a lot of variable names conflicts with new functions.
.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+USE_TK= 84
+USE_TCL= 84
.else
-RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+USE_TK= 83
+USE_TCL= 83
.endif
NO_BUILD= yes
-.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
-TCL_VER= 8.4
-.else
-TCL_VER= 8.3
-.endif
do-configure:
${REINPLACE_CMD} -e 's=%%WISH%%=wish${TCL_VER}=' \